it doesn't receive the focus when unhide

Bug #1649810 reported by brisssou on 2016-12-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Terminator
Undecided
Unassigned

Bug Description

Hello, this issue https://bugs.launchpad.net/terminator/+bug/805870 is back with the new gtk3 version

Ubuntu 16.04
terminator bzr 1683

When I unhide terminator using custom keybinding (<shift>F1 here) it does not gain focus.

Please find attached a terminator -d log where I opened terminator, move the window, hide/unhide it 2 times, click on it, <CTRL>+d to exit.

brisssou (brice-laurencin) wrote :
brisssou (brice-laurencin) wrote :

Here is my config file.

Stephen Boddy (stephen-j-boddy) wrote :

The following bug may have inadvertently led to a fix for a number of issues with focus and window z-order when opening new windows and unhiding a hidden one.

https://bugs.launchpad.net/terminator/+bug/1501128

Please retest revision 1715, and report if this bug is still reproducible.

Changed in terminator:
status: New → Incomplete
brisssou (brice-laurencin) wrote :

The bug remains, and the fix does not work anymore.

Stephen Boddy (stephen-j-boddy) wrote :

Do you mean the fix doesn't apply as a patch? Because the revision 1715 I refer to in #4 is effectively committing the fix that you refer to in #3 as working. So I don't see how it stops working just because I put it into the tree.

http://bazaar.launchpad.net/~gnome-terminator/terminator/gtk3/revision/1715

Stephen Boddy (stephen-j-boddy) wrote :

Oh stuff! I should get my eyes checked! I missed part of the patch :-D

New fix coming in 3... 2... 1...

Stephen Boddy (stephen-j-boddy) wrote :

Committed revision 1717.

Please test and let me know!

brisssou (brice-laurencin) wrote :

great success!!

Thanks a lot!

Changed in terminator:
status: Incomplete → Fix Committed
Changed in terminator:
milestone: none → 2.0
Changed in terminator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers