(gtk3-only) Issues with HighContrast mode

Bug #1494980 reported by Stephen Boddy on 2015-09-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Terminator
High
Stephen Boddy

Bug Description

Steps:
    Open a window
    Create a new Tab
    Split into 2x2
    Assign two to the same group, one to to a different group, one with no group
    Use prefs to activate Profile, Colours, Use colours from system theme
    Use GNOME settings, Appearance, Theme to switch to HighContrast
Actual result:
    Tab bars become quite chunky
    Titlebar loses a couple of vertical pixels of height
    Titlebar background only works over the group button, title is all white
    \Titles are invisible for broadcast and receiving terminals because text is white on white
    Need to open and close Preferences (causes reconfigure), or restart Terminator for vte widget to pick up the high contrast.
Expected result:
    Slimmer tabs? They match Nautilus, but are bigger than Prefs, GEdit, and GNOME Terminal
    Titlebar should not chop of vertical pixels
    Titlebar background should be as per Global swatches in Prefs
    \Titlebars will be visible when background fixed
    Theme change should be detected and responded to by vte widget.

Related branches

tags: added: gtk3
description: updated
Changed in terminator:
assignee: nobody → Skymathrix (asstaroid)
status: Triaged → Confirmed
Changed in terminator:
assignee: Skymathrix (asstaroid) → Stephen Boddy (stephen-j-boddy)
status: Confirmed → Triaged
Stephen Boddy (stephen-j-boddy) wrote :

Going to mark this as fixed now. The recent transparency and themeing work fixed the most serious of the issues with HighContrast. We'll leave the fine tuning to those that need it, and they can submit patches to tweak if necessary.

Changed in terminator:
status: Triaged → Fix Committed
Changed in terminator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers