logger plugin data loss with full screen apps

Bug #1477386 reported by James Harvey on 2015-07-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Terminator
Undecided
Unassigned

Bug Description

Terminator r1573. (I'm the guy on KDE, so someone will need to verify if this happens on GNOME.)

* Start logger, save as "~/loggertest"
* ls -la ~/
* vi foo <--> no need to save, this is just to bring up something full screen
* ls -la ~/
* Stop logger

For me, "~/loggertest" logged the first "ls -la ~/", but not the second. And, it has an extra few hundred to few thousand blank lines at the end.

I never get a good log with a full screen app, but it's corruption of the log does vary. Sometimes I get the numerous blank lines, sometimes not. Sometimes missing data is way further up from when the full screen went active. Sometimes it saves a snapshot of the full screen app (I think I've only seen the state upon first load, before any changes) at the bottom after a lot of blank lines. Sometimes there's lines missing before the full screen app is ran.

A hopefully easy workaround would be to implement an "export buffer to file" command, separate from the logger plugin. Ideally, it would be great for this new feature and for logger to work with full screen apps... But I'm not sure how easy "fixing" logger would be.

The "export buffer to file" would be at someone's risk of not having everything in the session, if they don't run unlimited scrollback history.

Other possibility might be for the logger plugin to "mark" the spot it starts at, and when the shell ends or the user stops logger, to grab everything from that point in the scrollback, to avoid having to "watch" for full screen mode. Maybe if there was a pending grab by logger it would temporarily leave the scrollback go past where the limit would be otherwise.

Re-writing of the same line seems to work fine, like progress meters on downloads.

Stephen Boddy (stephen-j-boddy) wrote :

Hi Bug subscribers, this is the maintainer (Steve Boddy) of Terminator, who took over from Chris.

In case you were not aware there has been a new release 0.98 of Terminator in the last few days which has many changes, fixes and updates. We also have an ongoing GTK3 port which uses a much more up-to-date libvte.

Even with the ~50 issues closed by that release, and discounting the ~90 outstanding wishlist items, we still have an unwieldy 95 bugs. With the oldest approaching it's 6th birthday and some that haven't seen any updates in nearly 5, it is time for a purge.

My intention is to try and get this list down to a minimum, and for that I need your help.

First I'm going to work through, oldest to newest, setting bugs to Incomplete, pending confirmation that they are still an issue. If after a month there is no feedback, the issue will get closed as Invalid. Here's where you come in. I can't always reproduce, or setting up (i.e. other distros) to even test takes a long time, so I'm going to try crowdsourcing this.

1. Get the latest release. Is it still an issue? If yes, set the confirmed-0.98 tag. For bonus points follow the guide http://gnometerminator.blogspot.com/2015/09/so-you-want-to-try-terminator-gtk3.html and see if the GTK3 branch has same issue, and set the confirmed-gtk3 or notaffected-gtk3 tag.

2. Can you reproduce with an empty/default config file? You can pass "-g temp_config" to do this without affecting your existing config. If you already have Terminator running, you'll need to pass -u as well to disable the DBus.

3. If able to, can you reproduce with another user/guest account?

4. If the issue does not already have clear, precise instructions to reproduce with minimal setup/steps, add them.

5. Put as much info about what you are running.
   * Software/library versions (libvte, gtk, pango, cairo, distro, desktop environment, language)
   * Screens (single or multi)
   * Any unusual / custom packages or configs that might be interacting.

6. If possible attach the config file, unless the issue also happens with an empty one, but mention that.

7. Attach the "-d" debug output from 0.98.

Some common things that cause incidents.

* Strange sizing issues or rapidly shrinking windows - Try turning off Window geometry hints.
* Input (esp. broadcasting duplicate chars etc) problems - Try killing IBus.
* Hand editing of the config file can cause various issues - Due to misunderstanding, incorrect structure or typos.
* Some issues are actually in libvte - This is why testing GTK3 is so important.
* segfaults - Unfortunately these are dying inside the C libraries, and it is usually beyond me to fix those.

Many thanks for your assistance, and hopefully this will get us closer to a bug-free Terminator.

Changed in terminator:
status: New → Incomplete
Stephen Boddy (stephen-j-boddy) wrote :

Old bug, codebase has moved on a lot, and I can't reproduce. Also OP never returned to bug.

Marking as Invalid/no-response.

tags: added: no-response
Changed in terminator:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers