terminator does not show italic fonts

Bug #1287794 reported by Matthias on 2014-03-04
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Terminator
Wishlist
Unassigned

Bug Description

It looks like terminator does not deal with italics. For example running this:

    echo -e "\e[3m foo \e[23m"

produces the string without italics. When run in gnomer-terminal it does show italics.

Not sure if this is a bug/known issue (couldn't find one) or a feature request.

Related branches

Stephen Boddy (stephen-j-boddy) wrote :

Hmmm. I can't see italics in either Terminator or Gnome-Terminal. Either way I'm pretty sure this is related to the embedded vte widget both programs use, and probably isn't something fixable within Terminator.

I'm using:
Ubuntu 12.04 LTS,
Terminator 0.97 (uses gtk 2 and vte 0.28.2)
GNOME Terminal 3.4.1.1 (uses gtk 3 and vte 0.32.1)

Changed in terminator:
status: New → Incomplete
Stephen Boddy (stephen-j-boddy) wrote :

Perhaps I should have added on the end there that you should respond with the versions that you are using. I suspect you are using a newer libvte which is why Gnome-Terminal gives you italics. Updating Terminator to the latest libvte is a huge job that no one has volunteered to do so far.

From vte changes for 0.34.1:
commit ad68297cb8792c5f2927ccac44014507ff310da2
Author: Patrick Niklaus <email address hidden>
Date: Fri Oct 5 01:40:28 2012 +0200

    emulation: Support italic text

    The escape sequence SGR 3 for italic text is now recognised and supported.

    https://bugzilla.gnome.org/show_bug.cgi?id=685223

Changed in terminator:
importance: Undecided → Wishlist
milestone: none → 2.0
Sparhawk (sparhawkthesecond) wrote :

I see this as well. Using the OP's code, italics work in gnome-terminal (and KDE's konsole), whereas they do not in terminator. I'm not sure how to work out which vte a terminal uses, but when I installed gnome-terminal to test, it also pulled vte3 0.38.3.

pi-rho (pi-rho) wrote :

if gnome-terminal does italic on that vte3, then terminator should too in my opinion.

Changed in terminator:
status: Incomplete → Confirmed
pi-rho (pi-rho) wrote :

Ubuntu 14.04 terminator uses python-vte 1:0.28.2-5ubuntu1
whereas gnome-terminal uses libvte-2.90-9 1:0.34.9-1ubuntu1 directly

My mistake. Please ignore my previous comment.

Stephen Boddy (stephen-j-boddy) wrote :

The GTK3 port of Terminator (still in fixup mode, but testable) does support italics escape codes.

https://code.launchpad.net/~gnome-terminator/terminator/gtk3

Note that running this is only advised for tinkerers, and people looking to contribute to get GTK3 release ready. Don't use it for important work.

Stephen Boddy (stephen-j-boddy) wrote :

I should add that the GTK2 Terminator will almost certainly never support italics, because the libvte developers are no longer touching it.

I think I'll stick this to Fix committed (because it is for gtk3) and when we get GTK3 released, then to Fix released.

Stephen Boddy (stephen-j-boddy) wrote :

But later. Just remembered there is a cleanup to happen on the bugs marking the 0.98 release committeds to released. Don't want to accidentally mark this released.

Sparhawk (sparhawkthesecond) wrote :

Oh wow… I'm looking forward to seeing this! This is the only feature that I miss in Terminator. Thanks for the update!

Setting to committed as the release bug cleanup has happened.

@Sparhawk: see http://gnometerminator.blogspot.com/2015/09/so-you-want-to-try-terminator-gtk3.html if you want to try using GTK3 as your daily driver. It's slowly plodding along to fully fixed, and ready to go.

Changed in terminator:
status: Confirmed → Fix Committed
Sparhawk (sparhawkthesecond) wrote :

Thanks Stephen! I'm using Arch Linux, so there's already a package available in the AUR [1]. Are you suggesting that it's fairly stable now? I'm happy to give it a shot if it's "close" to stable… :)

[1] https://aur.archlinux.org/packages/terminator-gtk3-bzr/

Sparhawk, I'm not too sure about that version. If that revision is accurate, then there are quite a lot of fixes/improvements missing from it. The Arch package says it is r1561, while the GTK3 branch is now at r1612, so 50 revisions. 14 of those are translations, but that still means 36 missing items. You'd have to look through those to see if there was something you really wanted.

It's as stable as Schroedingers cat. Until it is observed, it's status is indeterminate. (Plus, bear in mind that GTK2 Terminator has technically never had a "stable" release :-)

To give you an idea of where I *think* we are, these are the three known outstanding bugs that are unique to GTK3: https://bugs.launchpad.net/terminator/+bugs?field.tag=gtk3

Other outstanding items on my list for the GTK3 to be ready for an alpha release are:

Outstanding GTK3 port tasks/items/reviews etc.
==============================================
Outstanding trunk revisions: 1634 & 1637, 1647 (assuming all is good), 1663

Need to go through all the Gtk.STOCK_* items and remove. Deprecated in 3.10. Very low priority as won't be problem till 4.0.
Homogeneous_tabbar removed? Why?
terminal.py:on_vte_size_allocate, check for self.vte.window missing. Consequences?
terminal.py:understand diff in args between old fork and new spawn of bash. Consequences?
VERIFY(8)/FIXME(6) FOR GTK3 items to be dealt with

Sparhawk (sparhawkthesecond) wrote :

Okay, that sounds close enough to me. I'll try to kill the cat. :)

(Also, Arch version-control PKGBUILDs automatically install the latest revision. I don't know why they do it like that, but the listed version number must be a *previous* version in the tree. So even though the package version says r1561, it installed r1612 for me.)

Update: I use terminator as a drop-down terminal. This doesn't appear to work. I've filed a new bug: https://bugs.launchpad.net/terminator/+bug/1501128

OK, and it looks like you are already posting autopsy details so, good stuff!

The info on Arch is good to know. I was a bit concerned they'd jumped the gun and I'd be getting out of date reports.

Sparhawk (sparhawkthesecond) wrote :

They don't call Arch "bleeding edge" for nothing! :p

Changed in terminator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.