Terminator hangs on running 'exit' in Cinnamon

Bug #1285275 reported by terdon on 2014-02-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Terminator
Undecided
Unassigned

Bug Description

Sometimes, with no pattern I can discern, running `exit` fails to close a terminator window running in the Cinnamon desktop environment. The same thing happens whether using Ctrl + D, or running 'exit' manually. You can see an animated gif showing the problem in my post here: http://unix.stackexchange.com/q/117089/22222

Expected result:

  Both Ctrl + D and 'exit' should close the terminator window

Observed behavior:

  Sometimes, not always, a terminator window will refuse to close and hangs at:

    $ exit

Details:

1. This happens sometimes, not always, and I can see no pattern. In the gif attached, it is the 2nd terminal, sometimes it is the first or the Nth.

2. The same thing happens whether I run `exit` manually or hit <kbd>Ctrl</kbd> + <kbd>D</kbd>.

3. I have a shortcut key mapped to `terminator` in my DE's (Cinnamon) keyboard settings. The problem only occurs when launching with this shortcut. It does not seem to ever happen if I launch by running `terminator` manually.

4. It seems to be exclusive to terminator, neither xterm not gnome-terminal display this problem if I assign the same keyboard shortcut to them instead.

5. It happens irrespective of what keyboard shortcut I use (I tried using Ctrl + O instead of the Alt + Z I normally use) and had the same issue

6. It seems to be specific to Cinnamon, I tried on Mate and xfce and it worked fine.

7. Started happening after I updated my system (Linux Mint Debian Edition) to update pack 8 (see http://blog.linuxmint.com/?p=2544). Note that the updated pack did not upgrade my cinnamon version itself as that had already been updated. However, the update replaced various gnome libs with their cinnamon equivalents, I am guessing there might be an incompatibility there.

8. This only happens if the shortcut is defined in Cinnamon's keyboard settings. Using the same shortcut through xbindkeys works as expected (is a decent workaround in fact, see here for details on how to use it: http://unix.stackexchange.com/a/91433/22222)

9. The same behavior occurs if I use the terminator version downloaded with bzr branch lp:terminator

I'm afraid I can't attach the terminator -d output because I can't capture stderr from within the keyboard shortcut command (2>/tmp/foo breaks the shortcut).

System details:
LMDE, update pack 8
Cinnamon version 2.0.14
terminator version 0.97

Stephen Boddy (stephen-j-boddy) wrote :

Hi Bug subscribers, this is the maintainer (Steve Boddy) of Terminator, who took over from Chris.

In case you were not aware there has been a new release 0.98 of Terminator in the last few days which has many changes, fixes and updates. We also have an ongoing GTK3 port which uses a much more up-to-date libvte.

Even with the ~50 issues closed by that release, and discounting the ~90 outstanding wishlist items, we still have an unwieldy 95 bugs. With the oldest approaching it's 6th birthday and some that haven't seen any updates in nearly 5, it is time for a purge.

My intention is to try and get this list down to a minimum, and for that I need your help.

First I'm going to work through, oldest to newest, setting bugs to Incomplete, pending confirmation that they are still an issue. If after a month there is no feedback, the issue will get closed as Invalid. Here's where you come in. I can't always reproduce, or setting up (i.e. other distros) to even test takes a long time, so I'm going to try crowdsourcing this.

1. Get the latest release. Is it still an issue? If yes, set the confirmed-0.98 tag. For bonus points follow the guide http://gnometerminator.blogspot.com/2015/09/so-you-want-to-try-terminator-gtk3.html and see if the GTK3 branch has same issue, and set the confirmed-gtk3 or notaffected-gtk3 tag.

2. Can you reproduce with an empty/default config file? You can pass "-g temp_config" to do this without affecting your existing config. If you already have Terminator running, you'll need to pass -u as well to disable the DBus.

3. If able to, can you reproduce with another user/guest account?

4. If the issue does not already have clear, precise instructions to reproduce with minimal setup/steps, add them.

5. Put as much info about what you are running.
   * Software/library versions (libvte, gtk, pango, cairo, distro, desktop environment, language)
   * Screens (single or multi)
   * Any unusual / custom packages or configs that might be interacting.

6. If possible attach the config file, unless the issue also happens with an empty one, but mention that.

7. Attach the "-d" debug output from 0.98.

Some common things that cause incidents.

* Strange sizing issues or rapidly shrinking windows - Try turning off Window geometry hints.
* Input (esp. broadcasting duplicate chars etc) problems - Try killing IBus.
* Hand editing of the config file can cause various issues - Due to misunderstanding, incorrect structure or typos.
* Some issues are actually in libvte - This is why testing GTK3 is so important.
* segfaults - Unfortunately these are dying inside the C libraries, and it is usually beyond me to fix those.

Many thanks for your assistance, and hopefully this will get us closer to a bug-free Terminator.

Changed in terminator:
status: New → Incomplete
terdon (terdon) wrote :

Thanks for looking into this. I have since found that it works OK if I don't call it by setting a shortcut in the DE (Cinnamon) itself but instead set one using xbindkeys. I haven't had this issue since I stopped launching terminator through Cinnamon's shortcut system. This would suggest the bug has little to do with terminator itself and more to do with some particular idiosyncrasy of my system or DE.

So, I think it's safe to close this bug since it was probably never caused by terminator itself.

Changed in terminator:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers