Tempest unit testing for python 3.6|7 are blocked

Bug #1975036 reported by Ghanshyam Mann
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tempest
Fix Released
Critical
Ghanshyam Mann

Bug Description

Tempest python 3.6 and 3.7 unit test jobs are failing and blocked as oslo.log (same for other oslo lib) 5.0.0 dropped the py3.6|7(which is a valid drop).

Requirement constraints are updated to oslo.log===5.0.0 and caused Tempest py3.6|7 jobs to fail.
- https://review.opendev.org/c/openstack/requirements/+/842477

-https://zuul.opendev.org/t/openstack/build/2ae5c1b3bdb745ec8b13cbd452599e44

/home/zuul/src/opendev.org/openstack/tempest/.tox/py37/lib/python3.7/site-packages/pip/_vendor/packaging/version.py:114: DeprecationWarning: Creating a LegacyVersion has been deprecated and will be removed in the next major release
  DeprecationWarning,
ERROR: Cannot install oslo.log>=3.36.0 because these package versions have conflicting dependencies.

The conflict is caused by:
    The user requested oslo.log>=3.36.0
    The user requested (constraint) oslo-log===5.0.0

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

Changed in tempest:
importance: Undecided → Critical
assignee: nobody → Ghanshyam Mann (ghanshyammann)
status: New → Confirmed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to tempest (master)

Related fix proposed to branch: master
Review: https://review.opendev.org/c/openstack/tempest/+/842821

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tempest (master)

Fix proposed to branch: master
Review: https://review.opendev.org/c/openstack/tempest/+/843182

Changed in tempest:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to tempest (master)

Reviewed: https://review.opendev.org/c/openstack/tempest/+/842821
Committed: https://opendev.org/openstack/tempest/commit/b1ea4327108cbbd518dfc75482dff79493b4edc9
Submitter: "Zuul (22348)"
Branch: master

commit b1ea4327108cbbd518dfc75482dff79493b4edc9
Author: Ghanshyam Mann <email address hidden>
Date: Fri May 20 20:09:01 2022 -0500

    Unblock gate to temporary remove the py3.6|7 job

    py3.6 and py3.7 jobs are failing due to oslo dropped the
    py3.6|7 support. We will add them back once bug#1975036
    is resolved

    Tempest plugin sanity job is broken due to failure in
    murano-tempest-plugin. To make this patch merge which
    will unblock the gate, I am making plugin sanity job as
    non voting. We will revert that once below fix is merged

    tempest-full-centos-9-stream job is also failing which fix
    is also up and waiting for this patch to merge first, so making
    them non voting.

    devstack-plugin-ceph-tempest-py3 job is also mostly failing, let's
    make it temporarily non voting in order to avoid endless rechecks

    - https://review.opendev.org/c/openstack/murano-tempest-plugin/+/843040

    Related-Bug: #1975036
    Change-Id: Ibcaf1bce80521e05d76199ddebccb33488360644

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tempest (master)

Reviewed: https://review.opendev.org/c/openstack/tempest/+/843182
Committed: https://opendev.org/openstack/tempest/commit/87661fcef73ef502f7cdc70c4e0eabfd898db642
Submitter: "Zuul (22348)"
Branch: master

commit 87661fcef73ef502f7cdc70c4e0eabfd898db642
Author: Ghanshyam Mann <email address hidden>
Date: Sat May 28 19:00:24 2022 -0500

    Drop py3.6 and py3.7 from Tempest

    In zed cycle, OpenStack projects and oslo lib
    has dropped the py3.6 and py3.7 support

    - https://governance.openstack.org/tc/reference/runtimes/zed.html

    With oslo not supporting the py3.6 and py3.7, Tempest master is
    failing and cannot be run on py3.6|7 env.

    - https://bugs.launchpad.net/tempest/+bug/1975036

    We discussed about how to solve it in ML[1] and QA meeting[2] and
    decided to drop it from Tempest too. Stable branches testing from
    stable/victoria to stable/yoga (currently supported branch by Tempest
    master) can be tested on py3.8 or if cloud run those releases on py3.6
    then Tempest can be run in virtual env with py38.

    Closes-Bug: #1975036

    [1] http://lists.openstack.org/pipermail/openstack-discuss/2022-May/028622.html
    [2] https://meetings.opendev.org/irclogs/%23openstack-qa/%23openstack-qa.2022-05-24.log.html#t2022-05-24T15:31:51

    Change-Id: Ie844887a798a006794729e733748ceaa5e06d2db

Changed in tempest:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tempest ussuri-last

This issue was fixed in the openstack/tempest ussuri-last release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers