tempest.api.compute.servers.test_attach_interfaces.AttachInterfacesTestJSON failing in the gate lately

Bug #1796882 reported by Daniel Alvarez on 2018-10-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
networking-ovn
High
Unassigned
tempest
Undecided
Unassigned

Bug Description

This test is failing more than usual in the gate.

http://status.openstack.org/openstack-health/#/test/tempest.api.compute.servers.test_attach_interfaces.AttachInterfacesTestJSON.test_reassign_port_between_servers?duration=P1M

Looks like something merged on October 3th that made it failing more often.

Daniel Alvarez (dalvarezs) wrote :

This patch got merged on October the 3rd touching that test:
https://review.openstack.org/#/c/600046/

This test went from 60 seconds to 120 seconds after the patch got merged. We have few failures since then.

Changed in networking-ovn:
importance: Undecided → High
status: New → Confirmed

Logstash also shows [0][1] that after the patch [2] got merged this error became more common. It doesn't seem to affect only networking-ovn. From what I could see in the logs networking-odl, dragonflow and potential others have also been affected.

[0] https://i.imgur.com/BudrVKf.png
[1] http://logstash.openstack.org/#/dashboard/file/logstash.json?query=message:%5C%22test_reassign_port_between_servers%5C%22%20AND%20tags:screen-q-svc.txt (filter for 30d+)
[2] https://review.openstack.org/#/c/600046/

Changed in networking-ovn:
assignee: nobody → Lucas Alvares Gomes (lucasagomes)

The fix should go to tempest, here's a patch in networking-ovn testing the tempest change: https://review.openstack.org/#/c/609033/ (works)

Changed in networking-ovn:
status: Confirmed → Invalid
Changed in networking-ovn:
status: Invalid → New
Changed in networking-ovn:
status: New → In Progress

Reviewed: https://review.openstack.org/609032
Committed: https://git.openstack.org/cgit/openstack/tempest/commit/?id=692422babfb76ff2cea216877185a86eecf946e2
Submitter: Zuul
Branch: master

commit 692422babfb76ff2cea216877185a86eecf946e2
Author: Lucas Alvares Gomes <email address hidden>
Date: Wed Oct 10 10:33:45 2018 +0100

    Use remote_client from tempest.lib.common instead of tempest.common

    This patch is replacing the test_attach_interfaces.py module to use the
    RemoteClient from tempest.lib.common instead of tempest.common. Due to
    the saner defaults from the new class tests such
    "test_reassign_port_between_servers" is less prone to fail (see related
    bug).

    Also, this patch intentionally does not attempt to replace every
    occurence of tempest.common.utils.linux.remote_client with its
    counter-part in tempest.lib because that would require porting
    some of the methods that exists in the old class to the new one.
    The focus of this patch is to address the problem described in
    the related bug.

    Related-Bug: #1796882
    Change-Id: I07bde710581270766f049c7147246971fed6cd91

Change abandoned by Lucas Alvares Gomes (<email address hidden>) on branch: master
Review: https://review.openstack.org/609732
Reason: Not needed anymore

Changed in networking-ovn:
assignee: Lucas Alvares Gomes (lucasagomes) → nobody
Changed in networking-ovn:
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers