Tests in tempest.api.network.test_routers.RoutersTest don't clean up network resources

Bug #1670693 reported by Itzik Brown
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tempest
Fix Released
Low
Deepak Mourya

Bug Description

Tests in tempest.api.network.test_routers create networks but don't remove them when each test is finished.
Cleanup only occurs after all the tests in RoutersTest finish to run.

Changed in tempest:
importance: Undecided → Low
Revision history for this message
Jordan Pittier (jordan-pittier) wrote :

Indeed. The correct fix is to remove all the class fixture with per-test-resource and use self.addCleanup(...)

Changed in tempest:
status: New → Confirmed
Duc Truong (dkt26111)
Changed in tempest:
assignee: nobody → Duc (dkt26111)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tempest (master)

Fix proposed to branch: master
Review: https://review.openstack.org/468547

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on tempest (master)

Change abandoned by Duc (<email address hidden>) on branch: master
Review: https://review.openstack.org/468547
Reason: Incorrect Topic. Will resubmit with correct topic.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tempest (master)

Fix proposed to branch: master
Review: https://review.openstack.org/468551

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on tempest (master)

Change abandoned by Duc Truong (<email address hidden>) on branch: master
Review: https://review.openstack.org/468551

Duc Truong (dkt26111)
Changed in tempest:
assignee: Duc Truong (dkt26111) → nobody
Changed in tempest:
assignee: nobody → Deepak Mourya (mourya007)
Revision history for this message
Deepak Mourya (mourya007) wrote :
Revision history for this message
Deepak Mourya (mourya007) wrote :
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tempest 19.0.0

This issue was fixed in the openstack/tempest 19.0.0 release.

Revision history for this message
Doug Schveninger (ds6901) wrote :

https://review.openstack.org/#/c/572015/ fixed and the bug should be placed into a final state.

Changed in tempest:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers