verify_tempest_config.py: verify_api_versions can't get versions of glance and not check api_v3 for cinder

Bug #1611771 reported by Nikita Gerasimov on 2016-08-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tempest
Undecided
Nikita Gerasimov

Bug Description

tempest/cmd/verify_tempest_config.py

Function verify_glance_api_versions doesn't receive supported glance api versions and set both to False consonantly.

Function verify_cinder_api_versions doesn't check cinder api_v3. Only v1 and v2.

Fix proposed to branch: master
Review: https://review.openstack.org/353504

Changed in tempest:
assignee: nobody → Nikita Gerasimov (nikita-gerasimov)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/353522

Reviewed: https://review.openstack.org/353522
Committed: https://git.openstack.org/cgit/openstack/tempest/commit/?id=3b169cca35f1335da92f7f44a1a0c9a09e887219
Submitter: Jenkins
Branch: master

commit 3b169cca35f1335da92f7f44a1a0c9a09e887219
Author: Nikita Gerasimov <email address hidden>
Date: Wed Aug 10 17:10:42 2016 +0300

    Adds to verify_cinder_api_versions api_v3 check

    Change-Id: I5953c111127dfb332e4952fa48e3ceb04fb6bb98
    Partial-Bug: 1611771

Reviewed: https://review.openstack.org/353504
Committed: https://git.openstack.org/cgit/openstack/tempest/commit/?id=ff865d625cbb70e858034b06fa494cafc381cd49
Submitter: Jenkins
Branch: master

commit ff865d625cbb70e858034b06fa494cafc381cd49
Author: Nikita Gerasimov <email address hidden>
Date: Wed Aug 10 16:44:24 2016 +0300

    Fix of verify_glance_api_versions

    verify_glance_api_versions was used .get_versions() method which is
    work correctly only for RestClient and not applicable to child with
    defined property api_version. Now it's switched to _get_api_versions
    method.

    Change-Id: Ie5e7b384d3a661f22b3f1d16ffca2beeb41de954
    Partial-Bug: 1611771

Changed in tempest:
status: In Progress → Fix Committed
Changed in tempest:
status: Fix Committed → In Progress
Ken'ichi Ohmichi (oomichi) wrote :

This bug seems fixed already since https://review.openstack.org/#/c/353504/2

Changed in tempest:
status: In Progress → Fix Released
Changed in tempest:
status: Fix Released → Confirmed
Changed in tempest:
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers