test_connectivity_between_vms_on_different_networks doesn't work on OVH

Bug #1610994 reported by Sean Dague on 2016-08-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tempest
Medium
Unassigned

Bug Description

If guests actually have a working outbound route (like is added in the new neutron default patch for devstack), this test fails on OVH cloud because that cloud appears to be reflecting packets in some odd ways.

Full discussion here - http://lists.openstack.org/pipermail/openstack-dev/2016-August/100888.html

Reviewed: https://review.openstack.org/352463
Committed: https://git.openstack.org/cgit/openstack/tempest/commit/?id=17487fb9e8c2e1188df427dc4ab4eda5314b330b
Submitter: Jenkins
Branch: master

commit 17487fb9e8c2e1188df427dc4ab4eda5314b330b
Author: Sean Dague <email address hidden>
Date: Mon Aug 8 10:44:20 2016 -0400

    skip test_connectivity_between_vms_on_different_networks

    This test doesn't work on OVH if we make it so that created guests
    actually have the ability to talk to external networks. We're not
    really sure why, but having guests be able to talk to external
    networks is quite important from a devstack neutron default
    perspective.

    This is temporary so that we can move forward with the devstack switch
    over to neutron, and we can figure out what needs to be addressed to
    fix the bug in question.

    Depends-On: Ia75068dcf36dff548170c0fa5482ca825f5a9758
    (requirements fix)

    Change-Id: Ia07cd8d8d88d445420f881df6aca4a77cf9468fb
    Related-Bug: #1610994

Masayuki Igawa (igawa) on 2016-11-17
Changed in tempest:
status: New → Triaged
importance: Undecided → Medium
chandan kumar (chkumar246) wrote :

As the changes is merged. https://review.openstack.org/#/c/352463/ We need to change the status.

Changed in tempest:
status: Triaged → Fix Released
Masayuki Igawa (igawa) wrote :

hmm, was this bug really fixed? I think https://review.openstack.org/#/c/352463/ is just a workaround, not fix.

Masayuki Igawa (igawa) on 2017-01-26
Changed in tempest:
status: Fix Released → Triaged

I've just pushed up https://review.openstack.org/#/c/617023/ for a bug that we've been seeing during our testing. If the port is DOWN when _get_server_port_id_and_ip4 runs then the test will immediately fail. This allows _get_server_port_id_and_ip4 to wait for the port to change state and then updates the status. Would you mind testing this out, it may fix your issue as well as it looks very similar to what I was seeing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers