NetworksTest tries to call create_network() in a static way

Bug #1179938 reported by Jordan Pittier on 2013-05-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tempest
Undecided
Unassigned

Bug Description

nosetests tempest/tests/network fails with the following stack trace :

======================================================================
ERROR: test suite for <class 'tempest.tests.network.test_networks.NetworksTest'>
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/nose/suite.py", line 208, in run
    self.setUp()
  File "/usr/lib/python2.7/dist-packages/nose/suite.py", line 291, in setUp
    self.setupContext(ancestor)
  File "/usr/lib/python2.7/dist-packages/nose/suite.py", line 314, in setupContext
    try_run(context, names)
  File "/usr/lib/python2.7/dist-packages/nose/util.py", line 478, in try_run
    return func()
  File "/opt/stack/tempest/tempest/tests/network/test_networks.py", line 29, in setUpClass
    cls.network = cls.create_network()
TypeError: unbound method create_network() must be called with NetworksTest instance as first argument (got nothing instead)

create_network defined in BaseNetworkTest can't be called statically.

Jordan Pittier (jordan-pittier) wrote :

This bug affects only the grizzly branch. The problem is that tempest tries to use the old Quantum API (v1.1) which is deprecated and removed from the code base. This commit https://github.com/openstack/tempest/commit/cc939612b3aaff0acbe51e2175cd39b9c080f858 solves my issue but I would love to see it backported in the Grizzly branch.

ATM, the tempest branch is broken regarding network test

Nathan Biles (npbiles) wrote :

We're hitting this bug too:

  File "/usr/lib/python2.6/site-packages/nose/suite.py", line 208, in run
    self.setUp()
  File "/usr/lib/python2.6/site-packages/nose/suite.py", line 291, in setUp
    self.setupContext(ancestor)
  File "/usr/lib/python2.6/site-packages/nose/suite.py", line 314, in setupContext
    try_run(context, names)
  File "/usr/lib/python2.6/site-packages/nose/util.py", line 469, in try_run
    return func()
  File "/tmp/tempest/tempest/tempest/tests/network/test_networks.py", line 29, in setUpClass
    cls.network = cls.create_network()
unbound method create_network() must be called with NetworksTest instance as first argument (got nothing instead)

Nathan Biles (npbiles) wrote :

I'm testing using quantum with openvswitch and tempest is configured with

# Version of the Quantum API
api_version = v2.0

Nathan Biles (npbiles) wrote :

Actually I'm hitting the same error in master (testing with havana)

Jordan Pittier (jordan-pittier) wrote :

@Matt, thanks. I cherrypicked this patch on a grizzly branche, it applies well and works.

@Nathan Even with this patch, a lot of network related tests fail because of this : https://bugs.launchpad.net/nova/+bug/1160309

tags: added: grizzly-backport-potential
Attila Fazekas (afazekas) wrote :

Is it completely fixed ?

Jordan Pittier (jordan-pittier) wrote :

I believe it is. I just have to wait that my distro packages 2013.1.2 to be sure but the patch mentionned in #5 has been merged in grizzly and when I cherrypicked a few weeks ago it solved this issue.

Sean Dague (sdague) on 2013-06-05
Changed in tempest:
status: New → Fix Released
milestone: none → havana-2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers