test_list_server_filters is broken

Bug #1059568 reported by David Kranz on 2012-10-01
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tempest
High
Matthew Treinish

Bug Description

Due bug https://bugs.launchpad.net/tempest/+bug/1059565, this test is not being run by the tempest gating job. The error is:

======================================================================
ERROR: test suite for <class 'tempest.tests.compute.test_list_server_filters.ListServerFiltersTestXML'>
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/nose/suite.py", line 208, in run
    self.setUp()
  File "/usr/local/lib/python2.7/dist-packages/nose/suite.py", line 291, in setUp
    self.setupContext(ancestor)
  File "/usr/local/lib/python2.7/dist-packages/nose/suite.py", line 314, in setupContext
    try_run(context, names)
  File "/usr/local/lib/python2.7/dist-packages/nose/util.py", line 478, in try_run
    return func()
  File "/root/tempest/tempest/tests/compute/test_list_server_filters.py", line 224, in setUpClass
    super(ListServerFiltersTestXML, cls).setUpClass()
  File "/root/tempest/tempest/tests/compute/base.py", line 218, in setUpClass
    super(BaseComputeTestXML, cls).setUpClass()
  File "/root/tempest/tempest/tests/compute/base.py", line 46, in setUpClass
    creds = cls._get_isolated_creds()
  File "/root/tempest/tempest/tests/compute/base.py", line 108, in _get_isolated_creds
    tenant = admin_client.get_tenant_by_name(tenant_name)
AttributeError: 'AdminClientXML' object has no attribute 'get_tenant_by_name'

This test is also producing other erroneous output such as:

-------------------- >> begin captured logging << --------------------
tempest.common.rest_client: ERROR: Request URL: http://172.18.1.168:35357/v2.0/tenants
tempest.common.rest_client: ERROR: Request Body: {"tenant": {"enabled": "true", "name": "ListServerFiltersTestJSON-tenant", "description": "ListServerFiltersTestJSON-tenant-desc"}}
tempest.common.rest_client: ERROR: Response Headers: {'date': 'Fri, 28 Sep 2012 18:51:28 GMT', 'transfer-encoding': 'chunked', 'status': '409', 'content-type': 'application/json', 'vary': 'X-Auth-Token'}
tempest.common.rest_client: ERROR: Response Body: {u'error': {u'message': u'Conflict occurred attempting to store tenant. (IntegrityError) (1062, "Duplicate entry \'ListServerFiltersTestJSON-tenant\' for key \'name\'")', u'code': 409, u'title': u'Conflict'}}
tempest.tests.compute.base: INFO: Re-using existing tenant {u'id': u'aee286d60f8c40a6abeaaabb9592cf89', u'enabled': u'true', u'description': u'ListServerFiltersTestJSON-tenant-desc', u'name': u'ListServerFiltersTestJSON-tenant'}
tempest.common.rest_client: ERROR: Request URL: http://172.18.1.168:35357/v2.0/users
tempest.common.rest_client: ERROR: Request Body: {"user": {"email": "<email address hidden>", "password": "pass", "name": "ListServerFiltersTestJSON-user", "tenantId": "aee286d60f8c40a6abeaaabb9592cf89"}}
tempest.common.rest_client: ERROR: Response Headers: {'date': 'Fri, 28 Sep 2012 18:51:28 GMT', 'transfer-encoding': 'chunked', 'status': '409', 'content-type': 'application/json', 'vary': 'X-Auth-Token'}
tempest.common.rest_client: ERROR: Response Body: {u'error': {u'message': u'Conflict occurred attempting to store user. (IntegrityError) (1062, "Duplicate entry \'ListServerFiltersTestJSON-user\' for key \'name\'")', u'code': 409, u'title': u'Conflict'}}
tempest.tests.compute.base: INFO: Re-using existing user {u'tenantId': u'aee286d60f8c40a6abeaaabb9592cf89', u'id': u'461cd7e0c7b94a138cd9b97bd1f5ff9d', u'name': u'ListServerFiltersTestJSON-user', u'email': <email address hidden>'}
--------------------- >> end captured logging << ---------------------

Changed in tempest:
importance: Undecided → High
David Kranz (david-kranz) wrote :

The errors here seem to be because this test does not clean up the isolated tenants and users created. The test is actually being completely skipped but when it was XMLized theses issues may have crept in.

David Kranz (david-kranz) wrote :

I moved the skip to the JSON/XML classes to work around part of this.

Changed in tempest:
assignee: nobody → Mauro Sergio Martins Rodrigues (maurosr)
Changed in tempest:
assignee: Mauro Sergio Martins Rodrigues (maurosr) → nobody
assignee: nobody → Mauro Sergio Martins Rodrigues (maurosr)
Changed in tempest:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/19233

Changed in tempest:
assignee: Mauro Sergio Martins Rodrigues (maurosr) → Matthew Treinish (treinish)
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/19403

Fix proposed to branch: master
Review: https://review.openstack.org/19429

Reviewed: https://review.openstack.org/19233
Committed: http://github.com/openstack/tempest/commit/bf41e103c3bc3a158a63135d627933dcb0ecb2e8
Submitter: Jenkins
Branch: master

commit bf41e103c3bc3a158a63135d627933dcb0ecb2e8
Author: Matthew Treinish <email address hidden>
Date: Tue Jan 8 15:56:28 2013 -0500

    Add missing methods to xml admin_client.

    This adds methods missing from the xml version of the identity
    admin client. These methods are needed by some of the tests in
    test_list_server_filters.

    Partially fixes bug 1059568

    Change-Id: Iec0fd7ff49de78b9681ccfa27963393aff248b5f

Changed in tempest:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/19403
Committed: http://github.com/openstack/tempest/commit/4e1b3e6451a09273f5a9d23a4f1089c8c3bdde15
Submitter: Jenkins
Branch: master

commit 4e1b3e6451a09273f5a9d23a4f1089c8c3bdde15
Author: Matthew Treinish <email address hidden>
Date: Thu Jan 10 11:30:49 2013 -0500

    Fix list images xml deserialization.

    Partially fixes bug 1059568

    Change-Id: I17f88ca89e089e1f4dc85f785e60f1e08b9f5b39

Reviewed: https://review.openstack.org/19429
Committed: http://github.com/openstack/tempest/commit/6b4fe65923782aeca31185bee3947cf47f0d973a
Submitter: Jenkins
Branch: master

commit 6b4fe65923782aeca31185bee3947cf47f0d973a
Author: Matthew Treinish <email address hidden>
Date: Thu Jan 10 16:58:51 2013 -0500

    Remove skip from Server Filters Tests.

    Re-enable the servers filters tests.

    Fixes bug 1059568

    Change-Id: I4c1eacdc5f2a076fb98ab03b9db1bbf1297767c5

Sean Dague (sdague) on 2013-09-23
Changed in tempest:
milestone: none → havana-3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers