[mako] phone calls back automatically

Bug #1226739 reported by Omer Akram on 2013-09-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
telepathy-ofono
In Progress
Critical
Tiago Salem Herrmann
pulseaudio (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned
telepathy-ofono (Ubuntu)
Critical
Tiago Salem Herrmann
Saucy
Critical
Tiago Salem Herrmann

Bug Description

Once you reproduce bug 1226298 all you have to do is call the Ubuntu phone another time.

When Ubuntu Phone goes into a state that it does not show any notifications for Call try to ring Ubuntu phone once more from another phone and disconnect the call. Now wait you will get a call back from the Ubuntu phone.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ofono 1.12-0ubuntu8
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.1-0ubuntu4
Architecture: armhf
Date: Tue Sep 17 17:50:20 2013
InstallationDate: Installed on 2013-09-16 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20130916.3)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: ofono
UpgradeStatus: No upgrade log present (probably fresh install)

Omer Akram (om26er) wrote :
Changed in ofono (Ubuntu):
importance: Undecided → Critical
affects: ofono → telephony-service
affects: ofono (Ubuntu) → telephony-service (Ubuntu)
Changed in telephony-service:
importance: Undecided → Critical
Omer Akram (om26er) wrote :

Automatic call back is a critical issue.

Changed in telephony-service (Ubuntu):
assignee: nobody → Gustavo Pichorim Boiko (boiko)
status: New → Confirmed
Tony Espy (awe) wrote :

As this requires the phone to get into a jammed state ( see bug #1226298 ) as a prerequisite, should this really be considered a Critical bug?

Also, I've tried to reproduce this to no avail with mako running this morning's build ( ie. cdimage-touch --wipe --pending ), I'm suspecting this might be related to settings associated with the SIM card used.

I will try again, but we should get some independent confirmation that this is real. AFAIK, Omer is the only person who's managed to reproduce this behavior.

Please refer to the description of the 'monitor-ofono' script mentioned in bug #1226298. It's output would be most helpful in debugging this problem.

Pat McGowan (pat-mcgowan) wrote :

I have reproduced this on mako with the 16.3 build

Call the ubuntu phone, ring a couple times, hang up
repeat this until the ubuntu phone does not ring, and may or may not not show the notification
call again, let ring, then hangup
wait 10-60 seconds and ubuntu phone will call

note I never touch the ubuntu phone and control the calls from my other mobile
this will happen if the dialer app is running or not

Pat McGowan (pat-mcgowan) wrote :

Another note, I make the subsequent calls very quickly after hanging up

I can get this to happen every time in 2 to 4 calls.

Nicholas Skaggs (nskaggs) wrote :

I was not able to recreate this at all.. I couldn't get the phone in a jammed state (where calls didn't register) and never experienced a callback. This was using touch_ro image 916.1

Tony Espy (awe) wrote :

I managed to reproduce this with yesterday's build on my mako.

I spent some time yesterday afternoon debugging. In order to catch if the dialback was caused by the upper layers, I decided to try and snoop on DBus 'Dial' calls to the ofono's VoiceCallManager interface. In order to snoop these calls, I needed to create a file drop a fail named '99-eavesdrop.conf' into /etc/dbus-1/system.d ( and reboot ):

root@ubuntu-phablet:/etc/dbus-1/system.d# more 99-eavesdrop.conf
<!DOCTYPE busconfig PUBLIC
"-//freedesktop//DTD D-Bus Bus Configuration 1.0//EN"
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
<policy context="default">
  <allow send_destination="*" eavesdrop="true"/>
  <!-- Allow everything to be received -->
  <allow eavesdrop="true"/>
</policy>
</busconfig>

Once added, I can snoop the calls with this command:

# dbus-monitor --system "type='method_call',interface=org.ofono.VoiceCallManager"

I also ran the ofono script 'monitor-ofono' to watch ofono signals in a seperate window. For each incoming call, I'm seeing the expected "CallAdded" signal. And, as expected ( by me at least ), when the auto-callback happens, I see a 'Dial' method call:

method call sender=:1.41 -> dest=org.ofono serial=112 path=/ril_0; interface=org.ofono.VoiceCallManager; member=Dial
   string "6174480627"
   string ""

So, I suspect something is happening in telepathy-ofono, or telepathy itself to trigger this behavior.

Changed in telephony-service (Ubuntu Saucy):
assignee: Gustavo Pichorim Boiko (boiko) → Tiago Salem Herrmann (tiagosh)
Changed in telephony-service:
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Tony Espy (awe) wrote :

A further update. I cannot reproduce bug #1226298 on maguro. I tried again with today's image and made ~50 incoming calls and couldn't get the OSD to fail.

So, as I'd installed today's image on maguro, I installed the same on mako to be sure the bug hadn't been fixed in today's build.

It took me couple of tries to reproduce the callback scenario. The first two times I tried, I would just VoiceCallManager method calls "GetProperties" and "GetCalls" after which the OSD would work again. The third failure re-produced the auto-callback scenario and produced a DBus method call to "Dial" ( see above ).

summary: - Ubuntu phone calls back automatically
+ [mako] phone calls back automatically

I have tried more than 20 times and cannot reproduce the issue on maguro.
So yes it seems specific to mako

On Thu, Sep 19, 2013 at 12:52 AM, Tony Espy <email address hidden>wrote:

> A further update. I cannot reproduce bug #1226298 on maguro. I tried
> again with today's image and made ~50 incoming calls and couldn't get
> the OSD to fail.
>
> So, as I'd installed today's image on maguro, I installed the same on
> mako to be sure the bug hadn't been fixed in today's build.
>
> It took me couple of tries to reproduce the callback scenario. The
> first two times I tried, I would just VoiceCallManager method calls
> "GetProperties" and "GetCalls" after which the OSD would work again.
> The third failure re-produced the auto-callback scenario and produced a
> DBus method call to "Dial" ( see above ).
>
>
> ** Summary changed:
>
> - Ubuntu phone calls back automatically
> + [mako] phone calls back automatically
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1226739
>
> Title:
> [mako] phone calls back automatically
>
> Status in Telephony Service:
> New
> Status in “telephony-service” package in Ubuntu:
> Confirmed
> Status in “telephony-service” source package in Saucy:
> Confirmed
>
> Bug description:
> Once you reproduce bug 1226298 all you have to do is call the Ubuntu
> phone another time.
>
> When Ubuntu Phone goes into a state that it does not show any
> notifications for Call try to ring Ubuntu phone once more from another
> phone and disconnect the call. Now wait you will get a call back from
> the Ubuntu phone.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: ofono 1.12-0ubuntu8
> Uname: Linux 3.4.0-3-mako armv7l
> ApportVersion: 2.12.1-0ubuntu4
> Architecture: armhf
> Date: Tue Sep 17 17:50:20 2013
> InstallationDate: Installed on 2013-09-16 (0 days ago)
> InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf
> (20130916.3)
> MarkForUpload: True
> ProcEnviron:
> TERM=linux
> PATH=(custom, no user)
> SourcePackage: ofono
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/telephony-service/+bug/1226739/+subscriptions
>

Julien Funk (jaboing) on 2013-09-19
tags: added: jfunk-20130918
Changed in telephony-service:
status: New → In Progress
Tiago Salem Herrmann (tiagosh) wrote :

So the problem seems to be related to telephathy-ofono getting stuck when trying to change the audio route. (Can't even reply to a dbus introspection at that time).
That causes a timing problem internally in telepathy-ofono, and by the time it gets unlocked the call in ofono is already gone, so tp-ofono assumes that is actually an outgoing call and will dial the number back by mistake.

Other bugs (like #1226298) are probably related, as telepathy-ofono is stuck and can't notify other telepathy components about the new channel (incoming call).

Tony Espy (awe) wrote :

Fixes have been committed for pulseaudio and telepathy-ofono for bug #1226298, which also fix this bug.

affects: telephony-service (Ubuntu Saucy) → telepathy-ofono (Ubuntu Saucy)
affects: telephony-service → telephony-ofono
Changed in telepathy-ofono (Ubuntu Saucy):
status: Confirmed → Fix Committed
Changed in pulseaudio (Ubuntu Saucy):
status: New → Fix Committed
Changed in telepathy-ofono (Ubuntu Saucy):
status: Fix Committed → Fix Released
Changed in pulseaudio (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers