telepathy-butterfly crashed with TypeError: _on_session_completed() takes exactly 3 arguments (2 given)

Bug #735815 reported by Mauricio Pretto
150
This bug affects 18 people
Affects Status Importance Assigned to Milestone
telepathy-butterfly
Confirmed
Medium
papyon (Ubuntu)
Medium
Ken VanDine
Natty
Undecided
Unassigned

Bug Description

Binary package hint: telepathy-butterfly

;

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: telepathy-butterfly 0.5.15-1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
Architecture: amd64
Date: Tue Mar 15 20:16:54 2011
ExecutablePath: /usr/lib/telepathy/telepathy-butterfly
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/lib/telepathy/telepathy-butterfly
ProcEnviron:
 SHELL=/bin/bash
 LC_MESSAGES=en_GB.UTF-8
 LANGUAGE=en_GB:en
 LANG=pt_BR.UTF-8
PythonArgs: ['/usr/lib/telepathy/telepathy-butterfly']
SourcePackage: telepathy-butterfly
Title: telepathy-butterfly crashed with TypeError: _on_session_completed() takes exactly 3 arguments (2 given)
Traceback: TypeError: _on_session_completed() takes exactly 3 arguments (2 given)
UpgradeStatus: Upgraded to natty on 2011-03-09 (6 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
Mauricio Pretto (pretto) wrote :
tags: removed: need-duplicate-check
Revision history for this message
Jack Leigh (leighman) wrote :

Got this when starting Empathy just after login

Changed in telepathy-butterfly (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Changed in telepathy-butterfly (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
visibility: private → public
Revision history for this message
Pedro Villavicencio (pedro) wrote :
Changed in telepathy-butterfly:
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Ken , may you have a look to this bug? it's appearing everytime you log in to MSN. Thanks!.

Changed in telepathy-butterfly (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
affects: telepathy-butterfly (Ubuntu) → papyon (Ubuntu)
Changed in papyon (Ubuntu):
status: Triaged → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package papyon - 0.5.5-1ubuntu2

---------------
papyon (0.5.5-1ubuntu2) oneiric; urgency=low

  * papyon/p2p.py
    - Use the correct callback for rejected sessions (LP: #735815)
 -- Ken VanDine <email address hidden> Fri, 13 May 2011 15:34:12 +0200

Changed in papyon (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Ken VanDine (ken-vandine) wrote :

This one is going to be tricky to test, the root cause was failed login sessions (not wrong password) was calling the on_session_complete function instead of on_session_rejected function.

So someone that was having a failed login before, if it works with the proposed update, that is probably the best verification we can get.

I did have Pedro test this fix, and it worked for him.

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted papyon into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in papyon (Ubuntu Natty):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Mauricio Pretto (pretto) wrote :

seems fixed to me.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Just for the record , this is also working fine for me, I've testing the package that Ken provided me since UDS and didn't noticed any regression with it.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package papyon - 0.5.5-1ubuntu1.2

---------------
papyon (0.5.5-1ubuntu1.2) natty-proposed; urgency=low

  * papyon/p2p.py
    - Use the correct callback for rejected sessions (LP: #735815)

papyon (0.5.5-1ubuntu1.1) natty-proposed; urgency=low

  * papyon/msnp/notification.py:
    - Papyon doesn't answer server's pings. (LP: #768974)
 -- Ken VanDine <email address hidden> Fri, 13 May 2011 15:34:12 +0200

Changed in papyon (Ubuntu Natty):
status: Fix Committed → Fix Released
Revision history for this message
Barry Warsaw (barry) wrote :

Ken, can you double check whether this patch is still necessary in Precise? If not, then we can do a straight up sync to Debian's 0.5.5-2, otherwise we'll have to merge it. All the other Ubuntu deltas have been merged in Debian afaict.

Revision history for this message
Barry Warsaw (barry) wrote :

Actually, I think the patch is still relevant.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.