telepathy-butterfly crashed with TypeError in _send_chunk()

Bug #629501 reported by Benjamim Gois on 2010-09-03
82
This bug affects 12 people
Affects Status Importance Assigned to Milestone
telepathy-butterfly
Fix Released
Medium
telepathy-butterfly (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: telepathy-butterfly

It just stop working

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: telepathy-butterfly 0.5.13-1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
Architecture: amd64
Date: Fri Sep 3 10:16:03 2010
ExecutablePath: /usr/lib/telepathy/telepathy-butterfly
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/telepathy/telepathy-butterfly
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=pt_BR:pt:en
 LANG=pt_BR.utf8
PythonArgs: ['/usr/lib/telepathy/telepathy-butterfly']
SourcePackage: telepathy-butterfly
Title: telepathy-butterfly crashed with TypeError in _send_chunk()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

How does it work with WLM ? wouldn't it take the GUIDs from the JOI on the SB? or just send without the GUID and then use the GUID it receives in the response?
also, how could it be version 2 and peer_guid is None? what is the deciding factor? I thought that it should be :
if peer_guid is None:
   version = 1
else:
   version = 2

am I wrong ?

(In reply to comment #1)
> How does it work with WLM ? wouldn't it take the GUIDs from the JOI on the SB?
> or just send without the GUID and then use the GUID it receives in the
> response?
> also, how could it be version 2 and peer_guid is None? what is the deciding
> factor? I thought that it should be :
> if peer_guid is None:
> version = 1
> else:
> version = 2
>
> am I wrong ?

yesterday i had a brief look at the code with lfrb, and he said he thinks the endpoint list isn't ready yet, so i guess papyon is updating this list with UBXs (i didn't have time to check the code) and this bug is sort of a race condition where this list isn't updated yet and the p2p transfer is started (because i am starting the p2p transfer as soon as i receive the dp-changed signal that comes with NLNs).

Benjamim Gois (benjamim-gois) wrote :

Binary package hint: telepathy-butterfly

It just stop working

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: telepathy-butterfly 0.5.13-1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
Architecture: amd64
Date: Fri Sep 3 10:16:03 2010
ExecutablePath: /usr/lib/telepathy/telepathy-butterfly
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/telepathy/telepathy-butterfly
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=pt_BR:pt:en
 LANG=pt_BR.utf8
PythonArgs: ['/usr/lib/telepathy/telepathy-butterfly']
SourcePackage: telepathy-butterfly
Title: telepathy-butterfly crashed with TypeError in _send_chunk()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Benjamim Gois (benjamim-gois) wrote :
tags: removed: need-duplicate-check

*** Bug 30163 has been marked as a duplicate of this bug. ***

visibility: private → public
Changed in telepathy-butterfly (Ubuntu):
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugs.freedesktop.org/show_bug.cgi?id=30163

Changed in telepathy-butterfly (Ubuntu):
status: New → Triaged
Changed in telepathy-butterfly:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in telepathy-butterfly:
importance: Medium → Unknown
Changed in telepathy-butterfly:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.