Long press on photo will enter the preview mode

Bug #1604272 reported by Jin on 2016-07-19
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Telegram app
Critical
Unassigned

Bug Description

Description:
Telegram enters the photo preview mode after long pressed on the photo.

Reproduce Steps:
    a) Launch Telegram
    b) Enter the dialog which has attachment: photo
    c) Long press on the photo to enable multi-selection mode
    d) Observe the current mode
    e) Click back key to return back to dialog
    f) Observe the current mode and the multi-selection check box

Expected Result:
1. Telegram needs to enter the preview mode after short-click on the photo
2. Telegram needs to enter multi-selection mode directly after long-press on the photo

Actual Result:
Telegram does nothing after short click on the photo,
and enters preview mode after the photo long pressed.

Occurrence:
10/10 (100%)

Software Information:
    com.ubuntu.telegram (2.2.26.0)

Hardware Information:
    current build number: 484
    device name: mako
    channel: ubuntu-touch/rc-proposed/ubuntu
    last update: 2016-07-13 04:21:31
    version version: 484
    version ubuntu: 20160712
    version device: 20160401.1
    version custom: 20160712

Related branches

Jin (jindallo) on 2016-07-19
Changed in telegram-app:
status: New → Confirmed
importance: Undecided → High
milestone: none → m33
Jin (jindallo) wrote :

Set this bug as critical since it is a regression.

Changed in telegram-app:
importance: High → Medium
importance: Medium → Critical
Jin (jindallo) on 2016-08-31
Changed in telegram-app:
assignee: nobody → Jin (jin.cth)
Jin (jindallo) wrote :
Changed in telegram-app:
status: Confirmed → In Progress
Emanuele Sorce (tronfortytwo) wrote :

Affect me too. I'm on an aquaris E5, on the rc channel

Jin (jindallo) wrote :

Bug fixed,
and verified pass on developer side.

The change list is submitted as rev. 228,
below is the detail information.
    http://bazaar.launchpad.net/~libqtelegram-team/telegram-app/telegram/revision/228

Device Information:
    current build number: 824
    device name: krillin
    channel: ubuntu-touch/rc-proposed/bq-aquaris.en-proposed
    last update: 2016-09-02 14:17:00
    version version: 824
    version ubuntu: 20160901
    version device: 20160606-ab415b2
    version custom: 20160831-991-38-18

Changed in telegram-app:
status: In Progress → Fix Committed
Jin (jindallo) on 2016-11-21
Changed in telegram-app:
status: Fix Committed → Fix Released
assignee: Jin (jin.cth) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers