Adding contact from address book failed

Bug #1600706 reported by Jin on 2016-07-11
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Telegram app
Critical
Unassigned

Bug Description

Description:
Telegram returns to the IntroPage after contact added from address book.

Reproduce Steps:
    a) Launch Telegram
    b) Select "Contacts" in settings
    c) Press the button in top right to add the contact
    d) Select "From Address Book" to add contact
    e) Choose "Contacts" to select the one you want to import
    f) Check the contact information in Telegram then click the tick
    g) Observe the Telegram UI

Expected Result:
Telegram needs to import the contact properly,
and return to the main view (AccountListPage).

Actual Result:
Telegram returns to the start page (IntroPage).

Occurrence:
10/10 (100%)

Software Information:
    com.ubuntu.telegram (2.2.26.0)

Hardware Information:
    current build number: 480
    device name: mako
    channel: ubuntu-touch/rc-proposed/ubuntu
    last update: 2016-07-07 11:36:27
    version version: 480
    version ubuntu: 20160706.1
    version device: 20160401.1
    version custom: 20160706.1

Related branches

Jin (jindallo) on 2016-07-11
description: updated
description: updated
Changed in telegram-app:
milestone: none → m33
Devid Antonio Filoni (d.filoni) wrote :

I think this regression was introduced in commit 209, as per AccountListItem.qml file changes history, looks like that commit partially reverted commit 130. PHONE_NUMBER_INVALID error is triggered also when an invalid phone (or a valid one without country code) is added as contact, the described issue doesn't happen when a valid phone number (with country code) is added.

Emanuele Sorce (tronfortytwo) wrote :

happen also to me on my bq E5

Jin (jindallo) on 2016-11-01
Changed in telegram-app:
status: Confirmed → In Progress
Jin (jindallo) wrote :

Bug fixed,
and verified pass on developer side.

The change list is submitted as rev. 243,
below is the detail information.
    http://bazaar.launchpad.net/~libqtelegram-team/telegram-app/telegram/revision/243

Device Information:
    current build number: 862
    device name: krillin
    channel: ubuntu-touch/rc-proposed/bq-aquaris.en-proposed
    last update: 2016-10-27 14:57:07
    version version: 862
    version ubuntu: 20161027
    version device: 20160606-ab415b2
    version custom: 20160831-991-38-18
    version custom: 20160408.3

Changed in telegram-app:
assignee: nobody → Devid Antonio Filoni (d.filoni)
status: In Progress → Fix Committed
assignee: Devid Antonio Filoni (d.filoni) → Jin (jin.cth)
Jin (jindallo) on 2016-11-21
Changed in telegram-app:
status: Fix Committed → Fix Released
assignee: Jin (jin.cth) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers