Application shows a broken page "Please select chat" after notification clicked

Bug #1599030 reported by Jin on 2016-07-05
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Telegram app
Critical
Unassigned

Bug Description

Description:
Telegram goes to a page "Please select chat" after clicked the notification.

Reproduce Steps:
    a) Launch Telegram
    b) Enter a chat to see the messages with the contact
    c) Switch the application to background
    d) Click the Telegram message notification on Ubuntu Touch unity panel
    e) Observe the Telegram view

Expected Result:
It turns to the messages dialog view of the contact who mentioned in notification.

Actual Result:
Telegram shows a page "Please select chat".

Occurrence:
10/10 (100%)

Software Information:
    com.ubuntu.telegram (2.2.26.0)

Related branches

Jin (jindallo) wrote :
Changed in telegram-app:
status: New → Confirmed
importance: Undecided → Critical
milestone: none → m32
Jin (jindallo) wrote :

This issue could not be reproduced when the app is not running yet,
but when the app is running already in background, it's broken.

Ash (ashley-richards) on 2016-07-06
Changed in telegram-app:
assignee: nobody → Ash (ashley-richards)
Ash (ashley-richards) wrote :

After various of testing. It can only be reproduced if you have never chatted to the other user before. Otherwise you do not see this error.

1. Clear chat history with the other device.
2. Go into group chat (that has the other device in).
3. Tap the avatar and send a message.
4. Background Telegram.
5. The other device sends message back.
6. Tap on the Push Notification received.
7. 'Please Select Chat' error appears.

Changed in telegram-app:
status: Confirmed → In Progress
Jin (jindallo) wrote :

Bug fixed,
and verified pass on developer side.

The change list is submitted as rev. 222,
below is the detail information.
    http://bazaar.launchpad.net/~libqtelegram-team/telegram-app/telegram/revision/222

Device Information:
    current build number: 791
    device name: krillin
    channel: ubuntu-touch/rc-proposed/bq-aquaris.en-proposed
    last update: 2016-07-20 17:28:54
    version version: 791
    version ubuntu: 20160720
    version device: 20160606-ab415b2
    version custom: 20160701-981-38-14

Changed in telegram-app:
status: In Progress → Fix Committed
assignee: Ash (ashley-richards) → Jin (jin.cth)
Jin (jindallo) wrote :

Please use version 2.2.29.0 as current main trunk build to verify this issue,
many thanks.

Ethan Chang (ethan.chang) wrote :

Verified with 2.2.29.0

tags: added: cqa-verified
Jin (jindallo) on 2016-08-22
Changed in telegram-app:
status: Fix Committed → Fix Released
assignee: Jin (jin.cth) → nobody

Hi, it seems it's not fixed as I just experienced this bug.
Telegram version: 2.2.30.0

After last post i tried to reproduce bug, but didn't manage to.
I'll do more tests

Well, I can still reproduce this bug, but now steps are bit different:

Reproduce Steps:
    a) Launch Telegram
    b) Enter a chat to see the messages with a contact
    c) Keep the application in foreground
    d) Click the Telegram message notification FROM A DIFFERENT CONTACT on Ubuntu Touch unity panel
    e) Observe the Telegram view

Expected Result:
It turns to the messages dialog view of the contact who mentioned in notification.

Actual Result:
Telegram shows a page "Please select chat".

Occurrence:
10/10 (100%)

Software Information:
    com.ubuntu.telegram (2.2.30.0)

Jin (jindallo) wrote :

I can confirm the symptom according to the updated reproduce steps,
this bug will be reopened.

And since it is a regression,
will be planned as milestone 33.

Changed in telegram-app:
assignee: nobody → Jin (jin.cth)
status: Fix Released → Confirmed
milestone: m32 → m33
Jin (jindallo) on 2016-11-10
Changed in telegram-app:
status: Confirmed → In Progress
Jin (jindallo) wrote :

Bug fixed,
and verified pass on developer side.

The change list is submitted as rev. 246,
below is the detail information.
    http://bazaar.launchpad.net/~libqtelegram-team/telegram-app/telegram/revision/246

Device Information:
    current build number: 824
    device name: krillin
    channel: ubuntu-touch/rc-proposed/bq-aquaris.en-proposed
    last update: 2016-09-02 14:17:00
    version version: 824
    version ubuntu: 20160901
    version device: 20160606-ab415b2
    version custom: 20160831-991-38-18

Changed in telegram-app:
status: In Progress → Fix Committed
assignee: Jin (jin.cth) → nobody
assignee: nobody → Jin (jin.cth)
Jin (jindallo) on 2016-11-21
Changed in telegram-app:
status: Fix Committed → Fix Released
assignee: Jin (jin.cth) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers