Message shows a bar which has no conent when the input contains a specific link

Bug #1564823 reported by Jin on 2016-04-01
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Telegram app
High
Unassigned

Bug Description

Description:
Telegram shows a meaningless bar which has no content when the message is a text + a specific link.

Reproduce Steps:
    a) Launch Telegram
    b) Emit a message like below: "test: golem.de"
    c) Observe the dialog window

Expected Result:
Telegram shows the text with link properly.

Actual Result:
Telegram shows a bar with no content.

Occurrence:
10/10 (100%)

Software Information:
    com.ubuntu.telegram (2.0.8.2)

Hardware Information:
    current build number: 28
    device name: mako
    channel: ubuntu-touch/stable/ubuntu
    last update: 2016-03-30 14:21:51
    version version: 28
    version ubuntu: 20160217.1
    version tag: OTA-9.1
    version device: 20160112
    version custom: 20160217.1

Related branches

Jin (jindallo) wrote :
summary: - Message shows a bar which is no conent when the input contains a
+ Message shows a bar which has no conent when the input contains a
specific link
shaperton (hew-skaling) wrote :

It also happens when a phone number is shared with me. (Since they appear to be links too.)

Jin (jindallo) on 2016-05-24
Changed in telegram-app:
milestone: none → m31
Jin (jindallo) on 2016-05-24
Changed in telegram-app:
milestone: m31 → m32
Jin (jindallo) on 2016-06-13
Changed in telegram-app:
milestone: m32 → none
Jin (jindallo) wrote :

Bug below is duplicate with this one:
    https://bugs.launchpad.net/telegram-app/+bug/1630265

It gets confirmed and will be planned into our milestone.

Changed in telegram-app:
milestone: none → m34
Jin (jindallo) on 2016-11-02
Changed in telegram-app:
status: Confirmed → In Progress
assignee: nobody → Devid Antonio Filoni (d.filoni)
Jin (jindallo) wrote :

Bug fixed,
and verified pass on developer side.

The change list is submitted as rev. 244,
below is the detail information.
    http://bazaar.launchpad.net/~libqtelegram-team/telegram-app/telegram/revision/244

Device Information:
    current build number: 862
    device name: krillin
    channel: ubuntu-touch/rc-proposed/bq-aquaris.en-proposed
    last update: 2016-10-27 14:57:07
    version version: 862
    version ubuntu: 20161027
    version device: 20160606-ab415b2
    version custom: 20160831-991-38-18

Changed in telegram-app:
status: In Progress → Fix Committed
assignee: Devid Antonio Filoni (d.filoni) → Jin (jin.cth)
milestone: m34 → m33
Jin (jindallo) on 2016-11-21
Changed in telegram-app:
status: Fix Committed → Fix Released
assignee: Jin (jin.cth) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers