App doesn't start, just a blank screen is displayed

Bug #1535344 reported by Earendil02 on 2016-01-18
144
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Telegram app
Critical
Unassigned

Bug Description

When launching the app, a blank screen is all I get.
Tried to quit/reopen, restart and uninstall/reinstall multiple times: no change.
A couple of times has recovered magicfully by itself (both times when changing settings on wi-fi but might be a mere coincidence).
It seems it doesn't load something properly (normally the same blank screen appeared briefly before loading conversations).
I have a BQ aquaris 4.5 OTA-8.5Ubuntu 15.04 armhf 20151210-005527
telegram version 2.0.4.0
A screenshot is attached.
Note: notifications work, so it shouldn't be a network problem.

Related branches

Earendil02 (earendil002) wrote :
Michał Karnicki (karni) wrote :

How long does the problem manifest for (in terms of time, roughly in seconds)? Could it be perhaps the UI thread is affected by pulling the messages from the server, and it shows once you give it enough time? (This would assume you're rather an intense Telegram user.)

Changed in telegram-app:
status: New → Incomplete
dinamic (dinamic6661) wrote :

i also get this bug from time to time on MX4 arale/rc-proposed. i think i've waited for 2-3 minutes once and nothing happened :D
maybe i'll look at the log tomorow

Earendil02 (earendil002) wrote :

It remains like that (screenshot) for minutes, even hours or days counting when it is in backgroud...
It cannot be the connection to the server, there has to be some bug where it gets stuck.

Earendil02 (earendil002) on 2016-01-28
Changed in telegram-app:
status: Incomplete → Confirmed
Earendil02 (earendil002) wrote :

Are there any news or workarounds (delete some cache/log folder/file) about this?
It has been weeks since I last was able to use telegram on my Ubuntu Phone, right now I have to stick with the desktop app and when I'm on the go I have to use the hotspot of my UP to give wireless connection to my old Android and use Telegram there (!!!!!!!).
You can understand this is not acceptable from a core app.
I also uptdated the OS with the newest OTA-9 hoping something would change, but no. Please fix. Urgently.

Michał Karnicki (karni) wrote :

Workaround:

(in Terminal app)
rm -rf .cache/com.ubuntu.telegram
rm -rf .config/com.ubuntu.telegram

This will wipe cache (and secret chats - forever), and will require you to re-authenticate.

Earendil02 (earendil002) wrote :

Thank you very much for the workaround, seems working for now. I will update if/when this problem comes back (hope not!!).
In that case I will gladly provide any information that could help understand what went wrong, just let me know what you need.
Cheers for now

Hi!

I've reproduced this bug, please find attached a compress file with syslog and telegram app logs.

Time stamp: 08:27:12 h

Hope this is useful =)

Thank you so much Victor, I'll definitely call for attention to that one!

Sincerely,
karni

PS It's very good that you e-mailed me, I appreciate that! It's good timing
I should let you know I will be leaving the company in a week - if you'd
like to escalate any issues in the future, please e-mail:
<email address hidden>, <email address hidden> - Jin will be maintaining
Telegram, YC Cheng is the manager I and Jin report to. Thank you, Victor!

On Fri, Feb 19, 2016 at 2:16 PM, Victor gonzalez <email address hidden>
wrote:

> Hi!
>
> I've reproduced this bug, please find attached a compress file with
> syslog and telegram app logs.
>
> Time stamp: 08:27:12 h
>
> Hope this is useful =)
>
> ** Attachment added: "screenshot+logs.zip"
>
> https://bugs.launchpad.net/telegram-app/+bug/1535344/+attachment/4575636/+files/screenshot+logs.zip
>
> --
> You received this bug notification because you are subscribed to
> Telegram app.
> https://bugs.launchpad.net/bugs/1535344
>
> Title:
> App doesn't start, just a blank screen is displayed
>
> Status in Telegram app:
> Confirmed
>
> Bug description:
> When launching the app, a blank screen is all I get.
> Tried to quit/reopen, restart and uninstall/reinstall multiple times: no
> change.
> A couple of times has recovered magicfully by itself (both times when
> changing settings on wi-fi but might be a mere coincidence).
> It seems it doesn't load something properly (normally the same blank
> screen appeared briefly before loading conversations).
> I have a BQ aquaris 4.5 OTA-8.5Ubuntu 15.04 armhf 20151210-005527
> telegram version 2.0.4.0
> A screenshot is attached.
> Note: notifications work, so it shouldn't be a network problem.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/telegram-app/+bug/1535344/+subscriptions
>

--
Software Engineer
Professional and Engineering Services
Canonical Ltd.

Ubuntu - Linux for human beings | www.ubuntu.com

Michał Karnicki (karni) wrote :

While this is not evident from the logs (the app lost connection, and reconnects), I believe this may be related to the reconnect bug that was just fixed. We'll be releasing a fix for that hopefully next week, which will probably resolve the problem reported here. If not, we'll seek ways to deterministically reproduce that.

Changed in telegram-app:
importance: Undecided → High
importance: High → Critical
Paul Playe (v-ubunru-8) wrote :

Got this since the last update (on march 7th - version 2.0.8.1).

I don't remember having experienced this issue before this update.

One more thing that have not been notice here, the Telegram Scope shows unread notification even if the app itself stay blank.

Anyway, thanks for this great app.

Paul Playe (v-ubunru-8) wrote :

One more thing, I receive notifications as attended.

Salvi (salvi) wrote :

I have the same Issue. The App crashed after receiving an Image Inside a chat. Since then a blank Screen remains. not sure if it' connected to the last update.

Andrea Bernabei (faenil) wrote :

I get a completely blank screen when I enable flight mode, or whenever Telegram cannot connect to the servers (i.e. slow wifi, etc).

So, when I enable flight mode, I get
http://pastebin.ubuntu.com/15456908/

If I disable flight mode, and connect to WiFi/3G-data, then the app works as expected

Michael Zanetti (mzanetti) wrote :

If this is still happening to you regardless of flight mode being on or off,

can you please try to move the QML cache away?

mv /home/phablet/.cache/QML/ /home/phablet/.cache/QML.old

and then try starting the app?

If that solves the issue, please send us an archive of the cache. Thanks.

Jin (jindallo) on 2016-03-23
Changed in telegram-app:
milestone: none → m28
Jin (jindallo) on 2016-04-01
Changed in telegram-app:
milestone: m28 → m29
Jin (jindallo) on 2016-04-17
Changed in telegram-app:
milestone: m29 → m30
Changed in telegram-app:
assignee: nobody → Roberto Mier Escandón  (rmescandon)
Changed in telegram-app:
status: Confirmed → In Progress
Michael Zanetti (mzanetti) wrote :

This just happened to me. I figured I had a file named: .config/com.ubuntu.telegram/<phonenumber>/auth.lock

Deleting that made the app recover. Can anyone confirm? If so, we might have a case of bug 1576989

Jin (jindallo) wrote :

@Michael,

Thanks for your info.,
actually we can use the specific configuration wifi AP to reproduce this issue,
I think the situation you mentioned is one of the cause to leads Telegram blank,
but it seems like the problems are separate.

Anyway, I already memo-ed the symptom you have,
if Telegram meets the case I will duplicate the bug to that one: 1576989.

Many thanks for providing this information here!

flohack (flori-bin) wrote :

To me the bug almost always happens if for example my WiFi has bad reception and there is not really much data flowing through wireless. But then, Telegram does not seem to retry on a reasonable timeout, since I turn off the weak WiFi, 3G kicks in and internet routing changes (can be verified by opening a web page), and still telegram has a white screen.

So if smth goes wrong with the initial login or so, the app gets stuck.

BR Florian

Jin (jindallo) on 2016-05-20
Changed in telegram-app:
milestone: m30 → m31
Jin (jindallo) on 2016-06-22
Changed in telegram-app:
milestone: m31 → m32
Jan de Jonge (bdejonge) wrote :

To me the bug happens during startup and followed by shutting down the phone.
the white screen went away after Telegram update 2.2.24.0
and came back after the above described procedure.
the workaround Michał Karnicki (karni) help me out
White the 2.2.24.0 update it the bug can also be force in as described above.
I hope this helps

Jin (jindallo) on 2016-08-15
Changed in telegram-app:
milestone: m32 → m33
Jin (jindallo) on 2016-08-24
Changed in telegram-app:
milestone: m33 → m34
Hans-Peter (hanspeterg) wrote :

Hi
I am on a BQ Aquaris 4.5 running OTA13. I've just installed telegram. On on first startup I got a blank screen. Seconds later I received a SMS with a telegram code. Telegram App remained in blank screen.
Killing app and starting app always results in the same behaviour: Blank screen and a SMS with a telegram code.
best Regards
Hans-Peter

Hans-Peter (hanspeterg) wrote :

Hi
After removing .cache/com.ubuntu.telegram and /config/com.ubuntu.telegram and starting telegram I was able to enter phone number and telegram code. Seemed to be working. I was able to add some contacts from address book. When adding another contact, I got the blank screen. Removing the directories brought up telegram again. Trying to add the specific contact results in blank screen. I repeated this for a few times.Then I started investigating the contact. It was from a google address book. It was missing the country code in its phone number. After adding the country code, I was put into messenger to invite the person to telegram. Hope this helps.
BR
Hans-Peter

Jin (jindallo) wrote :

Hello @Hans-Peter,
Thanks for your information,
we are going to reproduce the symptom you met.

If I can confirm the issue I will post here,
then please let us manage a way to solve it,
thanks.

Changed in telegram-app:
assignee: Roberto Mier Escandón  (rmescandon) → Jin (jin.cth)
Jin (jindallo) wrote :

Issue confirmed,
follow below steps can reproduce the symptom,
and it is a general issue if the account or phone number,
without prefix as the country code:
    a) New a contact from our phone _without_ country code
    b) Launch Ubuntu Telegram
    c) "Add Contact" from the button we have in settings
    d) Select "From Address Book" to import contact from phone
    e) Observe the application UI

And this could be recovered after the app relaunched,
but it is annoying to our users after all,
issue confirmed and will be planned into our milestone.

Changed in telegram-app:
status: In Progress → Confirmed
Jin (jindallo) wrote :

Bug fixed,
and verified pass on developer side.

The change list is submitted as rev. 243,
below is the detail information.
    http://bazaar.launchpad.net/~libqtelegram-team/telegram-app/telegram/revision/243

Device Information:
    current build number: 862
    device name: krillin
    channel: ubuntu-touch/rc-proposed/bq-aquaris.en-proposed
    last update: 2016-10-27 14:57:07
    version version: 862
    version ubuntu: 20161027
    version device: 20160606-ab415b2
    version custom: 20160831-991-38-18
    version custom: 20160408.3

Changed in telegram-app:
status: Confirmed → Fix Committed
milestone: m34 → m33
Jin (jindallo) on 2016-11-21
Changed in telegram-app:
status: Fix Committed → Fix Released
assignee: Jin (jin.cth) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers