[bq 5] Telegram crashes

Bug #1473053 reported by Jasmin Tamburini on 2015-07-09
84
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Yuan-Chen Cheng
Telegram app
Critical
Michał Karnicki

Bug Description

Opening Telegram it shows the message "no chats" and then it crashes.
It happens only on the BQ 5. Everything fine on the BQ 4.5.

Telegram is still able to show notifications.

----

Need more information to identify if it deserve to spend time in v1. Please:

touch ~/.config/com.ubuntu.telegram/.debug
it'll spit out more logs in ~/.cache/upstart/application-click*telegram*.log

Michał Karnicki (karni) wrote :

Hi Jasmin,

As a temporary workaround, please try the following (note this will wipe your secret chats that you may have):

1. Install Terminal app from the store
2. run this command:
rm -rf .cache/com.ubuntu.telegram

Let me know if that helped, thanks.

Changed in libqtelegram:
status: New → Incomplete
Chris B (balcy) wrote :

I'm seeing this behaviour too, starting today. (BQ Aquaris 4.5)

Is there any workaround without loosing the chats ?

Timo Mueller (ti-mue-1010109) wrote :

I'm having the same problem on my aquaris E 4.5 as well. Unfortunately, deleting the cache didn't help.

L D (leoubuntuone) wrote :

Same problem for me. I'm using the Aquaris E5. Everything was working fine until for the first time today I tried to use the phone with a second SIM card inserted. I was able to fix the problem by going into Telegram from a different device and closing all other sessions. Hope this helps. Clearly a serious bug though that needs to be fixed!

Andreas Jung (docjuhnk) wrote :

Same here on Aquaris 4.5.
The problem started when I received a rather long message today and opened telegram from the notifications in the top bar.

I'm not using a second SIM-card.

Deleting the specific chat via telegrams web interface had no effect.
Deleting the cache had also no effect.
Reinstall had no effect either.

My personal workaround: use webogram until this is fixed.

Jasmin Tamburini (jasma) wrote :

So, I have tried to delete the telegram folder into ~/.cache but it didn't work. I have also tried to delete the telegram folder into ~/.config and for a few hours last night everything was working again. This morning Telegram started to crash again.

I hope this will be helpfull!

Grunzer_95 (grunzer-95) wrote :

Hello everyone,
I hav had this problem too , but after waiting 2 houers it works again

Andreas Jung (docjuhnk) wrote :

Deleted com.ubuntu.telegram in ~/.cache and ~/.config.
Telegram keeps crashing after entering phone number.

Michał Karnicki (karni) wrote :

Hi all, thank you for reporting this problem. Just to let you all know, we will investigate the problem immediately.

Changed in libqtelegram:
importance: Undecided → Critical
assignee: nobody → Michał Karnicki (karni)
Michał Karnicki (karni) wrote :

One of current suspects is Telegram failing to connect (while obviously it should not crash in such circumstance!), which may have been related to DDoS Telegram is/was recently experiencing https://twitter.com/telegram . This explanation is not a solution though, and we will work to resolve the issue.

Michał Karnicki (karni) wrote :

Hi guys,

I've tried E4.5, and MX4, a colleague tried E5, we could not reproduce the crasher. If one of you would be willing to help and is familiar with adb (and have developer mode enabled), please do the following:

1) enable debug logging:
adb shell "touch .config/com.ubuntu.telegram/.debug"
2) reproduce the crasher
3) adb pull /home/phablet/.cache/upstart/application-click-com.ubuntu.telegram_telegram_1.3.14.105.log

And e-mail that tile to michal.karnicki at canonical.com, thank you.

Timo Mueller (ti-mue-1010109) wrote :

For me, the problem fixed itself within the next days.
Telegram is working fine again.

Johannes Fischer (post-d) wrote :

I had the same problem on my bq 4.5 and solved it this way:

1. uninstall telegram
2. erase ~/.config/com.ubuntu.telegram
3. erase ~/.cache/com.ubuntu.telegram
4. install telegram
5. everything is fine

Michał Karnicki (karni) wrote :

Thank you guys. Based on Timo's commend I'd say this may have been related to:
https://bugs.launchpad.net/libqtelegram/+bug/1426067
which means the DDoS and problems connecting to Telegram servers may have surfaced the bug in the client. I'll leave this bug open for any possible further comments from users, and in a bit will probably mark is as dupe with the aforementioned one.

Trev Cobbett (nysosis) wrote :

I'm still suffering from this issue (BQ 4.5.)

I've done the uninstall/remove [cache/config]/reinstall process, and it worked for a little bit, and then started acting up as before.

I've just re-done the uninstall process, waiting to see if it starts acting up again

Markus Kohli (ubone-q) wrote :

I'm currently only seeing an empty, white screen, indefinitely. Log attached.
Device is an MX4.

Michał Karnicki (karni) wrote :

Markus, you're on rc-proposed channel, aren't you? This is a completely different bug. (This bug is about Telegram crashing, on a stable channel). Please mark this one as affecting you:
https://bugs.launchpad.net/libqtelegram/+bug/1475691 (I've already pulled a bunch of strings to get this resolved).

Markus Kohli (ubone-q) wrote :

You're right, sorry. My bad. Will attach to the other bug.

Notmaxpowder (larslugs) wrote :

First app start : everything is normal, functions as expected.
--Shut down app

Second start: (with wifi) the app shows a black screen with loading icon and Telegram header title. Crashes within approx 10sec of launch // (without wifi) Same behaviour

After reinstall (without fiddling w/ config files) : the app shows a black screen with loading icon and Telegram header title. Crashes within approx 10sec of launch.

After reinstall and removing /.config/com.ubuntu.telegram completely : app starts, shows expected behaviour. Haven't tested sending messages. App seems to work. Wifi was enabled and could connect to account/add number

After restarting app: App shows a loading screen for approx 5sec , then shows the message inbox screen with annotation "no chats". This screen is displayed for about 5secs before the app crashes. Relaunch of the app shows same behaviour.

After turning wifi off/on and 3G data off/on, the app shows the blank screen + loading icon + crash behaviour again.

device : bq 4.5 , up to date

logs : http://paste.ubuntu.com/12012113/

Notmaxpowder (larslugs) wrote :

EDIT
(..)
After reinstall (without fiddling w/ config files) : the app shows a blank screen with loading icon and Telegram header title. (..)

Blank, not black

Michał Karnicki (karni) wrote :

larslugs, please sign in to Ubuntu One account and update to latest Telegram version from the store. The problem you're reporting has been fixed.

Michał Karnicki (karni) wrote :
Michał Karnicki (karni) on 2015-08-17
tags: added: v2
Notmaxpowder (larslugs) wrote :

Confirmed working indeed, sorry for the late reply

jtd (jtdjtdjtd-business) wrote :

This behavior also exhibited on Ubuntu Phone 15.04 (r23) today.

ed (ed-stranger) wrote :

Just reinstalled today, first run successful.
Yet after I killed it, it wont start back up as it briefly shows the screen with the spinning loading icon and then instantly quits.

Nieke Aerts (nieke-a) wrote :

Bought the ubuntu BQ 4.5. Telegram won't open. I see a white screen for a short moment and then it crashes. I've uninstalled and reinstalled, same problem.

Is there a way to open it from the terminal so that I can see some error message?

Nieke Aerts (nieke-a) wrote :

Oh and webogram is working, so that can connect to the servers...

Michał Karnicki (karni) wrote :

In terminal, if you:
touch ~/.config/com.ubuntu.telegram/.debug

it'll spit out more logs in ~/.cache/upstart/application-click*telegram*.log

I apologize for the experience, we're working hard to get a major update released soon.

Nieke Aerts (nieke-a) wrote :

It seems that those files do not exist on my phone... maybe that is where the problem starts?
(I get "no such file or directory", also locate does not find anything.)

Nieke Aerts (nieke-a) wrote :

It is working now! The new updates fixed it for me! :)

Michał Karnicki (karni) wrote :

Hi Nieke. We have not released an update recently, so I'm afraid it's highly probable it's coincidental the problem no longer manifests for you.

Jasmin Tamburini (jasma) wrote :

Suddenly the camera of my BQ 5 stopped working and sometimes the device didn't respond to any command.
I reset the phone and now everything is working normally, even TELEGRAM works!

Nieke Aerts (nieke-a) wrote :

Hi Michal, Actually I did get an update, from ubuntu as well as telegram, so I was probably on an even older version. And now it stopped working. So I could use it for a bit and now it hangs on the first screen (with the loading images turning). Looking forward to the update! :D

Michał Karnicki (karni) on 2015-10-02
tags: added: v2-verify
removed: v2
Michał Karnicki (karni) on 2015-10-02
Changed in telegram-app:
milestone: none → alpha1
Michał Karnicki (karni) wrote :

We expect this problem will on longer manifest in the upcoming v2 update of the app.

Changed in telegram-app:
status: Incomplete → Fix Committed
Pat McGowan (pat-mcgowan) wrote :

When will this be released?

Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → ww46-2015
status: New → In Progress
Michał Karnicki (karni) wrote :

Release candidate is planned for in 3 weeks (alpha2 next friday, beta in 1.5 weeks), at which point it'll need to pass QA. Feel free to ping me tomorrow if you'd like to talk in more detail.

Pat McGowan (pat-mcgowan) wrote :

Can we find time to work on this for a v1 patch?

Changed in canonical-devices-system-image:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
Michał Karnicki (karni) wrote :

For the record:

- some people "affected by the bug" actually saw the breakage because of the old thumbnailer removal, that has been fixed
- for others, which may even still see the issue, the actual bug / reason for the crash may be [1], while this bug was kept open as the reason for the crash wasn't clear. It may as well have been [1].

[1] https://bugs.launchpad.net/telegram-app/+bug/1437246

Michał Karnicki (karni) wrote :

I'd also would kindly ask for users who have been affected by "Telegram crash" when starting, to comment on this bug that the issue still persists, or uncheck at the top left that you're no longer affected by this bug. Thank you, and thank you for your patience.

Trev Cobbett (nysosis) wrote :

Hi Michal,

I'm still experiencing this issue, I'm on your release branch version (i.e. 1.3.20.114), as opposed to any other QA etc branch.

description: updated
Yuan-Chen Cheng (ycheng-twn) wrote :

It's a complete re-design of the middle layer of the app in v2 with much clean way. I do apologized for the current bug in v1, and v2 is really not far.

Changed in canonical-devices-system-image:
status: In Progress → Triaged
gerry dublin (kiernangerald) wrote :

newest udpate dated same as this post. e4.5 still same problem, been there since start of october. trying to access menu crashes app. removing config files makes no difference, reinstall and reboot etc etc makes no difference.

Michał Karnicki (karni) wrote :

Gerry,
What do you mean by "newest update dated same as this post"? Do you mean one of the v2 pre-release versions?

If not, please try it:
http://people.canonical.com/~karni/telegram/com.ubuntu.telegram_2.0.2.0_armhf.click

Changed in canonical-devices-system-image:
status: Triaged → In Progress
milestone: ww46-2015 → ww02-2016
Markcortbass (markcortbass) wrote :

Could someone please update a new click package with the newrst Telegram-app?
Telegram v2.0.2.0 is crashing everytime I switch from an application. Thanks in advance :)

We're releasing to the store as we speak.

On Tue, Nov 17, 2015 at 12:57 PM, Markcortbass <email address hidden>
wrote:

> Could someone please update a new click package with the newrst
> Telegram-app?
> Telegram v2.0.2.0 is crashing everytime I switch from an application.
> Thanks in advance :)
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1473053
>
> Title:
> [bq 5] Telegram crashes
>
> Status in Canonical System Image:
> In Progress
> Status in Telegram app:
> Fix Committed
>
> Bug description:
> Opening Telegram it shows the message "no chats" and then it crashes.
> It happens only on the BQ 5. Everything fine on the BQ 4.5.
>
> Telegram is still able to show notifications.
>
> ----
>
> Need more information to identify if it deserve to spend time in v1.
> Please:
>
> touch ~/.config/com.ubuntu.telegram/.debug
> it'll spit out more logs in
> ~/.cache/upstart/application-click*telegram*.log
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1473053/+subscriptions
>

--
Software Engineer
Professional and Engineering Services
Canonical Ltd.

Ubuntu - Linux for human beings | www.ubuntu.com

Michał Karnicki (karni) on 2015-11-17
Changed in telegram-app:
status: Fix Committed → Fix Released
Markcortbass (markcortbass) wrote :

Thank you very much for your hard work! Its working perfectly

Michał Karnicki (karni) wrote :

Glad to hear it, thank you for letting us know!

Pat McGowan (pat-mcgowan) wrote :

can we get a custom tarball with this update

Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Pat McGowan (pat-mcgowan) wrote :

We need to ensure we get a new custom tarball for ll devices with this version.

Changed in canonical-devices-system-image:
status: Fix Released → In Progress
Penk Chen (penk) wrote :

@Pat, once it's released to store, all custom tarballs will contain this version. Do we plan to release this in OTA-9?

Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Iain Haywood (g4sgx) wrote :

Strange issue.
If my contact starts a non-secret chat, works fine. (I don't seem to have the option on a non-secret chat start)
If I or my contact starts a secret chat, he cannot see my messages but I can see his.
Have tried a re-install and re-boot etc, no change.
OTA 10.1 on E4.5 via wifi.

giovano iannotti (iannotti) wrote :

This happens to me every time I have a secret chat as the first one loading. If I open Telegram having a regular chat as the first one, the software will not crush. This is very annoying, since secret chats are essential to me.

giovano iannotti (iannotti) wrote :

Sorry: BQ 4.5 and BQ M10, OTA 10.1

Iain Haywood (g4sgx) wrote :

Also cannot delete old secret chats. Think this app needs work, remember it is BETA though guys.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers