401 received from server suddenly and not able to re-login

Bug #1402732 reported by Roberto Mier Escandón  on 2014-12-15
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Telegram app
Critical
Roberto Mier Escandón 

Bug Description

It happens sometimes that server unauthorizes current account and the application is not able to re-login again. Continuously the 401 happens

Related branches

Michał Karnicki (karni) wrote :

This would explain why Ken and Scott had these problems!

Tiago Salem Herrmann (tiagosh) wrote :

This is happening to me as well.
I keep receiving push notifications, but when I launch telegram I am asked to sign in again.

The account I am trying to use is already active on another device and removing the entire database (.config/com.ubuntu.telegram) does not help.

Ken VanDine (ken-vandine) wrote :

The key error seems to be:

qml: Client error: 401 AUTH_KEY_UNREGISTERED

See my log for more info: http://pastebin.ubuntu.com/9355488/

Changed in libqtelegram:
status: New → Confirmed
assignee: nobody → Roberto Mier Escandón (rmescandon)
milestone: none → m13

Thanks to Tiago who has reported these logs showing a 401 just after creating the shared key (wiping config and cache folder before starting app)

http://paste.ubuntu.com/9547973/

Changed in libqtelegram:
status: Confirmed → Fix Committed
Michał Karnicki (karni) on 2015-01-13
Changed in libqtelegram:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments