Badge counts not keeping sync with app/notifications

Bug #1397396 reported by Jonathan Cave on 2014-11-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Unassigned
Telegram app
High
Michał Karnicki
Ubuntu Push Notifications
Fix Released
High
Roberto Alsina
ubuntu-push-qml (Ubuntu)
Undecided
Unassigned
ubuntu-push-qml (Ubuntu RTM)
Undecided
Unassigned

Bug Description

App Version: 0.9.12.75
OS Version: ubuntu-touch/ubuntu-rtm/14.09-proposed r169 krillin

Steps to reproduce:
 * Configure telegram with push notification support (ubuntu one account)
 * Switch away from app so it is in background
 * Send a message to the account
 * Push notification is received, pop up displayed, entry in notification centre, telegram icon gets '1' badge
 * Open notification indicator
 * Select clear all (badge = 1)
 * Click on telegram in launcher (badge = 1)
 * Unread chat in telegram, read it (bage = 1)
 * background telegram again
 * send N messages (badge = N)
 * click on most recent of the notifications in the centre
 * chat opened

Actual Result:
 Unread message in telegram = 0, messages in centre = N-1, count on badges = N

Expected result:
 Not the above

Related branches

Michał Karnicki (karni) on 2014-11-28
Changed in libqtelegram:
status: New → Confirmed
Michał Karnicki (karni) on 2014-12-03
Changed in libqtelegram:
importance: Undecided → High
Michał Karnicki (karni) on 2014-12-04
Changed in libqtelegram:
assignee: nobody → Michał Karnicki (karni)
Michał Karnicki (karni) on 2014-12-11
tags: added: push
Noemí (noemi-gallego) wrote :

Any progress with this bug?

Michał Karnicki (karni) wrote :

Noemi, we're investigating this now, sorry for the delay.

Roberto, this line of code:
pushClient.count = 0;

results in:
tg.plugin.logic: push notification error: "Unknown method"

Changed in ubuntu-push:
importance: Undecided → High
assignee: nobody → Roberto Alsina (ralsina)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-push-qml - 0.1+15.04.20150119-0ubuntu1

---------------
ubuntu-push-qml (0.1+15.04.20150119-0ubuntu1) vivid; urgency=low

  [ Roberto Alsina ]
  * Fix a typo that prevented setting the icon badge counter value from
    QML (LP: #1397396)
 -- Ubuntu daily release <email address hidden> Mon, 19 Jan 2015 18:56:25 +0000

Changed in ubuntu-push-qml (Ubuntu):
status: New → Fix Released
Changed in canonical-devices-system-image:
importance: Undecided → Medium
milestone: none → ww05-2015
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-push-qml - 0.1+15.04.20150120~rtm-0ubuntu1

---------------
ubuntu-push-qml (0.1+15.04.20150120~rtm-0ubuntu1) 14.09; urgency=low

  [ Roberto Alsina ]
  * Fix typo that prevented setting the badge counter from QML (LP:
    #1397396)
 -- Ubuntu daily release <email address hidden> Tue, 20 Jan 2015 17:10:55 +0000

Changed in ubuntu-push-qml (Ubuntu RTM):
status: New → Fix Released
Michał Karnicki (karni) on 2015-01-21
Changed in libqtelegram:
milestone: none → m15
status: Confirmed → In Progress
Pat McGowan (pat-mcgowan) wrote :

@michal whats the status on this, is a telegram app change required?

Michał Karnicki (karni) wrote :

Hi Pat,

We have a fix for this. We plan to release on Monday (Tuesday the latest?) - depending on what's the deadline for the final tarball. I know it's late, but I assure you I'm completely dedicated to this (and a stable release).

For this next release, I'm actively working on a fix for another more serious bug [1], which I'm considering a blocker (thus working over the weekend). I have the fix, but we have a crash deep in the source when the app is opened multiple times from the notifications (and from the notifications only, not from the launcher). In the worst case, we'll land the fix for this bug, and trim the mentioned [1] so that the app launches, but does not open a dedicated dialog (which is a workaround I would very much prefer to avoid).

[1] https://bugs.launchpad.net/libqtelegram/+bug/1412921

Michał Karnicki (karni) wrote :

For now, we'll zero the badge counter when the app is launched. We'll later improve this to reflect the actual unread messages count as the user reads through them in the app (and perhaps has some still left to read).

Michał Karnicki (karni) wrote :

Forgot to say - yes, we'll want to release a click to the custom tarball. Perhaps by the end of the day. (That depends if we have some time tomorrow for other fixes).

Changed in libqtelegram:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Michał Karnicki (karni) on 2015-01-26
Changed in ubuntu-push:
status: New → Fix Released
Pat McGowan (pat-mcgowan) wrote :

Telegram update will go to the store, so no longer tracking

Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Michał Karnicki (karni) wrote :

Correct. We've handed over to QA to reflect the actual count of unread messages (not just zero'ing when app launched).

Noemí (noemi-gallego) wrote :

Was this bug going to be implemented in this new version?
It still keeps the counter up to 0 even if you have already read the messages.

Michał Karnicki (karni) wrote :

We had to hold the previous release (regression in notifications), and this week's was delayed mostly because QA resources preoccupied with BQ image QA. We plan to publish Telegram to the store before mid next week, so it's ready for Feb 6th as an update. In my understanding, we also plan to include the click in the upcoming custom tarball. Effectively, there was no release last week, and this week's release has been delayed, apologies. This version however addresses multiple issues, please see here:
https://launchpad.net/libqtelegram/+milestone/m15

Noemí (noemi-gallego) wrote :

Ok, thank you Michal.
If it is going to be via OTA next week, then there's no matter.

Jonathan Cave (jocave) on 2015-02-05
tags: added: cqa-verified
Michał Karnicki (karni) on 2015-02-07
Changed in libqtelegram:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers