juju deploy bionic/telegraf fails with error Cannot add PPA

Bug #1798545 reported by Teo Wood on 2018-10-18

This bug report will be marked for expiration in 30 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Telegraf Charm
Medium
Unassigned

Bug Description

DEBUG install Cannot add PPA: 'ppa:~telegraf-devs/ubuntu/ppa'.
DEBUG install ERROR: '~telegraf-devs' user or team does not exist.
DEBUG worker.uniter.jujuc server.go:181 running hook tool "juju-log"
INFO juju-log Failed executing 'add-apt-repository --yes ppa:telegraf-devs/ppa'. Will retry in 10 seconds
DEBUG juju.worker.uniter.remotestate watcher.go:510 update status timer triggered

Teo Wood (t-kalpakidis) wrote :

Seems to be a proxy issue, exporting http_proxy/https_proxy env and executing add-apt-repository with -E seems to add the repo.
How can I make juju do the same?

Junien Fridrick (axino) wrote :

There are "apt-http-proxy" and "apt-https-proxy" in your model config which _should_ work. See https://docs.jujucharms.com/2.4/en/models-config

Changed in telegraf-charm:
status: New → Invalid
Junien Fridrick (axino) wrote :

(or maybe "http-proxy" and "https-proxy", although this will impact other things).

Let us know if that works. The charm should be able to work with only apt-related traffic behind a proxy.

Changed in telegraf-charm:
status: Invalid → Incomplete
importance: Undecided → Medium
Teo Wood (t-kalpakidis) wrote :

yep, juju model-config http/https-proxy did the trick
thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers