Re-raising exceptions in Tarmac hides the real exception

Bug #617692 reported by Paul Hummer on 2010-08-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Tarmac
High
Paul Hummer

Bug Description

While trying to track down the cause of bug #617689 I found that we have a pattern that is actually hiding the real exception. It looks like this:

try:
    do_stuff()
except Exception, e:
    raise e

This means the traceback is wrong. What we should be doing is:

try:
    do_stuff()
except:
    raise

Related branches

Paul Hummer (rockstar) on 2010-08-14
Changed in tarmac:
status: In Progress → Fix Committed
Paul Hummer (rockstar) on 2010-09-18
Changed in tarmac:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers