Switching between simulation and edit mode changes the selected template to the last

Bug #872836 reported by Kenneth Yrke Jørgensen on 2011-10-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
TAPAAL
Medium
Kenneth Yrke Jørgensen
2.0
Medium
Kenneth Yrke Jørgensen

Bug Description

To reproduce

Open the ABP componet example,
Swith to simulation mode

Now the medium component is selected (the last), you would expect the selected one to be the same as you had selected when in edit mode

Reported on ubuntu 10.10 64 bit with TAPAAL 2.0.2rc

Related branches

description: updated
Jiri Srba (srba) on 2011-10-12
Changed in tapaal:
importance: Undecided → Medium
Kenneth Yrke Jørgensen (yrke) wrote :

Do we wish to fix this for 2.0.2, I would surges to push this to 2.1.

Jiri Srba (srba) wrote :

Well, having this in 2.0.2 would be nice. If this is too difficult, I would at least suggest to always select the fist component whenever entering the simulator, not the last one.

Jiri Srba (srba) wrote :

The same problem is also when returning from simulator to editor; again it returns at a different template (and not the first one).

Jiri Srba (srba) wrote :

And the same problems appears when doing redo/undo steps.

summary: - Switching to simulation mode changes selected template to the last
+ Switching between simulation and edit mode changes the selected template
+ to the last
Changed in tapaal:
status: New → Fix Committed
assignee: nobody → Kenneth Yrke Joergensen (yrke)
Jiri Srba (srba) wrote :

The bug is not completely fixed. Open the ABP with components example, select the second component and switch
to the simulator. Now the last one gets selected, no the one selected in the editor.

Changed in tapaal:
status: Fix Committed → In Progress
Kenneth Yrke Jørgensen (yrke) wrote :

I have committed a fix for 2.0 series, however i am keeping the bug open as to version 2.1 so we can improve the fix for future versions of TAPAAL.

The code for calulating active Template is not very well written and needs a larger refactor in order to be able to select which template is active.

Changed in tapaal:
status: In Progress → Triaged
milestone: none → 2.1
Kenneth Yrke Jørgensen (yrke) wrote :

@Jiri, the fix for 2.0 always selects the first component, I works fine on my computer, please try again

Changed in tapaal:
status: Triaged → Fix Committed
Changed in tapaal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers