tangerine-icon-theme is a bit big for ubuntu-desktop recommended package

Reported by Jacob Peddicord on 2009-09-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tangerine-icon-theme
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Currently ubuntu-desktop depends on tangerine-icon-theme. This prevents the theme from being removed if unused, and on a small system 7MB could make quite a difference. It should instead be listed as a Recommends.

No other (non-meta) packages depend on tangerine-icon-theme, and I've tested its removal without any issues. I won't deny that it's a good theme, but we shouldn't be forced to have it if we don't use it. :)

summary: - ubuntu-desktop: tangerine-icon-themes should be Recommends
+ ubuntu-desktop: tangerine-icon-theme should be Recommends

Well the reason behind this dependency is that human-icon-theme inherits missing icons from tangerine. For example Synaptic icon.

So you have the option to have this theme install or "enjoy" the gray/red box and a floppy disk as an icon for Synaptic. There are a few other icons as well which I can track down if needed.

There not a lot of icons which are taken from tangerine by human (eg human has it's own folder icons). So the tangerine-icon-theme can be split to the human-dependable icons and the full tangerine.

There is history behind tangerine-icon-theme as being "community" maintained theme instead of "Canonical's human". I guess with Karmic breathe will take over human and then tangerine & possibly human can be simply moved to universe.

Imho this is invalid bug for ubuntu-desktop and instead bug in the tangerine-icon-theme that it upsets VRMS, is a bit big and used very little by the current default icon theme?

Changed in ubuntu-meta (Ubuntu):
status: New → Invalid
summary: - ubuntu-desktop: tangerine-icon-theme should be Recommends
+ tangerine-icon-theme is a bit big for ubuntu-desktop recommended package
Jacob Peddicord (jpeddicord) wrote :

Valid points. In that case, since Human falls back on Tangerine for some icons, shouldn't human-icon-theme have tangerine-icon-theme listed as a dependency? If that were to be the case Tangerine could be dropped from ubuntu-desktop entirely as Human would pull it in.

Changed in ubuntu-meta (Ubuntu):
status: Invalid → Fix Released
status: Fix Released → Confirmed
status: Confirmed → Fix Released
Dimitri John Ledkov (xnox) wrote :

Tangerine-icon-theme has been dropped from the seeds in favor of simply using ubuntu-artwork package which pulls in the new slick humanity theme.

There are 47 scalable icons which are provided by tangerine and are not in the human theme. So I think it is reasonable for human theme to depend on tangerine for those who would still want to use that theme after karmic.

Changed in tangerine-icon-theme:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers