"emblem" for symbolic link huge

Bug #36833 reported by Emmanuel Touzery on 2006-03-27
48
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
High
tangerine-icon-theme
Undecided
Unassigned
tango-icon-theme
Won't Fix
Low
tango-icon-theme (Ubuntu)
Medium
Simon Pascal Klein

Bug Description

with the new ubuntu icon theme in dapper (and with tango, and actually this problem is inherited from tango), the emblem for symbolic links is huge.
it's probably also the case with emblems for read-only etc.

i'll attach a screenshot.

the problem is that
/usr/share/icons/Tango/scalable/emblems
probably shouldn't exist.
I don't know if the ubuntu icon theme can fix that easily without changing Tango since it inherits from Tango.

it's very annoying, see screenshot. in the case of the screenshot, viewing icons is completely impossible: they are hidden by the emblems..

in nautilus, you can see that viewing of the icons in the folder is totally impossible because of the abnormal size of emblems. on the desktop the emblem is very distracting, it's almost as big as the icon itself.

OK, that's good to know, I will make a note that the emblems should NOT
be scalable.

Mark

Suzan (suzan72) wrote :

It's a Tango Bug. The emblems are much too huge. It can be changed in the index.theme.

Change "Size" from 48 to 96 and "MinSize" from 32 to 1 (for tree).

Search in the index.theme this part:

[scalable/emblems]
Size=48
Context=Emblems
Type=Scalable
MinSize=32
MaxSize=256

and change it to

[scalable/emblems]
Size=96
Context=Emblems
Type=Scalable
MinSize=1
MaxSize=256

i think ubuntu should fix it in the ubuntu icon theme and also for the ubuntu tango package.

in any case, nobody wants this behaviour, it's clearly broken, so it should be fixed for both IMHO.

Mark Shuttleworth (sabdfl) wrote :

Pascal, see the latest comment there is a fix available, could you try that out on the Tango theme? Thanks! Mark

Changed in ubuntu-artwork:
assignee: nobody → 4pascal
status: Unconfirmed → Confirmed
Simon Pascal Klein (klepas) wrote :

On Wed, 29 Mar 2006 07:24:28 -0000
Mark Shuttleworth <email address hidden> wrote:

> Public bug report changed:
> https://launchpad.net/malone/bugs/36833
>
> Task: ubuntu ubuntu-artwork
> Assignee: (unassigned) => klepas
> Status: Unconfirmed => Confirmed
>
> Comment:
> Pascal, see the latest comment there is a fix available, could you try
> that out on the Tango theme? Thanks! Mark

I can look after it soon.

Reason why I've gone dormant this past week is because I've got exams.
One tomorrow, one the day thereafter and continuing into next week.
It's high time for assessment in the moment so I have been
concentrating on that.

Hope it doesn't disrupt anything, though if it does give me heads up
and I'll make sure it gets done if not by me, by a friend such as
Andreas. :)

Hope to be behind the computer for longer soon.
Cheers,

Pascal

>
>

--
Pascal Klein
http://klepas.org

Ubuntu Art team http://wiki.ubuntu.com/ArtworkTeam
Linux Australia http://www.linux.org.au

Daniel Holbach (dholbach) wrote :

This rather a tango-icon-theme bug, but Human inherits from Tango.

Peter Chabada (ubuntu-chabada) wrote :

I'm using this icon:
http://kwh.kernow-gb.com/~bvc/theme/devel/dapper/emblem-symbolic-link.svg

I don't know which solution is better (this icon or changing index.theme).

Daniel Holbach (dholbach) wrote :

 tango-icon-theme (0.7.1-0ubuntu2) dapper; urgency=low
 .
   * debian/postinst:
     - dropped, with gnome.mk we use dh_iconcache.
   * debian/rules:
     - use simple-patchsys.mk
   * debian/patches/fix-symbolic-link-emblem.patch:
     - fix Malone: #36833 ("emblem" for symbolic link huge), icon made by
       Peter Chabada <email address hidden>

Changed in tango-icon-theme:
status: Confirmed → Fix Released
Changed in tango-icon-theme:
status: Unconfirmed → Confirmed
michelem (michele-marcucci) wrote :

The bug is present in the Tangerine icon set too in Feisty and Gutsy.
The Suzan solution works well but you have to generate a new index cache file with:

sudo gtk-update-icon-cache -f /usr/share/icons/Tangerine

Changed in tango-icon-theme:
status: Confirmed → Invalid
Changed in nautilus:
status: Confirmed → Fix Released
dobey (dobey) wrote :

The upstream bug on this has been fixed for a while now, and was never directly an issue with Tangerine.

Changed in tangerine-icon-theme:
status: New → Invalid
Changed in tango-icon-theme:
importance: Unknown → Low
status: Invalid → Won't Fix
Changed in nautilus:
importance: Unknown → High
Changed in tango-icon-theme:
importance: Low → Unknown
Changed in tango-icon-theme:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.