InterfaceInfo (of vimConnectionInfo) Endpoint information is not set

Bug #1923425 reported by Aldinson C. Esto
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tacker
Fix Released
Undecided
Aldinson C. Esto

Bug Description

Endpoint information supposed to be set in InterfaceInfo of vimConnectionInfo is not set.

    "vimConnectionInfo": [
      {
        "id": "xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx",
        "vimId": "xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx",
        "vimType": "xxxxx",
        "interfaceInfo": {},★
        "accessInfo": {
          "username": "user",
          "region": "RegionA",
          "password": "abc123",
          "tenant": "xxxxxxxxxxxxxxxxxxxxxxxxxxx"
        }
      }
    ],

The following operations are affected:
      VNF Instances(GET)/Individual VNF Instances(GET).

Additional operations which might be affected and deemed necessary to check are the following:
    vnflcm op show, failres (other similar cases)

Changed in tacker:
assignee: nobody → Aldinson C. Esto (esto-aldin)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tacker (master)

Fix proposed to branch: master
Review: https://review.opendev.org/c/openstack/tacker/+/786350

Changed in tacker:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tacker (master)

Reviewed: https://review.opendev.org/c/openstack/tacker/+/786350
Committed: https://opendev.org/openstack/tacker/commit/c137b0ddfe10bd7b9ace0b94460e091d0d7f5ec6
Submitter: "Zuul (22348)"
Branch: master

commit c137b0ddfe10bd7b9ace0b94460e091d0d7f5ec6
Author: Aldinson Esto <email address hidden>
Date: Thu Apr 15 11:00:32 2021 +0900

    Add endpoint information in interfaceInfo

    This patch will fix the issue about the missing endpoint
    information in the interfaceInfo of vimConnectionInfo.

    Closes-Bug: #1923425
    Change-Id: I364ab27ad14f0af06a1befed28196bd1b027e909

Changed in tacker:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tacker 6.0.0.0rc1

This issue was fixed in the openstack/tacker 6.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers