get_vim_resource_id() got an unexpected keyword argument 'vim_auth'

Bug #1667236 reported by Jimmy.Ye
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tacker
High
Yan Xing'an

Bug Description

when I run cmd with this:

tacker --debug vnffg-create --vnffgd-name vnffgd_own_01 FG_vnffg_02

2017-02-22 18:30:52.068 DEBUG tacker.common.log req-29d091d2-73c6-4d23-8ebc-5d6faea93df2 nfv_user dad9eee0f0da42af9b7ca6dd278ce65b] tacker.nfvo.drivers.vim.openstack_driver.OpenStack_Driver method get_vim_resource_id called with arguments () {'vim_auth': {u'username': u'nfv_user', 'password': '***', u'project_name': u'nfv', u'user_id': u'', u'user_domain_name': u'Default', u'auth_url': u'http://localhost:5000/v3', u'project_id': u'', u'project_domain_name': u'Default'}, 'resource_name': u'net0', 'resource_type': u'network'} from (pid=57309) wrapper /opt/stack/stack_newton/tacker/tacker/common/log.py:
2017-02-22 18:30:52.080 ERROR tacker.api.v1.resource req-29d091d2-73c6-4d23-8ebc-5d6faea93df2 nfv_user dad9eee0f0da42af9b7ca6dd278ce65b] create failed^[[00m
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource Traceback (most recent call last):
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource File "/opt/stack/stack_newton/tacker/tacker/api/v1/resource.py", line 83, in resource
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource result = method(request=request, **args)
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource File "/opt/stack/stack_newton/tacker/tacker/api/v1/base.py", line 395, in create
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource obj = obj_creator(request.context, **kwargs)
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource File "/opt/stack/stack_newton/tacker/tacker/common/log.py", line 35, in wrapper
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource return method(*args, **kwargs)
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource File "/opt/stack/stack_newton/tacker/tacker/nfvo/nfvo_plugin.py", line 239, in create_vnffg
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource vnffg_dict = super(NfvoPlugin, self)._create_vnffg_pre(context, vnffg)
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource File "/opt/stack/stack_newton/tacker/tacker/db/nfvo/vnffg_db.py", line 353, in _create_vnffg_pre
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource vnf_mapping)
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource File "/opt/stack/stack_newton/tacker/tacker/db/nfvo/vnffg_db.py", line 566, in _policy_to_acl_criteria
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource vnf_mapping))
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource File "/opt/stack/stack_newton/tacker/tacker/db/nfvo/vnffg_db.py", line 599, in _convert_criteria
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource vnf_id)
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource File "/opt/stack/stack_newton/tacker/tacker/nfvo/nfvo_plugin.py", line 429, in _vim_resource_name_to_id
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource resource_name=name)
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource File "/opt/stack/stack_newton/tacker/tacker/common/driver_manager.py", line 70, in invoke
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource return getattr(driver, method_name)(**kwargs)
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource File "/opt/stack/stack_newton/tacker/tacker/common/log.py", line 35, in wrapper
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource return method(*args, **kwargs)
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource TypeError: get_vim_resource_id() got an unexpected keyword argument 'vim_auth'
2017-02-22 18:30:52.080 TRACE tacker.api.v1.resource
2017-02-22 18:30:52.133 INFO tacker.wsgi req-29d091d2-73c6-4d23-8ebc-5d6faea93df2 nfv_user dad9eee0f0da42af9b7ca6dd278ce65b 192.168.10.60 - - [22/Feb/2017 18:30:52] "POST /v1.0/vnffgs.json HTTP/1.1" 500 304 3.494

Jimmy.Ye (jimmy.ye)
Changed in tacker:
assignee: nobody → Jimmy.Ye (jimmy.ye)
Changed in tacker:
status: New → In Progress
Revision history for this message
Alessandro Delfino (alessandro.delfino) wrote :

Hi,
we have the same error using the Horizon web frontend instead of calling the tacker script directly.

We are using devstack with newton stable branch.

Changed in tacker:
importance: Undecided → High
milestone: none → pike-1
tags: added: backport-ocata
Revision history for this message
Jimmy.Ye (jimmy.ye) wrote :

To Alessandro Delfino

 you can change your local code like this commit:

https://review.openstack.org/#/c/437319/

Revision history for this message
Alessandro Delfino (alessandro.delfino) wrote :

Hi,
I have done the suggested changes at the two files, but got other errors, also commenting out the lines that give the error I obtain the instance of the vnffg on the tacker DB, but the web page give us an error, like an id not found and the record on vnffgs table is in ERROR status.

Maybe the problem is due to the newton/stable version?
As I mentioned in the first message we are using this branch and when I did the changes to the two files I found differences in line numbers between your code and mine version.

Changed in tacker:
assignee: Jimmy.Ye (jimmy.ye) → Yan Xing'an (yanxingan)
Yan Xing'an (yanxingan)
Changed in tacker:
assignee: Yan Xing'an (yanxingan) → nobody
Jimmy.Ye (jimmy.ye)
Changed in tacker:
assignee: nobody → Jimmy.Ye (jimmy.ye)
Changed in tacker:
assignee: Jimmy.Ye (jimmy.ye) → Yan Xing'an (yanxingan)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tacker (master)

Reviewed: https://review.openstack.org/437319
Committed: https://git.openstack.org/cgit/openstack/tacker/commit/?id=7bbafc812040186db58c176c5ec68181fec4c221
Submitter: Jenkins
Branch: master

commit 7bbafc812040186db58c176c5ec68181fec4c221
Author: Jimmy.Ye <email address hidden>
Date: Thu Feb 23 18:20:50 2017 +0800

    fix get_vim_resource_id() to support list_networks()

    add neutron filter name and not unique exception

    Co-Authored-By: Yan Xing an <yanxingan@cmss.​chinamobile.​com>
    Closes-Bug: #1667236

    Change-Id: I1b8dddff92a7ef7d11ba3d06254f4686df8deff3

Changed in tacker:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tacker 0.8.0

This issue was fixed in the openstack/tacker 0.8.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers