dsvm failure: devstack plugin is not enabled to reuse multiple times

Bug #1646807 reported by Tung Doan on 2016-12-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tacker
High
Tung Doan

Bug Description

Recently, OpenStack Devstack does not allow plugin to re-use multiple times [1]. That's why dsvm job in Tacker failed [2].
Error:
[ERROR] /opt/stack/new/devstack/functions-common:1775 Plugin attempted to be enabled twice: tacker git://git.openstack.org/openstack/tacker master

[1] https://review.openstack.org/#/c/396794/
[2] http://logs.openstack.org/97/404797/1/check/gate-tacker-dsvm-functional-ubuntu-xenial-nv/ccd5dc8/console.html#_2016-11-30_16_05_45_978220

Tung Doan (tungdoan) on 2016-12-02
Changed in tacker:
status: New → In Progress
assignee: nobody → Tung Doan (tungdoan)
Changed in tacker:
importance: Undecided → High

Reviewed: https://review.openstack.org/404797
Committed: https://git.openstack.org/cgit/openstack/tacker/commit/?id=17e28c9d900614a72ebcbf067a4919e99cfffc3d
Submitter: Jenkins
Branch: master

commit 17e28c9d900614a72ebcbf067a4919e99cfffc3d
Author: doantungbk <email address hidden>
Date: Wed Nov 30 06:36:59 2016 -0800

    Fix dsvm failure caused by devstack plugin and event/auditing func.

    This patch will fix dsvm failure:
    1. The new changes in devstack [1]. Whereby, plugin was not enabled
    to use multiple times. Currently, almost functions like fixup_quota,
    add_key and add_secgrp enable plugin which runs multiple times.
    2. Some functional tests were not working with event/auditing function.
    [1]https://review.openstack.org/#/c/396794/

    Change-Id: I1846c0df1d59557919a4caa612f2a4c60fbf7ce8
    Closes-Bug: #1646807

Changed in tacker:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/411577
Committed: https://git.openstack.org/cgit/openstack/tacker/commit/?id=02ea195a6c7cbe393bce1afe8dbda84f1d58c6c7
Submitter: Jenkins
Branch: stable/newton

commit 02ea195a6c7cbe393bce1afe8dbda84f1d58c6c7
Author: doantungbk <email address hidden>
Date: Wed Nov 30 06:36:59 2016 -0800

    Fix dsvm failure caused by devstack plugin and event/auditing func.

    This patch will fix dsvm failure:
    1. The new changes in devstack [1]. Whereby, plugin was not enabled
    to use multiple times. Currently, almost functions like fixup_quota,
    add_key and add_secgrp enable plugin which runs multiple times.
    2. Some functional tests were not working with event/auditing function.
    [1]https://review.openstack.org/#/c/396794/

    Change-Id: I1846c0df1d59557919a4caa612f2a4c60fbf7ce8
    Closes-Bug: #1646807
    (cherrypick from commit 17e28c9d900614a72ebcbf067a4919e99cfffc3d)

tags: added: in-stable-newton

This issue was fixed in the openstack/tacker 0.6.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers