Battery life estimation never comes around

Reported by Jon Loldrup on 2010-09-03
This bug affects 415 people
Affects Status Importance Assigned to Milestone
DeviceKit-Power
Fix Released
Medium
One Hundred Papercuts
Undecided
Unassigned
Release Notes for Ubuntu
Undecided
Unassigned
System76
Undecided
Unassigned
Upower
Fix Released
Undecided
Unassigned
gnome-power
Invalid
Undecided
Unassigned
upower (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: gnome-power-manager

When running on battery, the mouse over text for the battery icon (when running on battery) permanently says "Battery life (estimating...)". An estimate never shows up.
Computer: HP Envy 14

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-power-manager 2.31.90-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic-pae 2.6.35.3
Uname: Linux 2.6.35-19-generic-pae i686
NonfreeKernelModules: wl
Architecture: i386
Date: Fri Sep 3 06:38:47 2010
ExecutablePath: /usr/bin/gnome-power-manager
GConfNonDefault:
 /apps/gnome-power-manager/lock/blank_screen=false
 /apps/gnome-power-manager/lock/use_screensaver_settings=false
 /apps/gnome-power-manager/notify/sleep_failed_uri=
 /apps/gnome-power-manager/ui/icon_policy=charge
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
MachineType: Hewlett-Packard HP ENVY 14 Notebook PC
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-19-generic-pae root=UUID=76ae939d-2ce2-466e-88d5-98b11aad6098 ro quiet splash
ProcEnviron:
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-power-manager
dmi.bios.date: 07/21/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.12
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1436
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 59.20
dmi.chassis.asset.tag: CNU0274F2B
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.12:bd07/21/2010:svnHewlett-Packard:pnHPENVY14NotebookPC:pvr0492100000241910000620000:rvnHewlett-Packard:rn1436:rvr59.20:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP ENVY 14 Notebook PC
dmi.product.version: 0492100000241910000620000
dmi.sys.vendor: Hewlett-Packard

See also bug #629257 (one lower) for previous (lukewarm) discussions on the implications of showing "(estimating...)" via the user interface. This two bugs might want re-splitting/sorting again based on those that relate to the chrono estimate not being known, and those that relate to the pointless display of that unknown data for long periods of time to the user.

Jon Loldrup (loldrup) wrote :

Marking as invalid for the same reasons as your previous bug:
»The new battery menu (which you should have if you are running Ubuntu Lucid or later) does not have tooltips / mouse over text anymore. Instead it has a menu item directly showing »Laptop battery X hours X minutes left«.

It does not need to estimate anymore, so I’m going to mark this bug as invalid.«

If it occurs nonetheless, you should either update your system or report this upstream to GNOME: https://wiki.ubuntu.com/Bugs/Upstream/GNOME

Ah sorry, this bug _is_ in fact related to the GNOME battery menu. Then you should really report it upstream. :)

Jon Loldrup (loldrup) wrote :

According to the URL of this bug:
https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/629258
this bug is already associated with 'gnome power manager'
How can it be so, when you say I have to 'report it upstreams' (for the bug to be properly reported, I assume)
Does it mean nothing that it is apparently already associated with gnome power manager?

I have exact same problem. Time didn't estimated in lucid, but at least i had battery charge percentage. Now I totally confused about remaining battery charge.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Fabián Rodríguez (magicfab) wrote :

There is no mouseover in Maverick beta for this, however the "menu" item when clicking on the battery effectively remains at "estimating...". The battery icon, however, seems to be visually accurate, showing a battery that empties overtime. This is on an updated 10.10 beta i386 install.

FWIW, I can't reproduce this on g-p-m 2.31.92-0ubuntu1 or 2.32.0-0ubuntu1.

James White (jameswhite) wrote :

I have the same problem on a Compaq Presario CQ60-307EA (Laptop). Running Ubuntu 10.10 BETA with latest packages. A lot of HP & Compaq's seem to be affected by this bug.

T. Dalbo (cooltd825) wrote :

Just upgraded my HP G62-144DX to 10.10 today, and am having the same problem. It seems that most of our computers are unable to estimate time. I don't mind this, I can do my own estimations just fine, but the developers seem to think our computers can do this calculation therefore defaulting it.

Fabián Rodríguez (magicfab) wrote :

@Mathieu, what system(s) ?

I've now noticed that when the power is removed a notification is displayed with an accurate % value (but still no tim estimate).

I'd ask anyone adding comments here to mention their affected system(s), please don't add "me too"-only comments.

shwan rashid (shwany) wrote :

applied all updates, removed charger and still estimating, no percentage or time.
system is compaq c700.

Architecture: amd64
DistroRelease: Ubuntu 10.10
EcryptfsInUse: Yes
GConfNonDefault:
 /apps/gnome-power-manager/backlight/idle_dim_ac=true
 /apps/gnome-power-manager/lock/blank_screen=false
 /apps/gnome-power-manager/lock/use_screensaver_settings=false
 /apps/gnome-power-manager/notify/sleep_failed_uri=
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100923)
MachineType: Acer Aspire 5740
Package: gnome-power-manager 2.32.0-0ubuntu1
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=9f6960f1-acb7-4b3b-b8fe-a50a2479f02f ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_CA.UTF-8
 SHELL=/bin/zsh
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Tags: maverick
Uname: Linux 2.6.35-22-generic x86_64
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare
dmi.bios.date: 11/26/2009
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.09
dmi.board.name: Aspire 5740
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: Rev
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.09:bd11/26/2009:svnAcer:pnAspire5740:pvrRev:rvnAcer:rnAspire5740:rvrRev:cvnAcer:ct10:cvrRev:
dmi.product.name: Aspire 5740
dmi.product.version: Rev
dmi.sys.vendor: Acer

tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Just ran apport-collect for my system, where I do get the estimation to show up.

Architecture: amd64
DistroRelease: Ubuntu 10.10
GConfNonDefault:
 /apps/gnome-power-manager/lock/blank_screen=false
 /apps/gnome-power-manager/lock/use_screensaver_settings=false
 /apps/gnome-power-manager/notify/sleep_failed_uri=
 /apps/gnome-power-manager/ui/icon_policy=charge
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928)
MachineType: Hewlett-Packard HP Pavilion tx1000 Notebook PC
Package: gnome-power-manager 2.32.0-0ubuntu1
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=e4334e0c-5bd9-4dbe-bfaa-04c47cc8925c ro quiet splash
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Tags: maverick
Uname: Linux 2.6.35-22-generic x86_64
UserGroups: adm cdrom dialout dip fax floppy fuse plugdev tape video
dmi.bios.date: 04/18/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.20
dmi.board.name: 30BF
dmi.board.vendor: Quanta
dmi.board.version: 69.2E
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.20:bd04/18/2008:svnHewlett-Packard:pnHPPaviliontx1000NotebookPC:pvrRev1:rvnQuanta:rn30BF:rvr69.2E:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion tx1000 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Fabián Rodríguez (magicfab) wrote :

Just submitted my apport-collect info from another HP system.

I will open a new bug for a mini 9 system I have which is also affected.

Fabián Rodríguez (magicfab) wrote :

I've filed bug #654761 about this issue on the Dell Mini 9.

Changed in ubuntu-release-notes:
status: New → Fix Released
Andros83 (mail-ceandrea) on 2010-10-18
Changed in ubuntu-release-notes:
status: Fix Released → Confirmed
Changed in ubuntu-release-notes:
status: Confirmed → Fix Released
Changed in battery-status:
status: New → Confirmed
Changed in battery-status:
status: Confirmed → Invalid
affects: battery-status → null
Changed in gnome-power:
status: New → Invalid
Changed in ubuntu-release-notes:
status: Fix Released → Confirmed
Changed in null:
status: Invalid → Confirmed
Changed in ubuntu-release-notes:
status: Confirmed → Fix Released
Changed in null:
status: Confirmed → Invalid
affects: gnome-power-manager (Ubuntu) → upower (Ubuntu)
tags: added: patch
Changed in gnome-power:
status: Invalid → Confirmed
Paul Sladen (sladen) on 2010-11-28
description: updated
Colan Schwartz (colan) on 2011-01-10
Changed in system76:
status: New → Confirmed
Chris Wilson (notgary) on 2011-01-12
Changed in hundredpapercuts:
status: New → Invalid
Changed in devicekit-power:
status: Unknown → In Progress
Changed in devicekit-power:
importance: Unknown → Medium
Changed in upower (Ubuntu):
assignee: nobody → Amr Daouk (amr-z)
status: Confirmed → Fix Released
assignee: Amr Daouk (amr-z) → nobody
Changed in upower (Ubuntu):
assignee: nobody → Amr Daouk (amr-z)
assignee: Amr Daouk (amr-z) → nobody
104 comments hidden view all 184 comments

Bug still there in natty beta 2 (updated from beta 1) HP dv6745

luca (l-savio) wrote :

eeepc 900 natty beta2 too ...:(((

Bug is still alive and kicking. My HP g60 125nr does this and it drives me nuts. If we can get a discharge rate (Wh/time) isn't it just simple arithmetic to get at least a half-decent fallback routine should the current implementation fail/time out? I've had the stock battery replaced via BestBuy, and unsurprisingly it's a cheap Taiwanese knock-off. I can check if the stock battery (as in genuine HP) can give an estimate of remaining charge (it could be HP's hardware level vendor locking, similar to ink cartridges), but I still see no reason for not having a history based estimation as a failsafe.

Andy Cooling (andycooling) wrote :

This seems a little crazy, my Tosh NB200 battery estimation worked fine until an upgrade, can't remember now if it was 9.10 to 10.04 or 10.04 to 10.10. Anyway, the on screen pop-ups with the % remaining are fine, it's just the panel monitor that doesn't display a time. I installed batmon today as a test, it's graphically very poor, but at least it reports a percentage, it too cannot report an estimated time. Can an option for percentage or time be added to the indicator applet until this is resolved?

Luca Manzari (manzariluca) wrote :

Bug still alive, on a natty fresh install :(

MM (mmme) wrote :

I'm a Linux Geek and IT Tech of 10 years and I just installed Natty yesterday on a HP Pavilion dv6 and YES guys we have a BUG here so please let's get a fix for this...

THANKS

the same problem in HP-Mini-210-1000

ubuntu 11.04 clean install

battery:
    dispositive: battery_BAT0
    productor: Hewlett-Packard
    model: Primary
    present: yes
    rechargeable: yes
    state: charging
    energy: 11.4 Wh
    energy-empty: 0 Wh
    energy-full: 24.9 Wh
    energy-full-design: 27.5 Wh
    energy-rate: 0 W
    voltage: 10.9 V
    percentage: 45.8.7749%
    capacity: 90.4%
    technology: lithium-ion

The bug is known upstream, we just need somebody to re-enable the needed code. Please stop commenting, there's no point in giving any additional information: you can only help by actually doing the work yourself...

Changed in upower (Ubuntu):
status: Fix Released → Triaged
Changed in gnome-power:
status: Confirmed → Invalid
Changed in upower (Ubuntu Maverick):
status: Confirmed → Triaged
iMac (imac-netstatz) wrote :

I think what Milan is saying, is the proper way to say "me too" is to select "Affects Me" at the top of the bug, which will help to give developers an accurate scope of impact _ though this one is pretty high already. I posted upstream (freedesktop-bugs link at the top) where IMHO the bug needs a new title and some more activity. I noted the last dev comment was to look at turning on the time estimation code in October 2009 .. I'm guessing that presented a challenge.

papukaija (papukaija) on 2011-06-02
tags: added: natty
papukaija (papukaija) on 2011-06-02
tags: added: metabug
Airam RR (airamrguezrivero) wrote :

I'm having the same issue. Today I found at http://www.omgubuntu.co.uk/2011/02/battery-applet-status-ubuntu/ an applet which can estimate the battery percentage.

Download full text (3.6 KiB)

the battery-status applet emulates the indicator status.. it isn't one...
try using expo trough unity and look at the tray area with and without
"indicators".. you'll see what I mean. It's layered in .. not actually
integrated into the bar.

On Sun, Jun 5, 2011 at 10:19 AM, Airam RR <email address hidden> wrote:

> I'm having the same issue. Today I found at
> http://www.omgubuntu.co.uk/2011/02/battery-applet-status-ubuntu/ an
> applet which can estimate the battery percentage.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (758441).
> https://bugs.launchpad.net/bugs/629258
>
> Title:
> Battery life estimation never comes around
>
> Status in DeviceKit based power management D-Bus backend:
> In Progress
> Status in Gnome Powermanager:
> Invalid
> Status in One Hundred Paper Cuts:
> Invalid
> Status in NULL Project:
> Invalid
> Status in System76:
> Confirmed
> Status in Release Notes for Ubuntu:
> Fix Released
> Status in Upower:
> New
> Status in “upower” package in Ubuntu:
> Triaged
> Status in “upower” source package in Maverick:
> Triaged
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> When running on battery, the mouse over text for the battery icon (when
> running on battery) permanently says "Battery life (estimating...)". An
> estimate never shows up.
> Computer: HP Envy 14
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: gnome-power-manager 2.31.90-0ubuntu5
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic-pae 2.6.35.3
> Uname: Linux 2.6.35-19-generic-pae i686
> NonfreeKernelModules: wl
> Architecture: i386
> Date: Fri Sep 3 06:38:47 2010
> ExecutablePath: /usr/bin/gnome-power-manager
> GConfNonDefault:
> /apps/gnome-power-manager/lock/blank_screen=false
> /apps/gnome-power-manager/lock/use_screensaver_settings=false
> /apps/gnome-power-manager/notify/sleep_failed_uri=
> /apps/gnome-power-manager/ui/icon_policy=charge
> GnomeSessionIdleInhibited: No
> GnomeSessionInhibitors: None
> GnomeSessionSuspendInhibited: No
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386
> (20100901.1)
> MachineType: Hewlett-Packard HP ENVY 14 Notebook PC
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-19-generic-pae
> root=UUID=76ae939d-2ce2-466e-88d5-98b11aad6098 ro quiet splash
> ProcEnviron:
> LANG=en_DK.UTF-8
> SHELL=/bin/bash
> SourcePackage: gnome-power-manager
> dmi.bios.date: 07/21/2010
> dmi.bios.vendor: Hewlett-Packard
> dmi.bios.version: F.12
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 1436
> dmi.board.vendor: Hewlett-Packard
> dmi.board.version: 59.20
> dmi.chassis.asset.tag: CNU0274F2B
> dmi.chassis.type: 10
> dmi.chassis.vendor: Hewlett-Packard
> dmi.chassis.version: Chassis Version
> dmi.modalias:
> dmi:bvnHewlett-Packard:bvrF.12:bd07/21/2010:svnHewlett-Packard:pnHPENVY14NotebookPC:pvr0492100000241910000620000:rvnHewlett-Packard:rn1436:rvr59.20:cvnHewlett-Packard:ct10:cvrChassisVersion:
> dmi.product.name: HP ENVY 14 Notebook PC
> dmi.product.version: 0492100000241910000620000
> dmi.sys.vendor: Hewlett-Packard
>
> See also bug #629257 (one lower) for previous ...

Read more...

3 comments hidden view all 184 comments
John Doe (johndoe32102002) wrote :

This bug is still prevalent in System76 netbooks with Ubuntu 11.04 installed.

Andy Eyre (science-andyeyre) wrote :

This bug is still present in Natty. Sorry, I can't get LauchPad to add natty/upower as a new target for this bug - maybe somebody more au fait with launchpad can do that.

I have, however, examined & tested my earlier patch (for upower on 10.10) against upower-0.9.9 that ships with Natty, and it checks out and works fine.

Hence, I attach a .deb with the i386 binary of my patched upower, plus the source.

If somebody wants to also compile for amd64 architecture and add to their PPA (like they did with the earlier patch) to aid distribution, then I'd be thankful - I don't have time for this.

I also see a lot of comments about upstream patches and the need to re-enable the disabled code - this patch does exactly that - fixes the broken estimation code and re-enables it. I don't have time to do it myself, but if somebody wants to commit my patch back up to the ubuntu upower project, then this bug would be fixed for everybody.

Benjamin Drung (bdrung) wrote :

Can you attach a real patch file or debdiff?

1 comments hidden view all 184 comments
Andy Eyre (science-andyeyre) wrote :

Yes. Attached.

Mohegan (jack-mohegan) wrote :

Thanks Andy ! I applied you patch and it's work.

Just a little bug. The informations are shown twice (see the attachment / capture). Any idea ?

Andy Eyre (science-andyeyre) wrote :

Hi Mohegan.

I too saw the double reporting of battery status, when I first installed 11.04. However, I saw it *before* I'd installed the patched upower, so I don't think it's related to that (unless you tell me that you only had one line *until* you installed the patch).

The thing is, the patch affects upower and the data that it reports -- but the icon belongs to gnome-power-manager, which reads the upower data and draws the graphs and things -- and is nothing to do with upower per se. Unless you can definitely identify the behaviour as coming from the patched upower, I'd be tempted to file a new bug under gnome-power-manager.

If it's any help, the double reporting seemed to go away for me as soon as I installed all the latest package updates, though as I said, that was before I'd installed the upower patch.

andy

> I too saw the double reporting of battery status, when I first installed
> 11.04. However, I saw it *before* I'd installed the patched upower
>

I confirm this behavior. Seems that it has nothing to do with proposed
patch.

Sergio Zanchetta (primes2h) wrote :

@Mohegan, Andy

The double reporting of battery status was already present before that.
It happens when the system resume from suspending, i opened a bug
about that, bug #764055

--
Sergio Zanchetta
https://launchpad.net/~primes2h

Download full text (3.7 KiB)

A VERY GOOD alternative for now, for me that is, is to use the
battery-status applet as indicator to get a proper read on what's going on
with my battery and on my cpu governor status...

maybe we could just merge that as a replacement?

On Sun, Jun 26, 2011 at 6:51 PM, Sergio Zanchetta <email address hidden>wrote:

> @Mohegan, Andy
>
> The double reporting of battery status was already present before that.
> It happens when the system resume from suspending, i opened a bug
> about that, bug #764055
>
> --
> Sergio Zanchetta
> https://launchpad.net/~primes2h
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (758441).
> https://bugs.launchpad.net/bugs/629258
>
> Title:
> Battery life estimation never comes around
>
> Status in DeviceKit based power management D-Bus backend:
> In Progress
> Status in Gnome Powermanager:
> Invalid
> Status in One Hundred Paper Cuts:
> Invalid
> Status in NULL Project:
> Invalid
> Status in System76:
> Confirmed
> Status in Release Notes for Ubuntu:
> Fix Released
> Status in Upower:
> New
> Status in “upower” package in Ubuntu:
> Triaged
> Status in “upower” source package in Maverick:
> Triaged
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> When running on battery, the mouse over text for the battery icon (when
> running on battery) permanently says "Battery life (estimating...)". An
> estimate never shows up.
> Computer: HP Envy 14
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: gnome-power-manager 2.31.90-0ubuntu5
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic-pae 2.6.35.3
> Uname: Linux 2.6.35-19-generic-pae i686
> NonfreeKernelModules: wl
> Architecture: i386
> Date: Fri Sep 3 06:38:47 2010
> ExecutablePath: /usr/bin/gnome-power-manager
> GConfNonDefault:
> /apps/gnome-power-manager/lock/blank_screen=false
> /apps/gnome-power-manager/lock/use_screensaver_settings=false
> /apps/gnome-power-manager/notify/sleep_failed_uri=
> /apps/gnome-power-manager/ui/icon_policy=charge
> GnomeSessionIdleInhibited: No
> GnomeSessionInhibitors: None
> GnomeSessionSuspendInhibited: No
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386
> (20100901.1)
> MachineType: Hewlett-Packard HP ENVY 14 Notebook PC
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-19-generic-pae
> root=UUID=76ae939d-2ce2-466e-88d5-98b11aad6098 ro quiet splash
> ProcEnviron:
> LANG=en_DK.UTF-8
> SHELL=/bin/bash
> SourcePackage: gnome-power-manager
> dmi.bios.date: 07/21/2010
> dmi.bios.vendor: Hewlett-Packard
> dmi.bios.version: F.12
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 1436
> dmi.board.vendor: Hewlett-Packard
> dmi.board.version: 59.20
> dmi.chassis.asset.tag: CNU0274F2B
> dmi.chassis.type: 10
> dmi.chassis.vendor: Hewlett-Packard
> dmi.chassis.version: Chassis Version
> dmi.modalias:
> dmi:bvnHewlett-Packard:bvrF.12:bd07/21/2010:svnHewlett-Packard:pnHPENVY14NotebookPC:pvr0492100000241910000620000:rvnHewlett-Packard:rn1436:rvr59.20:cvnHewlett-Packard:ct10:cvrChassisVersion:
> dmi.product.name: HP ENVY 14 Notebook PC
> dmi.product.version: 0492100000241910000620000
> dmi.sys.v...

Read more...

Joel Pickett (jpickett) wrote :

Happening on HP dv6-3006tx

Changed in devicekit-power:
status: In Progress → Fix Released

I pointed the upstream maintainer to Andy's patch, and he just committed something slightly improved.

Martin Pitt (pitti) on 2011-07-04
Changed in upower (Ubuntu Maverick):
status: Triaged → Won't Fix
Changed in upower (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upower - 0.9.12-1

---------------
upower (0.9.12-1) unstable; urgency=low

  * New upstream release:
    - Fix estimation rate for batteries that do not provide this data.
      (LP: #629258)
  * debian/copyright: Fix headers.
  * debian/watch: Look for *.xz tarballs, upstream only publishes these now.
    Repack our tarball as tar.bz2.
 -- Martin Pitt <email address hidden> Fri, 08 Jul 2011 05:47:19 +0000

Changed in upower (Ubuntu):
status: Fix Committed → Fix Released
steubens (steubens) wrote :

will there be a natty backport? (please! :)

Benjamin Drung (bdrung) wrote :

If someone provides a debdiff for natty and adds the required information for a SRU, I am happy to sponsor that.

David Tomaschik (matir) wrote :

Rebuilding the 0.9.12-1 sources on Natty and installing it not only doesn't fix the problem, but makes my laptop suspend any time it is unplugged.

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
7 comments hidden view all 184 comments
Benchrest (benchrest) wrote :

I don't understand all the null updates. My laptop HP DV6646US worked perfectly on the previous 2 releases of Ubuntu. It worked correctly on Natty initially using the classic desktop. But after about a month it stopped working and only shows estimating. I am convinced something changed shortly after Natty was released. Anyhow I think my computer battery must pass the correct information or it would not have worked on the previous releases. And it appears hundred of other users must agree with me.

mlaverdiere (mlaverdiere) wrote :

I'm on Precise right now, with upower 0.9.15 and the problem appears to be solved.

Changed in upower:
status: New → Fix Released
Changed in system76:
status: Confirmed → Fix Released
Timse (timshel86) wrote :

I'm on saucy 13.10, and the problem seems to still be present!

Displaying first 40 and last 40 comments. View all 184 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.