add Mouse Click Debounce Feature?

Bug #602809 reported by Dan Hobson on 2010-07-07
80
This bug affects 17 people
Affects Status Importance Assigned to Milestone
System76
Undecided
Unassigned
xserver-xorg-input-evdev
New
Undecided
Unassigned
xserver-xorg-input-evdev (Ubuntu)
Wishlist
Unassigned

Bug Description

Model: bonp3
OS: Ubuntu 10.04 LTS

When I single click the mouse (external USB Mouse - Mouse Pad disabled) half the time the system responds as though I have double clicked the mouse. I try 2 different USB mouse units and it still does this. I am running Ubuntu 10.04 on a separate PC that does not have this mouse problem. So I am thinking this problem is a System76 driver issue???

It's annoying. :(

Dan Hobson (wd5jhi) wrote :

I tried a third mouse and didn't experience this issue. So it may be a mouse issue. You can cancel this if you want.

Thanks,

Dan

Ian Santopietro (isantop) wrote :

Yeah, if you made no changes to your configuration, and one mouse works just fine, it seems like a problem with two faulty mice. If you feel this is recurring, go ahead a send us an email at support...at...system76...dot...com.

Changed in system76:
status: New → Invalid
Zhang Weiwu (zhangweiwu) wrote :

I am re-opening this bug on accessibilty ground.

Debounce feature exists in AccessX. It was not intended for faulty keyboard. It is intend for users who cannot preciously do one key press.

Quote from wikipedia:
Bounce keys is a feature of computer Desktop Environments. It is an accessibility feature to aid users who have physical disabilities. Bounce keys allows you to configure the computer to ignore rapid, repeated keypresses of the same key.

It seems apparent to me that anyone who couldn't do preciously a single key-press, also could not do a single mouse key-press. Thus this should be an accessibility feature request.

Changed in system76:
status: Invalid → New
summary: - Mouse Click Debounce Disabled
+ add Mouse Click Debounce Feature?

I changed mouse 3 times (different brands), and have the issue with all new USB mouse I can buy (only the internal touchpad of my laptop works, and my OLD mouse, but I don't find the touchpad comfortable to use and wanted to have a new mouse)

However, I have dual boot with Windows and I only have the issue with Linux (whatever USB mouse I use), so it looks like Windows has integrated a software handled mouse debouncing, and that by knowing this manufacturers bother less putting quality mouse contacts and all new mouse I bought had the issue (except my OLD one and my touchpad).

I followed the instructions posted here:
http://blog.guntram.de/?p=16

Using Matt Whitlock's patch here:
http://lists.x.org/archives/xorg-devel/2012-August/033225.html

to build an xserver-xorg-input-evdev_2.8.2-1ubuntu3_amd64.deb package and created a /usr/share/X11/xorg.conf.d/12-evdev-debounce.conf file containing:

    Section "InputClass"
     Identifier "evdev pointer debounce"
     MatchIsPointer "on"
     MatchDriver "evdev"
     Option "DebounceDelay" "25"
     EndSection

and this has totally and definitely solved the issue for me.

I can attach here the xserver-xorg-input-evdev_2.8.2-1ubuntu3_amd64.deb (For trusty) I've build if anyone asks, but I suggest that having a minimum software debounce should be considered seriously.

Am I the only one having this issue? I don't really want to spend all my money buying a new mouse until I find a working one, I've already spend more than a hundred Euros in 3 non-working mice, and I can't get them refunded because the shops (different ones) where I bought them test the mouse under windows when I return it, and give it back to me refusing the refund because for them it works :-( (and when I test them under windows they indeed do work like a charm so this is quite frustrating).

Since Matt's patch works like a charm, it should be considered seriously.

bHarder (briana-harder) wrote :

I have had this problem on every single Logitech wireless mouse (sample size 6) I've owned over the years. A year of regular use and whatever hardware debouncing they do have stops being enough. Then the switches have to be cleaned and the springs retensioned, which is a hassle. One that can easily be avoided with a software fix, I've got a handful of options on my Windows machines to turn to when the built in software debouncing in the OS fails to catch the bounce.

The patch by Matt Whitlock mentioned earlier fixes the problem completely.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Confirmed
Nemes Ioan Sorin (nemes-sorin) wrote :

this is true
got an RAT7 (Mad Catz)
and right click sometime give 2 or 3 click events

a lot of peoples(and I really mean A LOT) using expensive devices (mice) are deep into this problem

fundamentally incredible is the fact that all guru's talk about bad hardware on the linux side, leaving the problem unsolved - on windows they all use the same trick for all devices (using autohotkey).

spending many hours over the internet to find a linux easy solution, I found that the ultimate solution is to patch the evdev driver.
how many peoples will rebuild evdev is my question ? - very few is my response - people use Ubuntu / Mint for ease of use - geeks use Arch < those guys know what to do but many Ubuntu users will leave the problem unsolved .. therefore please add this patch into evdev mainline.

Thanks in advance ...

Nish Aravamudan (nacc) on 2016-07-01
Changed in xserver-xorg-input-evdev (Ubuntu):
importance: Undecided → Wishlist

I'm still seeing this issue with a Logitech G700 with Linux Mint 17.3 (based on Ubuntu 14.04). I did not need Whitlock's patched evdev driver, but adding Comment #4's xorg.conf work-around seems to have alleviated this issue for me.

Alex Garel (alex-garel) wrote :

I am also having this issue since a long time (2 years or more), and this is really annoying. I also think software debouncing should be proposed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers