Kernel Hang During "Loading initial ramdisk..."

Bug #1937296 reported by Boyd Stephen Smith Jr.
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
System76
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

This is specific to the System 76 PPA.

linux-image-5.11.0-7614-generic boots with no problems.

```
% uname -a
Linux system76-pc 5.11.0-7614-generic #15~1622578982~20.04~383c0a9~dev-Ubuntu SMP Wed Jun 2 00:50:47 U x86_64 x86_64 x86_64 GNU/Linux
```

linux-image-5.11.0-7620-generic hangs at "Loading initial ramdisk...". This is true in recovery mode as well.

/etc/os-release:
```
NAME="Ubuntu"
VERSION="20.04.2 LTS (Focal Fossa)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 20.04.2 LTS"
VERSION_ID="20.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=focal
UBUNTU_CODENAME=focal
```

Hardware is Serval:
```
System Information
        Manufacturer: System76
        Product Name: Serval
        Version: serw11-b
        UUID: 6c5bfa80-9b7c-0000-0000-000000000000
        Wake-up Type: Power Switch
```

All packages / firmware is up-to-date, and EFI was updated a couple of months ago.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

It doesn't look like a Ubuntu kernel, can you please report the bug to system76?

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Boyd Stephen Smith Jr. (bss03) wrote :

I was wanting to assign to https://launchpad.net/~system76 but I couldn't figure out how to do that. Says I can only assign to myself when I try. :(

Revision history for this message
Boyd Stephen Smith Jr. (bss03) wrote :

5.11.0-7614-generic was updated last week, and no longer boots.

5.13.0-7614-generic had never booted.

5.8.0-43-generic boots, but comes up without audio devices or network devices (neither wired nor wireless). This is particularly weird since the Ubuntu Live environment I'm writing this update from is using 5.8.0-43, and has both audio and networking working fine.

5.4.0-84-generic boots, but comes up without audio devices or network devices.

I still need to try 5.4.0-26, but I'm not hopeful.

Revision history for this message
Boyd Stephen Smith Jr. (bss03) wrote :

On a personal note, I'm unable to be productive at work because I can no longer find a kernel that will boot with networking in a non-line environment. Never had this happen with the Debian installation I have on System76 (but not-Serval) hardware I have at home.

5.11.0-7620-generic never booted.

5.11.0-7633-generic never booted.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers