Headphone/Main speaker Volume on daru2

Bug #130669 reported by Trey Brown on 2007-08-06
2
Affects Status Importance Assigned to Milestone
System76
Undecided
Unassigned
System76 Driver
Medium
Unassigned

Bug Description

When headphones are plugged in the main speakers stay on, and when you try to use the volume control to turn down 'front' the headphones turn down as well, although the actual volume setting doesn't move and vice-versa.

Thomas Aaron (tom-system76) wrote :

Confirmed.

I've tried the latest BIOS update (which is in the beta stage at the moment). However, it did not solve the problem.
My next step is start researching ALSA to see if there is an answer to be found there.

Changed in system76:
status: New → Confirmed
Thomas Aaron (tom-system76) wrote :

Solved.

This problem is fixed by compiling the stable ALSA version (1.0.14) and adding this line to the bottom of the /etc/modprobe.d/alsa-base file:

options snd-hda-intel model=targa-dig

I've passed this information to our programmer and it will come down soon via a System 76 driver update.

Changed in system76:
status: Confirmed → Fix Committed
Trey Brown (trey.brown) wrote :

Will we just need to run the driver or download and install a new System76 driver?

It will come down via the little orange Update Notification Icon.
When you see it, you will just need to go to System > Admin > System 76 Driver
and click the Install Tab and Install Button. Voila.

----- Original Message -----
From: "Trey" <email address hidden>
To: <email address hidden>
Sent: Thursday, August 9, 2007 3:07:01 PM (GMT-0700) America/Denver
Subject: [Bug 130669] Re: Headphone/Main speaker Volume on daru2

Will we just need to run the driver or download and install a new
System76 driver?

--
Headphone/Main speaker Volume on daru2
https://bugs.launchpad.net/bugs/130669
You received this bug notification because you are a member of System76
Bugs, which is the bug contact for System76.

Trey Brown (trey.brown) wrote :

Any update on the timeline for this to be pushed down?

Thomas Aaron (tom-system76) wrote :

I know Carl is working on it now.
Probably early next week.

----- Original Message -----
From: "Trey" <email address hidden>
To: <email address hidden>
Sent: Thursday, August 16, 2007 12:13:42 PM (GMT-0700) America/Denver
Subject: [Bug 130669] Re: Headphone/Main speaker Volume on daru2

Any update on the timeline for this to be pushed down?

--
Headphone/Main speaker Volume on daru2
https://bugs.launchpad.net/bugs/130669
You received this bug notification because you are a member of System76
Bugs, which is the bug contact for System76.

Carl Richell (carlrichell) wrote :

Fix committed to pending 2.0.9 driver release

Changed in system76-driver:
importance: Undecided → Medium
status: New → Fix Committed

I'm not sure what is going on, but after the 2.0.9 driver update the headphone issue went away. But today, the issue came back, and I don't remember changing anything with respect to volume/sound controls.

Just checked, that extra line in modprobe.d/alsa-base is there. That was the fix right?

Thomas Aaron (tom-system76) wrote :

That was part of the fix. The other part of the fix was updating to the current stable ALSA (1.0.14). That should have been done in the driver as well.

My problem might be wanting to use the "hot keys" to control the volume (Fn-F7/F8/F9) to control sound volume, no matter what it is coming out (speakers or headphones).

What is the correct way of controlling sound output in the Darter? When i plug in my headphones can I still turn up/down the volume from those Fn keys and not have sound come out my speakers? I'm confused because i thought it was working the way I want it to yesterday, but now today it isn't.

Changed in system76:
status: Fix Committed → Fix Released
Changed in system76-driver:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers