Option 'finishings' has value '3' and cannot be edited

Bug #1780310 reported by Timur Tabi
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
System Config Printer
New
Unknown
system-config-printer (Ubuntu)
Undecided
Unassigned

Bug Description

Whenever I open the print queue for my local printer, I get a dialog box with the message:

Option 'finishings' has value '3' and cannot be edited

I can dismiss the dialog box and everything seems to work normally, but it is annoying. However, it's possible that some obscure printer feature does not work for me.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: system-config-printer 1.5.11-1ubuntu2
ProcVersionSignature: Ubuntu 4.15.0-24.26-generic 4.15.18
Uname: Linux 4.15.0-24-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Jul 5 12:30:50 2018
ExecutablePath: /usr/share/system-config-printer/system-config-printer.py
InstallationDate: Installed on 2018-07-03 (2 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
InterpreterPath: /usr/bin/python3.6
Lpstat: device for Ricoh-Aficio-MP-C3500: lpd://hqnvprint02.nvidia.com/secureprint
MachineType: ASUS X299-A
PackageArchitecture: all
Papersize: letter
PpdFiles: Error: command ['fgrep', '-H', '*NickName', '/etc/cups/ppd/Ricoh-Aficio-MP-C3500.ppd'] failed with exit code 2: grep: /etc/cups/ppd/Ricoh-Aficio-MP-C3500.ppd: Permission denied
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-24-generic root=UUID=d418cc23-14fc-41cf-b75f-29644c2a16be ro quiet splash vt.handoff=1
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3
PythonDetails: N/A
SourcePackage: system-config-printer
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/07/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1301
dmi.board.asset.tag: Default string
dmi.board.name: PRIME X299-A
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1301:bd03/07/2018:svnASUS:pnX299-A:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnPRIMEX299-A:rvrRev1.xx:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: X299-A
dmi.product.version: System Version
dmi.sys.vendor: ASUS

Revision history for this message
Timur Tabi (timur-tabi) wrote :
Revision history for this message
Timur Tabi (timur-tabi) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in system-config-printer (Ubuntu):
status: New → Confirmed
Revision history for this message
Theodore Vasiloudis (theodoros-vasiloudis) wrote :

Can confirm this for 18.04 with a network Ricoh NRG MP C5503 PS printer.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :
Changed in system-config-printer:
status: Unknown → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.5.11-2ubuntu2

---------------
system-config-printer (1.5.11-2ubuntu2) disco; urgency=low

  * 40_temporary-fix-for-error-pop-up-window-for-ipp-2.x-attributes.patch:
    Temporary fix for error pop-up window for IPP2.0+ attributes backported
    from upstream (Upstream issue #122, LP: #1780310, LP: #1766107).

 -- Till Kamppeter <email address hidden> Mon, 7 Jan 2019 20:01:12 +0100

Changed in system-config-printer (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Dan Kortschak (dan-kortschak) wrote :

Still affecting 18.04. Also note that upstream does not have an issue tracker anymore, losing the linked issue above.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Upstream has moved system-config-printer to the GitHub of OpenPrinting. You find it now here:

https://github.com/OpenPrinting/system-config-printer

There you find also all the opened and closed issues and pull requests with the same numbers.

The upstream issue corresponding to this bug report you find here now:

https://github.com/OpenPrinting/system-config-printer/issues/122

Revision history for this message
Nicolas Damgaard Larsen (ndl101) wrote :

Confirming issue. Using the Ricoh Aficio MP C3502 PS driver.

Revision history for this message
Nicolas Damgaard Larsen (ndl101) wrote :

According to https://github.com/OpenPrinting/system-config-printer/issues/122 it should be temporarily fixed in 1.5.12 which is included in 20.04. Will this be be released into 18.04?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.