Feature request: Use Launchpad translations instead of *.properties file

Bug #795053 reported by Philipp C. Heckel
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Syncany
Confirmed
Low
Marius Voila

Bug Description

It would be much easier if people could just use the Launchpad Translations tool to translate Syncany. Currently *.properties-files are used. For more information refer to this Answers thread: https://answers.launchpad.net/syncany/+question/160433

The task would be to transform this *.properties-based architecture to a *.pot-based system, set up the tool in Launchpad and change the code to make it work.

Revision history for this message
Marius Voila (mariusv) wrote :

I will do it this weekend.

Changed in syncany:
assignee: nobody → Marius Voilă (mariusv)
Revision history for this message
Philipp C. Heckel (binwiederhier) wrote : Re: [Bug 795053] Re: Feature request: Use Launchpad translations instead of *.properties file

Awesome!

2011/6/9 Marius Voilă <email address hidden>:
> I will do it this weekend.
>
> ** Changed in: syncany
>     Assignee: (unassigned) => Marius Voilă (mariusv)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/795053
>
> Title:
>  Feature request: Use Launchpad translations instead of *.properties
>  file
>
> Status in Syncany:
>  Confirmed
>
> Bug description:
>  It would be much easier if people could just use the Launchpad
>  Translations tool to translate Syncany. Currently *.properties-files
>  are used.  For more information refer to this Answers thread:
>  https://answers.launchpad.net/syncany/+question/160433
>
>  The task would be to transform this *.properties-based architecture to
>  a *.pot-based system, set up the tool in Launchpad and change the code
>  to make it work.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/syncany/+bug/795053/+subscriptions
>

Changed in syncany:
milestone: none → 0.1-alpha
Revision history for this message
Paulo de Souza Lima (paulo-s-lima) wrote :

It would be nice.

Revision history for this message
Christoph Buchner (bilderbuchi) wrote :

Seeing that the translations section on LP is now activated, I mark this as fixed.

Changed in syncany:
status: Confirmed → Fix Released
Revision history for this message
Philipp C. Heckel (binwiederhier) wrote :

Hi there,

There is a template that Marius made (en.pot), and the translations
are imported in my branch (~binwiederhier/syncany/trunk), but we're at
the moment not using the *.po-files. So it's not really fixed yet.

Marius said he wanted to do it, but you can contact him directly if
you want to help :-)

Cheers,
Philipp

Revision history for this message
Christoph Buchner (bilderbuchi) wrote :

Ah, sorry about that. I just saw all the translation work already done, figured it's fixed already. Unfortunately, now I've run out of spoken languages. :-/

Revision history for this message
Christoph Buchner (bilderbuchi) wrote :

...aaand I'm not allowed to set the status back to "Confirmed"... :-(

Revision history for this message
Philipp C. Heckel (binwiederhier) wrote :

Weird. I thought everybody could change these things...

Changed in syncany:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers