New Hebrew translation

Bug #587026 reported by Yaron on 2010-05-28
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
synaptic
Fix Released
Undecided
Michael Vogt
synaptic (Debian)
Fix Released
Unknown
synaptic (Freespire)
New
Undecided
Unassigned
synaptic (Ubuntu)
Undecided
Unassigned

Bug Description

The current Hebrew translation for Synaptic is really bad, it has many incorrect translated strings and quite a few typos.
Please replace it with the attached translation ASAP.

* Because of Yaron's comment saying that launchpad keeps loading an old and buggy translation for every new Ubuntu release even if it's fixed on an older one, we think that is would be better if the translation will be committed directly to the source.

Yaron (sh-yaron) wrote :
description: updated
Changed in synaptic:
assignee: nobody → Michael Vogt (mvo)
assignee: Michael Vogt (mvo) → nobody
status: New → Confirmed
tags: added: i18n
Yaron (sh-yaron) wrote :

Deleted for some reason before

Changed in synaptic:
assignee: nobody → Michael Vogt (mvo)
Mark Krapivner (mark125) wrote :

Why the Ubuntu's Hebrew translation team can't use the upload option provided by launchpad?

I want it upstream!
Fixing the same mistakes over and over again every six months makes no sense
Efficiency matters...

Mark Krapivner (mark125) wrote :

Ubuntu is not the upstream for Synaptic?
The code is hosted on Ubuntu's servers:
http://people.ubuntu.com/~mvo/bzr/synaptic/synaptic--main/

Yaron (sh-yaron) wrote :

Yet if you update the translation via the Launchpad Translation interface
the translation is not saved and the strings are overwritten every half a
year...
So this is clearly not saved upstream

Mark Krapivner (mark125) on 2010-06-17
description: updated

Well, what about submitting the updated translation to Debian?

I check for already reported bugs at
http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=synaptic and didn't find
anything.

Kaplan

On Fri, Jun 18, 2010 at 1:51 AM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> You have been subscribed to a public bug by Yaron (sh-yaron):
>
> The current Hebrew translation for Synaptic is really bad, it has many
> incorrect translated strings and quite a few typos.
> Please replace it with the attached translation ASAP.
>
> * Because of Yaron's comment saying that launchpad keeps loading an old
> and buggy translation for every new Ubuntu release even if it's fixed on
> an older one, we think that is would be better if the translation will
> be committed directly to the source.
>
> ** Affects: synaptic
> Importance: Undecided
> Assignee: Michael Vogt (mvo)
> Status: Confirmed
>
> ** Affects: synaptic (Ubuntu)
> Importance: Undecided
> Status: New
>
>
> ** Tags: i18n
> --
> New Hebrew translation
> https://bugs.edge.launchpad.net/bugs/587026
> You received this bug notification because you are a direct subscriber of
> the bug.
>

Yaron (sh-yaron) wrote :

Yeah, if we still didn't get any answer that would be a nice detour

Can we make sure that the former translations will not get back to the
distros whatsoever or we still need this bug to be resolved?
Yaron Shahrabani

On Wed, Jun 23, 2010 at 7:19 PM, Lior Kaplan <email address hidden> wrote:

> Well, what about submitting the updated translation to Debian?
>
> I check for already reported bugs at
> http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=synaptic and didn't find
> anything.
>
> Kaplan
>
> On Fri, Jun 18, 2010 at 1:51 AM, Launchpad Bug Tracker <
> <email address hidden>> wrote:
>
> > You have been subscribed to a public bug by Yaron (sh-yaron):
> >
> > The current Hebrew translation for Synaptic is really bad, it has many
> > incorrect translated strings and quite a few typos.
> > Please replace it with the attached translation ASAP.
> >
> > * Because of Yaron's comment saying that launchpad keeps loading an old
> > and buggy translation for every new Ubuntu release even if it's fixed on
> > an older one, we think that is would be better if the translation will
> > be committed directly to the source.
> >
> > ** Affects: synaptic
> > Importance: Undecided
> > Assignee: Michael Vogt (mvo)
> > Status: Confirmed
> >
> > ** Affects: synaptic (Ubuntu)
> > Importance: Undecided
> > Status: New
> >
> >
> > ** Tags: i18n
> > --
> > New Hebrew translation
> > https://bugs.edge.launchpad.net/bugs/587026
> > You received this bug notification because you are a direct subscriber of
> > the bug.
> >
>
> --
> New Hebrew translation
> https://bugs.launchpad.net/bugs/587026
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Lior Kaplan (kaplan) wrote :
  • he.po Edit (109.1 KiB, text/x-gettext-translation; charset=UTF-8; name="he.po")

I didn't understand what you wrote.

You should take your latest translation, compare it to the Debian's one
(attached he.po from synaptic 0.63.1), and send a patch to Debian. When you
do that, let me know the Debian bug number.

You're welcome to contact me privately if you have questions or problems.

On Wed, Jun 23, 2010 at 8:00 PM, Yaron <email address hidden> wrote:

> Yeah, if we still didn't get any answer that would be a nice detour
>
> Can we make sure that the former translations will not get back to the
> distros whatsoever or we still need this bug to be resolved?
> Yaron Shahrabani
>
>
> On Wed, Jun 23, 2010 at 7:19 PM, Lior Kaplan <email address hidden> wrote:
>
> > Well, what about submitting the updated translation to Debian?
> >
> > I check for already reported bugs at
> > http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=synaptic and didn't
> find
> > anything.
> >
> > Kaplan
> >
> > On Fri, Jun 18, 2010 at 1:51 AM, Launchpad Bug Tracker <
> > <email address hidden>> wrote:
> >
> > > You have been subscribed to a public bug by Yaron (sh-yaron):
> > >
> > > The current Hebrew translation for Synaptic is really bad, it has many
> > > incorrect translated strings and quite a few typos.
> > > Please replace it with the attached translation ASAP.
> > >
> > > * Because of Yaron's comment saying that launchpad keeps loading an old
> > > and buggy translation for every new Ubuntu release even if it's fixed
> on
> > > an older one, we think that is would be better if the translation will
> > > be committed directly to the source.
> > >
> > > ** Affects: synaptic
> > > Importance: Undecided
> > > Assignee: Michael Vogt (mvo)
> > > Status: Confirmed
> > >
> > > ** Affects: synaptic (Ubuntu)
> > > Importance: Undecided
> > > Status: New
> > >
> > >
> > > ** Tags: i18n
> > > --
> > > New Hebrew translation
> > > https://bugs.edge.launchpad.net/bugs/587026
> > > You received this bug notification because you are a direct subscriber
> of
> > > the bug.
> > >
> >
> > --
> > New Hebrew translation
> > https://bugs.launchpad.net/bugs/587026
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
> --
> New Hebrew translation
> https://bugs.launchpad.net/bugs/587026
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Lior Kaplan (kaplan) wrote :

See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=586940 for the inclusion of the updated translation in Debian.

(before sending the file to debian I fixed some typos and mistakes, changes were sent back to Yaron)

Changed in synaptic (Debian):
status: Unknown → New
Yaron (sh-yaron) wrote :

The files we both sent are invalid, I updated from pot and fixed the mistakes (line 2014 in the Debian version had & instead of % so it won't compile), same for the current version (line 2032)...

Changed in synaptic (Debian):
status: New → Fix Released
Michael Vogt (mvo) on 2010-12-13
Changed in synaptic (Ubuntu):
status: New → Fix Released
Changed in synaptic:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.