Should run dpkg --configure -a automatically

Bug #19021 reported by Sven Herzberg on 2005-07-17
116
This bug affects 11 people
Affects Status Importance Assigned to Milestone
synaptic
New
Undecided
Unassigned
synaptic (Ubuntu)
Medium
Michael Vogt
Nominated for Lucid by Rajat Khanduja
Nominated for Maverick by Rajat Khanduja
Hardy
Medium
Michael Vogt
Intrepid
Medium
Michael Vogt

Bug Description

If an upgrade process failed it might help to run 'dpkg --configure -a'. As this
needs root priviliges (which require sudo - which is not mentioned in the
dialog), synaptic should run dpkg --configure -a automatically if necessary.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Synaptic will now run dpkg --configure -a automatically if it detects that it is needed (e.g. on failures during upgrade).

Cheers,
 Michael

Changed in synaptic:
status: Unconfirmed → Fix Committed
Michael Vogt (mvo) wrote :

This will be part of the next upload.

Changed in synaptic:
status: Fix Committed → Fix Released
joe (joerg-unglaub) wrote :

This feature got lost during edgy and now feisty

Please reimplement this.

Changed in synaptic:
status: Fix Released → Confirmed

Please reimplement it for Hardy !!

To prevent of a regression from a LTS to LTS ...

I agree this should be reimplement for Hardy. So I set the Milestone to hardy-alpha-4.

Changed in synaptic:
milestone: none → hardy-alpha-4
status: Confirmed → Triaged
Steve Langasek (vorlon) on 2008-02-01
Changed in synaptic:
milestone: hardy-alpha-4 → none
Alexander Sack (asac) wrote :

discussed this bug with mvo. This is now done by update-manager. fixing this in synaptic would mean a new feature and is unlikely to qualify for SRU. Steve, if you disagree reopen and milestone.

Changed in synaptic:
status: Triaged → Won't Fix
raystenson (raystenson09) wrote :

ok.. im sorta new to using ubuntu so yeah.. i have security updates and updates that i cant install because i get a message saying that i need to run 'dpkg --configure -a' manually.. but how do i do that?? and what is it?
If anyone can help me out that be great, thanks!

Necimal (necimal) wrote :

raystenson, try going Applications -> Accessories -> Terminal, then typing in "sudo dpkg --configure -a", press enter, then type your password (it won't show as you type), then enter again. After some screens of information scroll past the problem should be solved. :)

raystenson (raystenson09) wrote :

haha that was really easy... ill get a hang of this sooner or later lol.. thanks for your help! It worked flawlessly!!

So and why do I have to open that Terminal. The update-tools allready
requested your password to autherize the installation process. There are two
options for me. In Synaptic there should just be a message window informing
you that something went wrong last time and if synaptic should try to
correct the problem by pressing yes or close by pressing no. In the case of
the simple update for the normal user there should be no message just try to
correct the problem. Only inform the user if it could'nt be corrected.

So I reported that issue one and a half year ago. It was corrected in the
meantime and forgotten in the next version step. May be someone fixes that,
because Ubuntu is meant du be easy to use. Hacking on the Console
is not easy.

Thanks

2008/7/7, raystenson <email address hidden>:
>
> haha that was really easy... ill get a hang of this sooner or later
> lol.. thanks for your help! It worked flawlessly!!
>
> --
> Should run dpkg --configure -a automatically
> https://bugs.launchpad.net/bugs/19021
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Ian Weisser (ian-weisser) wrote :

This needs to be fixed in Synaptic for the following use case:

Brett is a new user, and has been directed to install sun-java-6 packages from Synaptic by a help.ubuntu.com page. He unknowingly interrupted an update a few days earlier by powering off his laptop incorrectly, and never saw an error message. He receives the error message and is stuck: The message is incorrect (doesn't include sudo), it tells him to do a command he doesn't know how to execute, and is in a technical vernacular that he is not familiar with. He gets conflicting advice from forums and wikis and becomes very frustrated.

Antoine Pairet (b-ly) wrote :

What is the status of this for intrepid?

Would be nice, not RC.

Laurence (l-d-anderson) wrote :

This has been mentioned in an article by PC Pro (one of the biggest computer magazines in the UK) on someone using Linux for the first time. Basically while installing automatic updates, the system crashed, then once it rebooted things didn't work properly until "sudo dpkg --configure -a" was run. Why can't this be run automatically during boot if needed? It would be much more user friendly!

Aha! You *can* untarget bugs from Intrepid

Changed in synaptic:
status: Triaged → Won't Fix
Laurence (l-d-anderson) wrote :

Still present in Kubuntu 9.04 - although KPackageKit doesn't even tell you how to fix it, just tells you there is a problem.

Laurence (l-d-anderson) wrote :

Additionally when you corrupt /var/lib/dpkg/status, /var/lib/dpkg/available it should restore them from the -old versions, and delete the stuff in /var/lib/dpkg/updates

tags: added: usability
Martin Albisetti (beuno) wrote :

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.
A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

Changed in hundredpapercuts:
status: New → Invalid

While this isn't a situation that happens often, it is certainly a bug that should be addressed. Any chance to get this in for Lucid?

Changed in synaptic (Ubuntu):
status: Triaged → Opinion
JaD Ferrer (jado92mx) wrote :

That sounds great, and looks very helpful and useful for beginers, wich
could have a problem with some packages, or maybe his machine suddenly
powers off during an upgrade, and needs to continue with the
installation process. Very good papercut!

Greetings,
JaD!

tags: added: amd64 precise
Chris Wilson (notgary) on 2013-02-11
no longer affects: hundredpapercuts
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.