Some fields in Properties window can't be selected

Bug #173464 reported by PetrB on 2007-12-02
4
Affects Status Importance Assigned to Milestone
synaptic
Confirmed
Undecided
Unassigned
synaptic (Ubuntu)
Low
Unassigned

Bug Description

1. Right-click on installed package name
2. Choose "Properties". Window appears
3. Try to select versions or priority, section.

What happens: the fields can not be select and therefore can not be copied to clipboard.
What should happen: the fields should be copyable.
(Some version numbers are long, retyping is error-prone and version numbers are vital for reporting bugs precisely.)

(I would report to upstream but the site google finds appears dead.)

Related branches

Jean-Philippe Fleury (jpfle) wrote :

I confirm this bug on Synaptic 0.62.1ubuntu10: some fields in the "Properties" window aren't selectable, but should be.

Changed in synaptic:
status: New → Confirmed
Jean-Philippe Fleury (jpfle) wrote :

At least, the version field can now be selected with Synaptic 0.62.5.

summary: - Some fields in Properties window
+ Some fields in Properties window can't be selected
Robert Roth (evfool) on 2012-02-16
Changed in synaptic:
assignee: nobody → Robert Roth (evfool)
Robert Roth (evfool) on 2012-02-16
Changed in synaptic (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: New → Confirmed
importance: Undecided → Low
Robert Roth (evfool) on 2012-02-17
Changed in synaptic (Ubuntu):
status: Confirmed → In Progress
Robert Roth (evfool) on 2012-07-13
Changed in synaptic (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.80~exp1

---------------
synaptic (0.80~exp1) experimental; urgency=low

  [ Robert Roth ]
  * * Disables typeahead in summary dialog, as it doesn't do anything,
    so it's unnecesary (LP: #24319)
  * Move up and Move down buttons in columns preferences changed to
    respect buttons_have_icons preference (LP: #66574)
  * Set the title of the package properties dialog opened for the first
    time (it has not been set before, so it was synaptic the first time
    the dialog has been opened) (LP: #932495)
  * Added a reload button to the repositories changed dialog (LP: #78987)
  * Updated the wording of the expander on the download progress dialog to
    Show individual files" instead of "Show for individual files"
    (LP: #301428)
  * Fixed inconsistencies between column namings in column headers and
    column visibility preferences (LP: #335723)
  * Linkified maintainer label in the package properties dialog
    when running as non-root (LP: #321380)
  * Added package name in the warning scaring you about breaking your
    system (LP: #63974)
  * Added name of the application (Synaptic Package Manager) in the
    titleless dialog shown when starting without administrative
    privilegess (LP: #510261)
  * Improved filter editing checkbox tooltips (LP: #790420)
  * Made all the property values from the package properties dialog
    selectable (LP: #173464)
  * Changed Package Properties accelerator from Ctrl+O to widely used
    (nautilus, eog, evince etc) Alt+Enter (LP: #933554)
  * Use the synaptic icon from the user's icon theme, or fall back to
    the old one if the current theme does not provide a synaptic icon
    (LP: #153755)
  * Focus the Apply button by default. (LP: #488718)
  * Removed log message from automatically installed item click
    (LP: #883984)
  * Fixed delete filter button not working caused by a typo in the
    name of the button when getting it from the GtkBuilder object
    (LP: #779756)
  * Added suggests tasksel as with tasksel installed synaptic
    provides additional functionality (LP: #605186)
  * Fixes incorrect radiobutton handling in the proxy preferences
    (LP: #706262)
  * Fixed incorrect status message when canceling 'Mark all available
    upgrades' feedback dialog (LP: #975578)

  [ Michael Vogt ]
  * ensure external helpers are runs as the user uid
  * build for gtk3 and update build-depends
  * move software-propoerties-gtk into suggests
  * strip strings properly in a markings file, thanks to
    Vassilis Palassopoulos (palasso)
  * show source package name in the details (closes: #692528)
  * merged lp:~fitoschido/synaptic/es-redundancy:
    - Remove empty es_ES .po files. Spanish translations are already
      provided in es files. Thanks to Adolfo Jayme Barrientos (fitoschido)
  * common/rpackagelister.cc:
    - add support for complete removal (purge) in the markings file

 -- Michael Vogt <email address hidden> Thu, 13 Dec 2012 10:08:37 +0100

Changed in synaptic (Ubuntu):
status: Fix Committed → Fix Released
Robert Roth (evfool) on 2018-02-04
Changed in synaptic:
assignee: Robert Roth (evfool) → nobody
Changed in synaptic (Ubuntu):
assignee: Robert Roth (evfool) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers