Synapse doesn't learn when files and directories are on the mix.

Bug #873857 reported by Pablo Piaggio on 2011-10-14
34
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Synapse
Medium
Unassigned

Bug Description

I've seen how Synapse 'learn'. For example, using several calls that start with 'v' and match VLC, will map 'v' to VLC:

    Ctrl+Space v ---> VirtualBox
    Ctrl+Space vl ---> VLC
    Ctrl+Space v ---> VirtualBox
    Ctrl+Space vl ---> VLC
    Ctrl+Space v ---> VLC ...Bingo!

However this behavior does not work the same when there are a match for both a file path and its root directory. Until recently I was able to open the directory '~/Downloads' like this:

    Ctrl+Space Downl ---> Download directoy

However I had the unfortunate choice to open a file on Downloads:

    Ctrl+Space file ---> Download/file.txt

Now Synapse got stuck on the file.

    Ctrl+Space Down ---> 'Download/file.txt'

I've tried to make it relearn by doing:

    Ctrl+Space Down ---> 'Download/file.txt' + (Down Arrow to Download directory) + Enter ---> Downloads/

But doesn't stick, even if I repite it several times. I've even tried many times:

    Ctrl+Space Down ---> 'Download/file.txt' + (Rigth Arrow to Places) + Enter ---> Downloads/

In short by opening a file inside a directory, I've lost the ability to gain access to the directory easily. It is SO bad that even this won't work:

    Ctrl+Space Downloads /----> 'Downloads/file.txt'

I would gladly provide more information and do some testing if requested.
Regards.

$ uname -a
Linux vaughan 2.6.32-34-generic-pae #77-Ubuntu SMP Tue Sep 13 21:16:18 UTC 2011 i686 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.3 LTS
Release: 10.04
Codename: lucid

$ apt-cache policy synapse
synapse:
  Installed: 0.2.8.1~bzr479~lucid1
  Candidate: 0.2.8.1~bzr479~lucid1
  Version table:
 *** 0.2.8.1~bzr479~lucid1 0
        500 http://ppa.launchpad.net/synapse-core/ppa/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Michal Hruby (mhr3) on 2012-03-18
Changed in synapse-project:
milestone: none → 0.3.0
importance: Undecided → Medium
status: New → Triaged
Changed in synapse-project:
milestone: 0.2.99.1 → 0.2.99.2
Sb (sb56637) wrote :

Additionally, I could add to this that Synapse doesn't learn from frequently used files until *after* restarting. For example, I have:

some-file-a.txt
some-file-b.txt
some-file-c.txt

When I type "some" It shows them in alphabetical order. But I select "some-file-c.txt", and later I repeat the same action several times more. But it never puts "some-file-c.txt" as the first suggestion until after I restart Synapse.

Jeremy Munsch (jeremy-munsch) wrote :

The OP issue seems to happen in Hybrid search I just cleaned zeitgeist data i believe:

relevancy for file:///home/kwaadpepper/T%C3%A9l%C3%A9chargements/images.png: 110000
relevancy for file:///home/kwaadpepper/Images: 70000

Jeremy Munsch (jeremy-munsch) wrote :

I would also add for the related file issue that synapse reloads app and uri popularity from Zeitgeist every
Timeout.add_seconds (60*30, refresh_popularity); so 30 minutes.

Changed in synapse-project:
milestone: 0.2.99.2 → 0.3.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers