does not remember choices

Bug #683371 reported by Patrick Ulbrich on 2010-11-30
136
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Synapse
Wishlist
Michal Hruby

Bug Description

Synapse looks great, but it does not seem to remember the most frequent choices like Do does.
Other than that, great release :-)

Changed in synapse-project:
importance: Undecided → Wishlist
Daniel Rodrigues (danyr) wrote :

This is really needed, I think, as it really speeds up the interaction with the launcher. Right now, with Do, I can get to any desired application just by hitting, maximum, three, four keys.

notrock (kicelo) wrote :

I noticed this also. In DO if I type 'P' or 'PPA' on a fresh install I can get to symantec package manager , in Synapse 'P' just shows all my applications that begin with the letter P

Alberto Aldegheri (albyrock87) wrote :

This feature will be implemented as soon as possible :)

Michal Hruby (mhr3) on 2010-12-01
Changed in synapse-project:
status: New → Confirmed
Michal Hruby (mhr3) on 2010-12-05
Changed in synapse-project:
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 0.2.2
status: Confirmed → Triaged
Nikke (nmellegard) wrote :

Hi

I've hacked together a very rudimentary "popularity tracker". It "votes" on an item each time it is executed by Synapse.

The patch:
- adds a class to interface with a Sqlite3-database (in which the item and its votes are stored).
- hooks into common-actions::Action.execute to throw a vote on the Match
- hooks into data-sink::DataSink.search to adjust the relevancy of an item based on its number of "votes" (though, this is most likely not the proper way to do it, as it doesn't seem to work...)

It's perhaps a start?

Cheers
/N

Nikke (nmellegard) wrote :

I should add that the above patch is based on rev 226...

/N

Nikke (nmellegard) wrote :

(bzr noob)
Forgot to add a file...

Michal Hruby (mhr3) wrote :

@Nikke, thanks for the patch, I pushed some first stubs of RelevancyService in r227, so it'll be probably better to wait a bit until that interface is usable and hooked up. For now it will use Zeitgeist as the backend service, but perhaps we could use sqlite if ZG is not available (though imo sqlite might be a bit of an overkill for this).

Nikke (nmellegard) wrote :

@Michal
I checked this page on Saturday and noticed no activity, so I figured that I'd try to get the ball rolling.
Turns out I wasn't alone :)

All the best
/N

Michal Hruby (mhr3) on 2010-12-06
Changed in synapse-project:
status: Triaged → Fix Committed
SB (sonny-benshimon) wrote :

why not use zeitgeist to track most frequently used applications? I think this will be a better integration than the patch suggested.
It will probably require more work for the integration, but that way synapse can become the best frontend for zeitgeist. I mean the "instant access" of synapse and the zeitgesit backend, can be a killer feature not only to access applications, but to access documents, contacts, URLs etc.

Changed in synapse-project:
status: Fix Committed → In Progress
Changed in synapse-project:
status: In Progress → Fix Committed
Michal Hruby (mhr3) on 2010-12-13
Changed in synapse-project:
status: Fix Committed → Fix Released
Oren_B (oren.barnea) wrote :

Is it possible that there was a regression on this bug in version 0.2.6? This is the first version of Synapse I'm using and it doesn't seem to remember that I use Firefox *much* more often than F-spot.
Anyone else experiencing this problem?

Alberto Aldegheri (albyrock87) wrote :

Just to know, what are you searching for? only "F" ?

I mean, we still have a "Relevancy" that tries to push Firefox in the first position,
but "F" it's a better match for "F Spot" then for "Firefox",
because "F Spot" has a complete word that is exactly "F".

Anyway, this can be improved, and we are working on better matching algorithms.
But well, the bug is fixed, because Synapse does have a relevancy service based on your choices.

Oren_B (oren.barnea) wrote :

Sorry I missed your answer until now, Alberto.

When I only type "f", f-spot is shown, when I add the "i" everything works as I would expect it to.
I understand your answer, and I agree that the specific case of F-spot and Firefox F-spot is a kind of unique. However, I think that the fact that I open Firefox very often and f-spot very rarely should override the fact that "f-spot" is a better match for "f" than "Firefox". Please consider this when working on the improved matching algorithms. If this issue is not resolved, I will have to uninstall F-spot :D

Thanks for your work on Synapse, it's fantastic.

Mik Wind (evilpollo) wrote :

I'm not sure how the algorithm works, but for me it applies relevancy for some things and doesn't for others...

I type "st" -> startup aplications
launch steam 15 times...
"st" -> steam
it works.

However, it doesn't seem to matter how many times I type them, shut down , suspend, and restart, don't become more relevant:

"sh" -> desktop sharing (never used it)
"su" ->sudoku (never used it,)
 "re" -> remote desktop client (also never used)

Is there a way of editting the relevancy list directly?, I wouln't mind having the option to force some comands to the top xD
I'd be glad to help improving the algorithms, but have absolutely no idea when it comes to programming in Vala

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers