ssh-plugin fails to find terminal application

Bug #1080755 reported by Gondlar on 2012-11-19
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Synapse
Undecided
Jeremy Munsch

Bug Description

When I try to launch a ssh session in synaptic, nothing is started and I get the following output if i started synapse from a terminal:

[14:52:03.507548 GLib-GIO-Warning] couldn't find a terminal, falling back to xterm
[14:52:03.512454 Warning] ssh-plugin.vala:189: Kindprozess »xterm« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)

So synapse fails to get the terminal configured in the system preferences, falls back to xterm (which is not installed) and fails finding it.

I am running a minimal installation of XFCE (with the default terminal application replaced by roxterm) on archlinux. I did configure that change in the XFCE settings and starting a terminal explicitly by typing "Terminal" works fine.

Related branches

Jeremy Munsch (jeremy-munsch) wrote :

This is old but still here, only workaround found
1- making a symlink
2 - making a bash script wrapper to add stuff you want (nicer)
#!/bin/sh
arg=""
for var in "$@";do
    arg="$arg $var"
done
terminator --new-tab $arg

Changed in synapse-project:
assignee: nobody → Jeremy Munsch (jeremy-munsch)
Changed in synapse-project:
milestone: none → 0.2.99.3
Changed in synapse-project:
status: New → In Progress
Changed in synapse-project:
status: In Progress → Fix Committed
Changed in synapse-project:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions