Use Gtk.Image from icon name instead of from Pixbuf

Bug #1469908 reported by Daniel Fore on 2015-06-29
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
Medium
Daniel Fore
Noise
Fix Released
Medium
Unassigned
Slingshot
Fix Released
Medium
Corentin Noël
Switchboard
Fix Released
Medium
Daniel Fore

Bug Description

We've discovered that most of the problems with HiDPI icon support are due to the use of Gdk.Pixbuf instead of Gtk.Image

Related branches

Daniel Fore (danrabbit) on 2015-06-30
Changed in pantheon-files:
milestone: none → loki-beta1
Changed in noise:
milestone: none → loki-beta1
Changed in pantheon-photos:
milestone: none → loki-beta1
Changed in slingshot:
milestone: none → loki-beta1
status: New → Confirmed
Daniel Fore (danrabbit) wrote :

Most of the apps affected have issues in the sidebar or welcome screens. An easy way to test on LowDPI displays is to inspect a gtk.image with gtkinspector and look at its properties. If the "icon name" field is "null" and the "pixbuf" field has something in it, you're probably not okay.

Changed in noise:
status: New → Fix Committed
summary: - Use Gtk.Image instead of Gdk.Pixbuf
+ Use Gtk.Image from icon name instead of from Pixbuf
Changed in pantheon-files:
status: New → Confirmed
importance: Undecided → Medium
yEdubart (vps1992) on 2015-08-14
Changed in pantheon-photos:
status: New → Confirmed
Daniel Fore (danrabbit) on 2015-08-19
Changed in noise:
milestone: loki-beta1 → freya-0.3.1
Cody Garver (codygarver) on 2015-09-01
Changed in noise:
milestone: freya-0.3.1 → loki-beta1
Cody Garver (codygarver) on 2015-09-16
Changed in switchboard:
importance: Undecided → Medium
Changed in slingshot:
importance: Undecided → Medium
Changed in pantheon-photos:
importance: Undecided → Medium
Changed in noise:
importance: Undecided → Medium
Daniel Fore (danrabbit) on 2015-10-22
Changed in pantheon-files:
milestone: loki-beta1 → loki-alpha1
Changed in noise:
milestone: loki-beta1 → loki-alpha1
Changed in pantheon-files:
milestone: loki-alpha1 → loki-beta1
Daniel Fore (danrabbit) on 2015-12-22
Changed in slingshot:
status: Confirmed → In Progress
Cody Garver (codygarver) on 2015-12-23
Changed in slingshot:
assignee: nobody → Corentin Noël (tintou)
milestone: loki-beta1 → loki-alpha1
status: In Progress → Fix Committed
Marvin Beckers (embik) wrote :

Some relevant code to change for Switchboard is here: https://bazaar.launchpad.net/~elementary-pantheon/switchboard/switchboard/view/head:/src/CategoryView.vala#L255

Introducing Gtk.Image here would most likely add the benefit of third-party plugs installing their custom icons correctly. As of yet, Switchboard doesn't recognize icons installed to /usr/share/icons/hicolor (which is the proper location for custom icons) and third-party plugs have to install to /usr/share/icons/elementary. Which they really shouldn't because they're not part of the elementary-icons package.

Is this worth an additional bug attached to Switchboard?

Daniel Fore (danrabbit) on 2016-04-17
Changed in pantheon-files:
status: Confirmed → In Progress
assignee: nobody → Daniel Fore (danrabbit)
RabbitBot (rabbitbot-a) on 2016-04-18
Changed in pantheon-files:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2016-04-27
Changed in switchboard:
milestone: loki-beta1 → none
Changed in pantheon-photos:
milestone: loki-beta1 → none
Daniel Fore (danrabbit) on 2016-05-12
Changed in switchboard:
status: Confirmed → In Progress
assignee: nobody → Daniel Fore (danrabbit)
Daniel Fore (danrabbit) on 2016-06-07
no longer affects: pantheon-photos
Daniel Fore (danrabbit) on 2016-07-02
Changed in switchboard:
status: In Progress → Fix Committed
milestone: none → loki-rc1
Daniel Fore (danrabbit) on 2016-08-10
Changed in noise:
status: Fix Committed → Fix Released
Daniel Fore (danrabbit) on 2016-08-10
Changed in switchboard:
milestone: loki-beta2 → 2.1.0
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2016-08-14
Changed in slingshot:
status: Fix Committed → Fix Released
Daniel Fore (danrabbit) on 2016-08-15
Changed in pantheon-files:
status: Fix Committed → Fix Released
milestone: loki-beta1 → 0.3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints