Needs minimum size

Bug #1081310 reported by Sam Tate
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Switchboard
Fix Released
Medium
David Gomes

Bug Description

You can resize the Switchboard window and maximise it. This means that things can look really ugly when there is a hell of a lot of padding going on (See attachment).

There should be a set size for Switchboard that is just the right size, and that is what all the plugs are designed around.

Fixing this bug would also fix bug 1081313

Revision history for this message
Sam Tate (samtatr) wrote :
description: updated
Revision history for this message
Cody Garver (codygarver) wrote :

Ugh, we just made it resizable! I think it had design team permission.

Changed in switchboard:
assignee: nobody → elementary UX Team (elementary-design)
Revision history for this message
Jaap Broekhuizen (jaapz-b) wrote :

I think this is more of a feature than it is a bug. Problem is that some plugs don't resize well yet, so that should be fixed. But i think switchboard should remain resizable.

Revision history for this message
Jaap Broekhuizen (jaapz-b) wrote :

I think we do need a minimum size though, because you can now resize switchboard to be something like 30x30, with nothing visible anymore...

Cody Garver (codygarver)
summary: - Switchboard is resizable
+ Needs minimum size
Changed in switchboard:
milestone: none → luna-beta2
Revision history for this message
Danielle Foré (danrabbit) wrote :

I have to agree that Switchboard needs a minimum size. But also that it looks really weird maximized. I wonder why we made it resizeable?

Is it possible for Switchboard to have a set width and expand vertically if 1. it's necessary and 2. the display is tall enough to allow it?

Cody Garver (codygarver)
Changed in switchboard:
status: New → Confirmed
importance: Undecided → Medium
assignee: elementary UX Team (elementary-design) → nobody
Revision history for this message
Jaap Broekhuizen (jaapz-b) wrote :

What would happen if you for example have a drectory with a lot of wallpapers? In other words: can certain parts of plugs still be scrollable? I don't think you would want the switchboard window to resize when selecting the wallpaper plug.

Revision history for this message
Danielle Foré (danrabbit) wrote :

Jaap,

Yea I guess we might want a maximum vertical size as well. I would assume we'd want to remain vertically scrollable.

Patrick Pace (pqp)
Changed in switchboard:
assignee: nobody → Patrick Pace (pqp)
status: Confirmed → In Progress
Patrick Pace (pqp)
Changed in switchboard:
status: In Progress → Confirmed
assignee: Patrick Pace (pqp) → nobody
David Gomes (davidgomes)
Changed in switchboard:
assignee: nobody → David Gomes (davidgomes)
status: Confirmed → In Progress
Cody Garver (codygarver)
Changed in switchboard:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers