Switchboard segaults on startup on 12.10

Bug #1050508 reported by Roland (Rolandixor) Taylor on 2012-09-13
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Switchboard
Fix Released
High
Tom Beckmann

Bug Description

When I try to launch from the Launcher nothing happens, so I tried the commandline and found it segfaults on startup. This happens on two systems (both run 12.10).

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: switchboard 0.9-0~r304+pkg13~quantal1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
CrashDB: switchboard
Date: Thu Sep 13 11:56:58 2012
ProcEnviron:
 LANGUAGE=en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: switchboard
UpgradeStatus: Upgraded to quantal on 2010-01-19 (967 days ago)

greggory.hz (greggory-hz) wrote :

I can confirm this issue as well. This happens from both the daily ppa and from source. This is the exact error I get:

[_LOG_LEVEL_FATAL 09:21:06.572128] [GLib-GIO] g_application_list_actions: assertion `application->priv->is_registered' failed
[_LOG_LEVEL_FATAL 09:21:06.572165] Switchboard will not function properly.
Segmentation fault (core dumped)

And then a stack trace from GDB:

#0 0x00007ffff74ec3e8 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#1 0x00007ffff7765144 in gtk_window_set_application () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#2 0x0000000000406da5 in switchboard_switchboard_app_construct ()
#3 0x0000000000407b22 in switchboard_switchboard_app_new ()
#4 0x000000000040e955 in switchboard_main ()
#5 0x000000000040eaa3 in main ()

I don't know how to enable debugging in elementary apps, so there's no symbol table. I'd be willing to add that if I get some guidance on how to turn it on, or perhaps there is another method for debugging vala apps .... :)

greggory.hz (greggory-hz) wrote :

Here's a slightly better trace:

#0 g_action_muxer_insert (muxer=0x6fbea0, prefix=0x7ffff77c123d "app", action_group=0xb50160)
    at /build/buildd/gtk+3.0-3.5.18/./gtk/gactionmuxer.c:645
#1 0x00007ffff7765144 in gtk_window_set_application (window=0x90a040, application=0xb50160)
    at /build/buildd/gtk+3.0-3.5.18/./gtk/gtkwindow.c:2849
#2 0x0000000000406da5 in switchboard_switchboard_app_construct ()
#3 0x0000000000407b22 in switchboard_switchboard_app_new ()
#4 0x000000000040e955 in switchboard_main ()
#5 0x000000000040eaa3 in main ()

Jerome (romjerome) wrote :

I get the same problem.

Maybe you can close my duplicated bug report?
https://bugs.launchpad.net/elementaryos/+bug/1064975

Is this bug even being looked at?
lol

On Sun, Oct 14, 2012 at 4:17 AM, Jerome <email address hidden> wrote:

> I get the same problem.
>
> Maybe you can close my duplicated bug report?
> https://bugs.launchpad.net/elementaryos/+bug/1064975
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1050508
>
> Title:
> Switchboard segaults on startup.
>
> Status in Switchboard System Settings:
> New
>
> Bug description:
> When I try to launch from the Launcher nothing happens, so I tried the
> commandline and found it segfaults on startup. This happens on two
> systems (both run 12.10).
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: switchboard 0.9-0~r304+pkg13~quantal1 [origin:
> LP-PPA-elementary-os-daily]
> ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
> Uname: Linux 3.5.0-14-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.5.1-0ubuntu7
> Architecture: amd64
> CrashDB: switchboard
> Date: Thu Sep 13 11:56:58 2012
> ProcEnviron:
> LANGUAGE=en
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: switchboard
> UpgradeStatus: Upgraded to quantal on 2010-01-19 (967 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/switchboard/+bug/1050508/+subscriptions
>

Cody Garver (codygarver) on 2012-10-14
summary: - Switchboard segaults on startup.
+ Switchboard segaults on startup on 12.10
Changed in switchboard:
status: New → Confirmed
importance: Undecided → High
Cody Garver (codygarver) on 2012-10-14
Changed in switchboard:
status: Confirmed → In Progress
assignee: nobody → Tom Beckmann (tombeckmann)
Jerome (romjerome) wrote :

> "Switchboard segaults on startup on 12.10"

Sorry, but it also occurs under ElementaryOS (beta), based on precise pangolin (12.04)...
https://bugs.launchpad.net/elementaryos/+bug/1064975

BTW if you guys need any help with getting more info or doing testing, let
me know.

On Sun, Oct 14, 2012 at 9:43 AM, Jerome <email address hidden> wrote:

> > "Switchboard segaults on startup on 12.10"
>
> Sorry, but it also occurs under ElementaryOS (beta), based on precise
> pangolin (12.04)...
> https://bugs.launchpad.net/elementaryos/+bug/1064975
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1050508
>
> Title:
> Switchboard segaults on startup on 12.10
>
> Status in Switchboard System Settings:
> In Progress
>
> Bug description:
> When I try to launch from the Launcher nothing happens, so I tried the
> commandline and found it segfaults on startup. This happens on two
> systems (both run 12.10).
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: switchboard 0.9-0~r304+pkg13~quantal1 [origin:
> LP-PPA-elementary-os-daily]
> ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
> Uname: Linux 3.5.0-14-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.5.1-0ubuntu7
> Architecture: amd64
> CrashDB: switchboard
> Date: Thu Sep 13 11:56:58 2012
> ProcEnviron:
> LANGUAGE=en
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: switchboard
> UpgradeStatus: Upgraded to quantal on 2010-01-19 (967 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/switchboard/+bug/1050508/+subscriptions
>

Tom Beckmann (tombeckmann) wrote :

Yep, it would be great if you could test if lp:~tombeckmann/switchboard/quantal-crash works.

I'm getting Cmake issues when trying to build.

Seems it's not finding vala.

On Thu, Oct 18, 2012 at 1:30 AM, Tom Beckmann <email address hidden>wrote:

> Yep, it would be great if you could test if lp:~tombeckmann/switchboard
> /quantal-crash works.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1050508
>
> Title:
> Switchboard segaults on startup on 12.10
>
> Status in Switchboard System Settings:
> In Progress
>
> Bug description:
> When I try to launch from the Launcher nothing happens, so I tried the
> commandline and found it segfaults on startup. This happens on two
> systems (both run 12.10).
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: switchboard 0.9-0~r304+pkg13~quantal1 [origin:
> LP-PPA-elementary-os-daily]
> ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
> Uname: Linux 3.5.0-14-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.5.1-0ubuntu7
> Architecture: amd64
> CrashDB: switchboard
> Date: Thu Sep 13 11:56:58 2012
> ProcEnviron:
> LANGUAGE=en
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: switchboard
> UpgradeStatus: Upgraded to quantal on 2010-01-19 (967 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/switchboard/+bug/1050508/+subscriptions
>

Fixed. It was a problem with the included build instructions.

On Sat, Oct 20, 2012 at 10:30 PM, Roland Taylor <email address hidden>wrote:

> I'm getting Cmake issues when trying to build.
>
> Seems it's not finding vala.
>
>
> On Thu, Oct 18, 2012 at 1:30 AM, Tom Beckmann <email address hidden>wrote:
>
>> Yep, it would be great if you could test if lp:~tombeckmann/switchboard
>> /quantal-crash works.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1050508
>>
>> Title:
>> Switchboard segaults on startup on 12.10
>>
>> Status in Switchboard System Settings:
>> In Progress
>>
>> Bug description:
>> When I try to launch from the Launcher nothing happens, so I tried the
>> commandline and found it segfaults on startup. This happens on two
>> systems (both run 12.10).
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 12.10
>> Package: switchboard 0.9-0~r304+pkg13~quantal1 [origin:
>> LP-PPA-elementary-os-daily]
>> ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
>> Uname: Linux 3.5.0-14-generic x86_64
>> NonfreeKernelModules: nvidia
>> ApportVersion: 2.5.1-0ubuntu7
>> Architecture: amd64
>> CrashDB: switchboard
>> Date: Thu Sep 13 11:56:58 2012
>> ProcEnviron:
>> LANGUAGE=en
>> TERM=xterm
>> PATH=(custom, no user)
>> LANG=en_US.UTF-8
>> SHELL=/bin/bash
>> SourcePackage: switchboard
>> UpgradeStatus: Upgraded to quantal on 2010-01-19 (967 days ago)
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/switchboard/+bug/1050508/+subscriptions
>>
>
>

(Sorry for all the replies). I just built it from that branch and it works
so far.

On Sat, Oct 20, 2012 at 10:33 PM, Roland Taylor <email address hidden>wrote:

> Fixed. It was a problem with the included build instructions.
>
>
> On Sat, Oct 20, 2012 at 10:30 PM, Roland Taylor <email address hidden>wrote:
>
>> I'm getting Cmake issues when trying to build.
>>
>> Seems it's not finding vala.
>>
>>
>> On Thu, Oct 18, 2012 at 1:30 AM, Tom Beckmann <email address hidden>wrote:
>>
>>> Yep, it would be great if you could test if lp:~tombeckmann/switchboard
>>> /quantal-crash works.
>>>
>>> --
>>> You received this bug notification because you are subscribed to the bug
>>> report.
>>> https://bugs.launchpad.net/bugs/1050508
>>>
>>> Title:
>>> Switchboard segaults on startup on 12.10
>>>
>>> Status in Switchboard System Settings:
>>> In Progress
>>>
>>> Bug description:
>>> When I try to launch from the Launcher nothing happens, so I tried the
>>> commandline and found it segfaults on startup. This happens on two
>>> systems (both run 12.10).
>>>
>>> ProblemType: Bug
>>> DistroRelease: Ubuntu 12.10
>>> Package: switchboard 0.9-0~r304+pkg13~quantal1 [origin:
>>> LP-PPA-elementary-os-daily]
>>> ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
>>> Uname: Linux 3.5.0-14-generic x86_64
>>> NonfreeKernelModules: nvidia
>>> ApportVersion: 2.5.1-0ubuntu7
>>> Architecture: amd64
>>> CrashDB: switchboard
>>> Date: Thu Sep 13 11:56:58 2012
>>> ProcEnviron:
>>> LANGUAGE=en
>>> TERM=xterm
>>> PATH=(custom, no user)
>>> LANG=en_US.UTF-8
>>> SHELL=/bin/bash
>>> SourcePackage: switchboard
>>> UpgradeStatus: Upgraded to quantal on 2010-01-19 (967 days ago)
>>>
>>> To manage notifications about this bug go to:
>>> https://bugs.launchpad.net/switchboard/+bug/1050508/+subscriptions
>>>
>>
>>
>

Cody Garver (codygarver) on 2012-10-28
Changed in switchboard:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers