Guest account can't be disabled via Settings

Bug #1425769 reported by Jared Schwartz on 2015-02-26
80
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Switchboard User Accounts Plug
Fix Released
Critical
Rico Tzschichholz

Bug Description

The option in the system settings to disable the guest account is not working properly.
After clicking unlock, entering my root password, unticking the 'guest account' option, and rebooting, I am faced with the guest account on the login screen and the guest account tick once again enabled in the settings.

Related branches

Daniel Fore (danrabbit) on 2015-02-26
affects: elementaryos → switchboard-plug-useraccounts
Marvin Beckers (embik) wrote :

This does not sound like the native useraccounts plug. What version of elementary OS are you running? Freya or Luna? If Freya, is your system fully up-to-date?

Marvin Beckers (embik) wrote :

Oh, I'm sorry, I misread your bug description, so nevermind my previous comment. Nonetheless I cannot reproduce this on my system, it is working properly over here.

Did you create any files in /usr/share/lightdm/lightdm.conf.d/? Is there a file called "60-guest-session.conf"?

Marvin Beckers (embik) on 2015-03-01
Changed in switchboard-plug-useraccounts:
status: New → Incomplete
Marvin Beckers (embik) on 2015-03-01
Changed in switchboard-plug-useraccounts:
importance: Undecided → High
Jared Schwartz (jschwartz3205) wrote :

This past week has been very busy, so sorry for the late response. I had not upgraded my system at the time of reporting the bug. I have since upgraded the system and can report that it still applies. I am running Freya Beta 2. I have not added anything to /usr/share/lightdm/lightdm.conf.d/ and there is no 60-guest-session.conf file in that directory. The setting reverts after closing switchboard. I originally thought that that might be because it had not rebooted, but this might be the actual root of the issue. I will try a fresh install and upgrade tonight and see if it is just an anomaly.

Marvin Beckers (embik) wrote :

Okay, a short notice about the bug's state on a fresh install would be great :)

Adolfo Jayme (fitojb) on 2015-03-24
Changed in switchboard-plug-useraccounts:
status: Incomplete → Confirmed
Martin Edwards (martinedwards) wrote :

Hi, please forgive me I am new to this (first post) but I thought I would add that I am experiencing this bug with a fresh install of Freya (64bit).

Marvin Beckers (embik) on 2015-04-13
Changed in switchboard-plug-useraccounts:
status: Confirmed → In Progress
assignee: nobody → Marvin Beckers (embik)
importance: High → Critical
AB (arturas-baranauskas) wrote :

The same bug affects my Freya installation.

Matheus (mths-ss-w) wrote :

The same here.

Cody Garver (codygarver) on 2015-04-15
Changed in switchboard-plug-useraccounts:
milestone: none → freya-0.3.1
Cody Garver (codygarver) on 2015-04-15
Changed in switchboard-plug-useraccounts:
assignee: Marvin Beckers (embik) → Rico Tzschichholz (ricotz)
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers