Apps aren't removed when they're uninstalled

Bug #1406799 reported by Daniel Fore on 2014-12-31
66
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Switchboard Notifications Plug
Fix Released
Medium
Marcus Wichelmann

Bug Description

This is probably a consequence of our discovery method, but it seems there's not a mechanism to detect that an app has been uninstalled

Related branches

Marcus Wichelmann (l-admin-3) wrote :

That's right. The problem is, that we couldn't compare the list of installed apps with the list of the recognized one, because the application-ids and the notification-ids are different. As long as that's so inconsistent such a feature would cause many problems...

Daniel Fore (danrabbit) wrote :

Indeed. So it sounds like we need to be using the .desktop entry to discover apps. In that way, we have a theoretically up-to-date list of installed apps that send notifications. We just have to make sure all our default apps are using this key and hope that 3rd party apps do the right thing.

Marcus Wichelmann (l-admin-3) wrote :

So any compatible app should (1) use the X-GNOME-UsesNotifications=true key in it's .desktop-file and (2) should register itself using the same name as set in the .desktop-file on the notifications-server. And if gala couldn't assign a .deskop-file with the specific key to a registered app it should ignore all settings and just show the notification...?

Changed in switchboard-plug-notifications:
status: New → Confirmed
importance: Undecided → Medium
Daniel Fore (danrabbit) wrote :

yes, I think that is probably the best way we can make sure that we have an accurate list of installed apps

Julian (julian-pe) wrote :

Same problem.
But Spotify does strange things, too :-(

Daniel Fore (danrabbit) on 2015-06-12
Changed in switchboard-plug-notifications:
milestone: none → loki-beta1
Changed in switchboard-plug-notifications:
status: Confirmed → In Progress
assignee: nobody → Marcus Wichelmann (l-admin-3)
TC (smalltimer) wrote :

Also, there are multiple entries for some apps! I installed R-studio and there are 5 entries for the same app. There is also an entry titled 'unknown'. I submitted a bug, but I think this report pretty much addresses the main problem.

Marcus Wichelmann (l-admin-3) wrote :

You're right, the reason for the bug is the same. Mostly this is caused by a problem with the code of these third-party apps, but anyway, Im working on making this behaviour better with the new-backend branch on top.

Cody Garver (codygarver) on 2015-10-21
Changed in switchboard-plug-notifications:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2015-10-22
Changed in switchboard-plug-notifications:
milestone: loki-beta1 → loki-alpha1
Scard (scard) wrote :

Does someone know where we can remove these old apps by hand?

Cody Garver (codygarver) on 2016-08-11
Changed in switchboard-plug-notifications:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers