Socks Proxy Not Available Unless All Proxy Types Enabled

Bug #1652208 reported by Jack Desert on 2016-12-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Switchboard Network Plug
Fix Released
Medium
Adam Bieńkowski

Bug Description

Network Settings => Select Proxy tab => Select "Manual Configuration"

Fill in your hostname and port number for "Socks Proxy"

At this point it is clearly broken. It will not let you click "Apply" unless you first fill out host names for an http proxy, an https proxy, and an ftp proxy.

Note that if you put in fake values for http proxy, https proxy, and ftp proxy, it will try to use those fake values as actual proxies instead of using the Socks Proxy that you had intended. Which has the unintended side effect that the Chrome browser, will not load any web pages at all.

Elementary Loki
Note: this worked fine when I first installed Loki, but one of the updates broke it later.

Related branches

Changed in elementaryos:
status: New → Confirmed
assignee: nobody → Adam Bieńkowski (donadigo)
status: Confirmed → In Progress
affects: elementaryos → switchboard-plug-networking
Changed in switchboard-plug-networking:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2016-12-23
Changed in switchboard-plug-networking:
milestone: none → juno-beta1
Cody Garver (codygarver) on 2017-09-15
Changed in switchboard-plug-networking:
importance: Undecided → Medium
milestone: juno-beta1 → 0.1.1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers