Crashes because left-handed key no longer exists

Bug #1495808 reported by Cody Garver on 2015-09-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Switchboard Mouse & Touchpad Plug
Fix Released
Critical
Unassigned

Bug Description

Crashes on launch on Ubuntu Wily

Settings schema 'org.gnome.settings-daemon.peripherals.mouse' does not contain a key named 'left-handed'

Daniel Fore (danrabbit) wrote :

Okay, so this is a bit over my head. The problem is that the keys were split up. So half of them are at "org.gnome.desktop.peripherals" and the other half are still at "org.gnome.settings-daemon.peripherals"

I'm unsure how to fix the bindings/classes/etc in this way

Daniel Fore (danrabbit) on 2015-10-22
Changed in switchboard-plug-mouse-touchpad:
milestone: loki-beta1 → loki-alpha1
Changed in switchboard-plug-mouse-touchpad:
status: Confirmed → Fix Committed
Maxime Gauduin (alucryd) wrote :

The keys appear to have hanged again. Trying this with GNOME 3.20 returns:

[GLib-GIO] Settings schema 'org.gnome.settings-daemon.peripherals.mouse' does not contain a key named 'left-handed'

Cody Garver (codygarver) on 2016-08-12
Changed in switchboard-plug-mouse-touchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers